guest_1
Posts: 7
Joined: Thu Feb 20, 2014 10:09 am

Help with florence, keys and captions stay black

Thu Feb 20, 2014 10:39 am

Hi there,

since I wanted to upgrade my Linux knowledge I choose to start a Pi-Project. I installed Raspbian Wheezy latest and florence (virtual keyboard) with:

Code: Select all

sudo apt-get update
sudo apt-get install florence
since I plan to disconnect the hardware keyboard and mouse in the future and just use the touchscreen.
After the installation of florence I tried several things in it's GUI-settings but some key captions stay in black on a black key, here is a picture of that, please excuse the reflection of the photo and the harsh JPG-Compression. The picture shows a fresh and clean installed florence without any setting changes.
Image
Does anybody know how to fix that? Couldn't find any fix for that on google or the developers website. Could this problem be caused by some Gnome stuff that is missing on LXDE and Raspbian?

thx for reading
Regard a guest_1

guest_1
Posts: 7
Joined: Thu Feb 20, 2014 10:09 am

Re: Help with florence, keys and captions stay black

Mon Feb 24, 2014 8:37 pm

Has anybody an idea which could lead to solve this issue?

msmithy12
Posts: 94
Joined: Fri Aug 10, 2012 8:57 am

Re: Help with florence, keys and captions stay black

Tue Mar 11, 2014 2:41 pm

Hi, just install Florence this morning, and got the same issue. So I

Code: Select all

sudo apt-get remove florence
then i downloaded the .tar.bz2 file from a Google search (source forge i think)

then I

Code: Select all

tar xjf florence-0.6.0.tar.bz2
cd florence-0.6.0
sudo ./configure --prefix=/usr
sudo make
sudo make install
and jobs a good 'un.

Next I want to add the keyboard as an applet to a taskbar but im still working on that.

Anyways Enjoy and have fun!
I assume I know what I`m talking about... I probably don`t

Home: 256mb Made in UK, Rasbmc, 40" Sony Bravia KDL-40v3000
Work: 2b+, Rasbian, 6" Lilliput touchscreen

guest_1
Posts: 7
Joined: Thu Feb 20, 2014 10:09 am

Re: Help with florence, keys and captions stay black

Wed Mar 12, 2014 10:00 am

Hi,

thank you msmithy12 I will try your way today. Meanwhile I got an answer from François Agrech the developer of florence, along with the request to post it here.
You are affected by this Debian bug:
https://bugs.debian.org/cgi-bin/bugrepo ... bug=704962
This bug has been fixed in Debian experimental but they can not
release it in stable due to their release policy (see the bug report).
The stable Debian package of Florence is outdated and conflicts with
the newer librsvg library. I'm afraid I can not do anything about the
package that is currently in Debian stable.
Your options are:
* Use the package from Debian experimental.
* Compile a newer Florence version from source.
* Use an alternative onscreen keyboard (like xvkbd, onboard or Caribou)

I hope this helps, please do not hesitate to contact me again if there
is anything I can do to help you.
I would appreciate if you could please post something in the
raspberrypi forum's thread to direct people to the debian bug I
linked. That could help some people.

guest_1
Posts: 7
Joined: Thu Feb 20, 2014 10:09 am

Re: Help with florence, keys and captions stay black

Wed Mar 12, 2014 1:44 pm

Update, I tried the way msmithy12 pointed out, but I got stuck and need help.
On the step:

Code: Select all

sudo ./configure --prefix=/usr
I get the error

Code: Select all

configure: error: gtk version 3.0 or superior required. Please install the dev package of gtk
prior I installed:

Code: Select all

sudo apt-get install build-essential libxml2-dev libgconf2-dev
sudo apt-get install libglade2-dev libatspi-dev libcairo2-dev gnome-doc-utils librsvg2-dev gettext
sudo apt-get install libnotify-dev libxtst-dev intltool libgnome-desktop-dev  libgstreamer0.10-dev
sudo apt-get install libgtk-3-0
sudo apt-get install gtk+3.0
I don`t understand the error because I installed GTK+3.0, what am I doing wrong?

msmithy12
Posts: 94
Joined: Fri Aug 10, 2012 8:57 am

Re: Help with florence, keys and captions stay black

Wed Mar 19, 2014 1:47 pm

hi try doing

Code: Select all

sudo apt-get install gtk3-dev
then follow my florence instructions

Thanks

(sorry i only just replied i unticked the 'Notify me when a reply is posted')

I will be much quicker with a fix next time
I assume I know what I`m talking about... I probably don`t

Home: 256mb Made in UK, Rasbmc, 40" Sony Bravia KDL-40v3000
Work: 2b+, Rasbian, 6" Lilliput touchscreen

guest_1
Posts: 7
Joined: Thu Feb 20, 2014 10:09 am

Re: Help with florence, keys and captions stay black

Fri Mar 21, 2014 7:19 pm

Sry my Raspbian can't find the package gtk3-dev with apt-get, so I installed libgtk-3-dev.

Compile and Install went well. Florence is now working with all key captions in white on black and transparency is also working. But there are two strange things that are still there:
  • When I press a key on the keyboard it changes it's layout to english and repeats that keystroke 16x, i.e. if I press z I get yyyyyyyyyyyyyyyy in my terminal. From the next keystroak every response in the terminal has the right amount, i.e. if I press g, there is one g in my terminal.
  • Under settings -> behaviour "move to near selected widget" and "auto hide" doesn't seam to do anything.
Does anybody has encountered and solved these errors?

guest_1
Posts: 7
Joined: Thu Feb 20, 2014 10:09 am

Re: Help with florence, keys and captions stay black

Sun Mar 23, 2014 8:05 pm

Sorry for the double post, I think I have some news to share that is worth while the thread notification. The florence developer François Agrech mailed me again along with request to post his answer here.
You are probably affected by another bug:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1016661
This bug is well known but the root cause is not identified yet as it
is not easy to reproduce. It's probably linked to xtest but I haven't
been able to trace it back to its source.
It seems to happen when there are exactly 2 keyboard layouts
configured in the system. Only one or 3 keyboard layouts seem ok but 2
is not ok for some reason. This is what I observed but I'm not sure
this is always the case.
You can fix your problem with that command:
setxkbmap de
Or maybe by removing one layout or adding another in your system (I'm
not 100% sure it will fix the issue but it might)
After I tried setxkbmap de, it solved the keyboard layout switching. So I did in the terminal:

Code: Select all

nano .profile
headed to the end of the file and added setxkbmap de to it, then save and exit. This fix is now permanent including reboots.

François Agrech also wrote;
The auto hide feature works when the at-spi daemon is running
(accessibility is enabled in your system)
you can check if it is running with that command:
ps -ef | grep at-spi
if you see at-spi-registryd, it means that it is running.
How to enable accessibility depends on your desktop environment. If
you are using GNOME 2, you can use gnome-at-properties and activate
accessibility tools.
After enabling accessibility, you need to reboot your desktop
environment and auto hide mode should be working.

I hope this helps, please tell me if that fixed both your problems.
If your problem are fixed, I would appreciate if you could post the
solution on the raspberri forum as it might help other people with the
same problem.
So I installed at-spi and created a file named autostart in ~/.config/lxsession/LXDE/ with the content:

Code: Select all

@/usr/lib/at-spi/at-spi-registryd
Now the florence auto hide feature should work as the at-spi daemon is running on my system. But sadly it doesn't work and I can't find a guide, on how to configure at-spi-registryd. I get the following warnings:

Code: Select all

** (at-spi-registryd:2503): WARNING **: Could not set GTK_MODULES: The name org.gnome.SessionManager was not provided by any .service files

** (at-spi-registryd:2503): WARNING **: Failed to register client: The name org.gnome.SessionManager was not provided by any .service files

** (at-spi-registryd:2503): WARNING **: Unable to register client with session manager
Can anybody help?

guest_1
Posts: 7
Joined: Thu Feb 20, 2014 10:09 am

Re: Help with florence, keys and captions stay black

Mon Mar 31, 2014 8:14 am

I managed to find out that I need at-spi2-atk for the auto hide feature, which isn't available in Raspbian Wheezy stable. :|
So I have the option to upgrade to testing or build it from source. I would like to stay on the stable tree, so I tried to build it from source. Until now I wasn't successful on that as it pulls out quiet some dependencies which leads to compile a current GTK version first. That's where I'm struggling.

Can somebody help me there or point out a good tutorial link on that?

mosttly
Posts: 7
Joined: Sun May 18, 2014 4:30 am

Re: Help with florence, keys and captions stay black

Tue Aug 19, 2014 4:25 pm

guest_1 wrote:I managed to find out that I need at-spi2-atk for the auto hide feature, which isn't available in Raspbian Wheezy stable. :|
So I have the option to upgrade to testing or build it from source. I would like to stay on the stable tree, so I tried to build it from source. Until now I wasn't successful on that as it pulls out quiet some dependencies which leads to compile a current GTK version first. That's where I'm struggling.

Can somebody help me there or point out a good tutorial link on that?
Hi, Any update on the auto-hide feature.
Learning Begets Learning

Return to “Raspberry Pi OS”