jklanka
Posts: 5
Joined: Tue Nov 19, 2013 8:37 am

install libsdl1.2debian-pulseaudio

Tue Nov 19, 2013 12:06 pm

Hi All,

I am trying to install libsdl1.2debian-pulseaudio using

>sudo apt-get install -y libsdl1.2debian-pulseaudio

but it gives package has no installation candidate. Please help me to install this.
source.list file contains following line

deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi

Thanks

MoosePi
Posts: 112
Joined: Wed Nov 06, 2013 4:42 pm

Re: install libsdl1.2debian-pulseaudio

Tue Nov 19, 2013 12:23 pm

I believe you are trying to install packages from Raspbian ARMv7

Maybe what you need is

apt-get update
apt-get libsdl1.2debian

libsdl1.2debian

Simple DirectMedia Layer

SDL is a library that allows programs portable low level access to
a video framebuffer, audio output, mouse, and keyboard.

This version of SDL is compiled with X11, caca and DirectFB graphics
drivers and OSS, ALSA, NAS and PulseAudio sound drivers.
Pi Forum Search and Google yields answers to many questions

jklanka
Posts: 5
Joined: Tue Nov 19, 2013 8:37 am

Re: install libsdl1.2debian-pulseaudio

Wed Nov 20, 2013 2:38 am

Thanks for you reply.

I tried to setup XIBO client on raspbian using the below link
> sudo apt-get install -y libdc1394-22 libgraphicsmagick++3 libgraphicsmagick3 bzr
python-soappy python-feedparser python-serial libavcodec52 libavformat52
libswscale0 libsdl1.2debian-pulseaudio libvdpau1


Where it is asked to install libsdl1.2debian-pulseaudio.

I followed your instruction and now I found libsdl1.2debian is installed. is this package enough and including pulse audio options. ?

Also I am newbie to raspberry pi, how can I find the ARM of my Raspberry Box.

Thanks

MoosePi
Posts: 112
Joined: Wed Nov 06, 2013 4:42 pm

Re: install libsdl1.2debian-pulseaudio

Wed Nov 20, 2013 7:02 am

jklanka wrote:Thanks for you reply.

I tried to setup XIBO client on raspbian using the below link
> sudo apt-get install -y libdc1394-22 libgraphicsmagick++3 libgraphicsmagick3 bzr
python-soappy python-feedparser python-serial libavcodec52 libavformat52
libswscale0 libsdl1.2debian-pulseaudio libvdpau1


Where it is asked to install libsdl1.2debian-pulseaudio.

I followed your instruction and now I found libsdl1.2debian is installed. is this package enough and including pulse audio options. ?

Also I am newbie to raspberry pi, how can I find the ARM of my Raspberry Box.

Thanks
FYI Raspbian Wheezy is compiled to run on the Pi ARMv6 Architecture, this is not the same as Raspbian or Debian ARMHF which are compiled for ARMv7

Prior to installing any updates run:

sudo apt-get update

If you have not yet upgraded packages then run:

sudo apt-get dist-upgrade

To find available packages I also use Synaptic Package Manager which is a GUI for APT and give description of packages, obviously you will need to be in the LXDE Desktop to access, to install Synaptic:

apt-get install synaptic

Regards you issues you need to install packages which have been compiled to run with the ARMv6 architecture and that any Blogs / Instructions you follow for specific software is Pi related.

Regards XiBo see http://potlatchtech.blogspot.co.uk/2012 ... ry-pi.html

http://www.raspberrypi.org/phpBB3/viewt ... hilit=xibo

Though the Screenly Digital Signage software may be an alternative for you:

http://www.screenlyapp.com
http://www.screenlyapp.com/ose.html
Pi Forum Search and Google yields answers to many questions

jklanka
Posts: 5
Joined: Tue Nov 19, 2013 8:37 am

Re: install libsdl1.2debian-pulseaudio

Fri Nov 22, 2013 3:45 pm

Thanks for your reply and really this synaptic helped me lot.

I am following the link

http://www.cnx-software.com/2012/01/24/ ... toolchain/

to compile berkelium. What I undestood is I need to install emdebian in another machine and compile the berkelium and copy the binaries to Raspbian insatlled Raspberry Pi Box.

I installed VirtualBox to my MAC Book and now trying to install emdebian from the following link
http://www.emdebian.org/emdebian/flavours.html

Which Version I should download, I mean emdebian grid 2 or 3. I am very confused on this.

for Berkelium cross compilation I have to install the following packages using aptx as per link.

libnss3-dev = Distribution:sid-grip ] [ Component: main ]
libgconf2-dev = [ Distribution: sid-grip ] [ Component: main ]
libgnome-keyring-dev = Distribution:wheezy-grip ] [ Component: main ]
ibgtk2.0-dev = Distribution: sid-grip ] [ Component: main ]
libgnome-keyring-dev = Distribution:wheezy-grip ] [ Component: main ]
libxtst-dev= Distribution: lenny ] [ Component: main ]
libpam-dev= Distribution: sid-grip ] [ Component: main ] note: only libpam0g-dev
libxss-dev= Distribution: sid-grip ] [ Component: main ]
libdbus-glib-1-dev= Distribution: lenny ] [ Component: main ]
libnspr4-dev= Distribution: sid-grip ] [ Component: main ]
libglib2.0-dev= Distribution: lenny ] [ Component: main ]
libjpeg-dev= Distribution:sid-grip ] [ Component: main ] note : this is not available, but install libgd-dev and get as dependency
libasound2-dev= Distribution:sid-grip ] [ Component: main ]
libbz2-dev= Distribution:squeeze ] [ Component: dev ]
libgcrypt-dev= Distribution: lenny ] [ Component: main ] note: only libgcrypt11-dev available
libspeex-dev= Distribution:sid-grip ] [ Component: main ]
libcups2-dev = Distribution:squeeze ] [ Component: dev ]

Or Do I need to install some other version like lenny, squeezy etc. to get the binary of berkelium.

Please advice.

jklanka
Posts: 5
Joined: Tue Nov 19, 2013 8:37 am

Re: install libsdl1.2debian-pulseaudio

Tue Dec 03, 2013 2:19 am

Hi

I found a link http://rpiserver.breggen.nl:8080/building_xibo.html and really given good steps to follow and where I am trying to
compile the chromium using 16GB SD card following the article.

In the link Under Getting code section I am trying to build using the command given

util/build_chromium.sh

But I am getting an error below


NameError: name 'use_system_yasm' is not defined while evaluating condition 'use_system_yasm==1'
in src/third_party/libjpeg_turbo/libjpeg.gyp while loading dependencies of
src/ui/gfx/gfx.gyp while loading dependencies of src/gpu/gpu.gyp while loading dependencies of
src/skia/skia.gyp while loading dependencies of src/app/app.gyp while loading dependencies of
src/build/all.gyp while trying to load src/build/all.gyp
Error: Command /usr/bin/python src/build/gyp_chromium returned non-zero exit status 1 in /home/pi/raspberry/berkelium/build/chromium
Hook '/usr/bin/python src/build/gyp_chromium' took 54.62 secs
Failed to install: chromium


I realise this something to do with gyp and no idea how to overcome this issue. Please need someone help to overcome this issue.

Thanks

Return to “Raspberry Pi OS”