gkreidl
Posts: 5688
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Tutorial: Compile VLC with HW acceleration - Jessie, RPi 2/3

Fri Mar 30, 2018 10:41 pm

JMastaC4 wrote:
Fri Mar 30, 2018 10:29 pm

Code: Select all

 [email protected]*******:~/Downloads/vlc-2.2.5.1 $ make -j3 
make: *** No targets specified and no makefile found. Stop.
Hmm... what to do now?
Whelp im stuck ¯\_(ツ)_/¯. Guess Ill just stick to old OMXPlayer.
The makefiles are created by the other steps. You must have been missing something.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

alexkapoios
Posts: 3
Joined: Mon Sep 17, 2018 4:47 pm

Re: Tutorial: Compile VLC with HW acceleration - Jessie, RPi 2/3

Mon Sep 17, 2018 4:57 pm

Hello. I 'm beginner and I need your help.
I have got a Raspberry Pi 2 Model V2.
I want to install VLC.
I have made update and upgrade my Raspbian and I try to install
sudo apt-get install autopoint gettext liba52-0.7.4-dev libaa1-dev libasound2-dev libass-dev libavahi-client-dev libavc1394-dev libavcodec-dev libavformat-dev libbluray-dev libcaca-dev libcddb2-dev libcdio-dev libchromaprint-dev libdbus-1-dev libdc1394-22-dev libdca-dev libdirectfb-dev libdvbpsi-dev libdvdnav-dev libdvdread-dev libegl1-mesa-dev libfaad-dev libflac-dev libfluidsynth-dev libfreerdp-dev libfreetype6-dev libfribidi-dev libgl1-mesa-dev libgles1-mesa-dev libgles2-mesa-dev libgnutls28-dev libgtk2.0-dev libidn11-dev libiso9660-dev libjack-jackd2-dev libkate-dev liblircclient-dev liblivemedia-dev liblua5.2-dev libmad0-dev libmatroska-dev libmodplug-dev libmpcdec-dev libmpeg2-4-dev libmtp-dev libncursesw5-dev libnotify-dev libogg-dev libomxil-bellagio-dev libopus-dev libpng12-dev libpulse-dev libqt4-dev libraw1394-dev libresid-builder-dev librsvg2-dev libsamplerate0-dev libschroedinger-dev libsdl-image1.2-dev libsdl1.2-dev libshine-dev libshout3-dev libsidplay2-dev libsmbclient-dev libspeex-dev libspeexdsp-dev libssh2-1-dev libswscale-dev libtag1-dev libtheora-dev libtwolame-dev libudev-dev libupnp-dev libv4l-dev libva-dev libvcdinfo-dev libvdpau-dev libvncserver-dev libvorbis-dev libx11-dev libx264-dev libxcb-composite0-dev libxcb-keysyms1-dev libxcb-randr0-dev libxcb-shm0-dev libxcb-xv0-dev libxcb1-dev libxext-dev libxinerama-dev libxml2-dev libxpm-dev libzvbi-dev lua5.2 oss4-dev pkg-config zlib1g-dev libtool build-essential autoconf
and I show error
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.3).
libfreetype6-dev is already the newest version (2.6.3-3.2).
pkg-config is already the newest version (0.29-4).
zlib1g-dev is already the newest version (1:1.2.8.dfsg-5).
zlib1g-dev set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libaa1-dev : Depends: libslang2-dev but it is not going to be installed
libcaca-dev : Depends: libslang2-dev but it is not going to be installed
libgtk2.0-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
libnotify-dev : Depends: libgdk-pixbuf2.0-dev but it is not going to be installed
libpng-dev : Conflicts: libpng12-dev but 1.2.54-6 is to be installed
libpng12-dev : Conflicts: libpng-dev but 1.6.28-1 is to be installed
librsvg2-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.23.5-2) but it is not going to be installed
Depends: libcairo2-dev (>= 1.2.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Why can't I install plugins library?

gkreidl
Posts: 5688
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Tutorial: Compile VLC with HW acceleration - Jessie, RPi 2/3

Mon Sep 17, 2018 8:01 pm

Did you run a
sudo apt-get update
sudo apt-get upgrade
before you tried to install the packages?
Are you really running Jessie? There is a separate thread about a Stretch installation.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

alexkapoios
Posts: 3
Joined: Mon Sep 17, 2018 4:47 pm

Re: Tutorial: Compile VLC with HW acceleration - Jessie, RPi 2/3

Tue Sep 18, 2018 7:30 am

Yes, I run a update and upgrade. After, I try to install

Code: Select all

sudo apt-get install autopoint gettext liba52-0.7.4-dev libaa1-dev libasound2-dev libass-dev libavahi-client-dev libavc1394-dev libavcodec-dev libavformat-dev libbluray-dev libcaca-dev libcddb2-dev libcdio-dev libchromaprint-dev libdbus-1-dev libdc1394-22-dev libdca-dev libdirectfb-dev libdvbpsi-dev libdvdnav-dev libdvdread-dev libegl1-mesa-dev libfaad-dev libflac-dev libfluidsynth-dev libfreerdp-dev libfreetype6-dev libfribidi-dev libgl1-mesa-dev libgles1-mesa-dev libgles2-mesa-dev libgnutls28-dev libgtk2.0-dev libidn11-dev libiso9660-dev libjack-jackd2-dev libkate-dev liblircclient-dev liblivemedia-dev liblua5.2-dev libmad0-dev libmatroska-dev libmodplug-dev libmpcdec-dev libmpeg2-4-dev libmtp-dev libncursesw5-dev libnotify-dev libogg-dev libomxil-bellagio-dev libopus-dev libpng12-dev libpulse-dev libqt4-dev libraw1394-dev libresid-builder-dev librsvg2-dev libsamplerate0-dev libschroedinger-dev libsdl-image1.2-dev libsdl1.2-dev libshine-dev libshout3-dev libsidplay2-dev libsmbclient-dev libspeex-dev libspeexdsp-dev libssh2-1-dev libswscale-dev libtag1-dev libtheora-dev libtwolame-dev libudev-dev libupnp-dev libv4l-dev libva-dev libvcdinfo-dev libvdpau-dev libvncserver-dev libvorbis-dev libx11-dev libx264-dev libxcb-composite0-dev libxcb-keysyms1-dev libxcb-randr0-dev libxcb-shm0-dev libxcb-xv0-dev libxcb1-dev libxext-dev libxinerama-dev libxml2-dev libxpm-dev libzvbi-dev lua5.2 oss4-dev pkg-config zlib1g-dev libtool build-essential autoconf
I installed Raspbian Stretch with desktop and I run that.
https://www.raspberrypi.org/downloads/raspbian/

gkreidl
Posts: 5688
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Tutorial: Compile VLC with HW acceleration - Jessie, RPi 2/3

Tue Sep 18, 2018 7:39 am

alexkapoios wrote:
Tue Sep 18, 2018 7:30 am
Yes, I run a update and upgrade. After, I try to install

Code: Select all

sudo apt-get install autopoint gettext liba52-0.7.4-dev libaa1-dev libasound2-dev libass-dev libavahi-client-dev libavc1394-dev libavcodec-dev libavformat-dev libbluray-dev libcaca-dev libcddb2-dev libcdio-dev libchromaprint-dev libdbus-1-dev libdc1394-22-dev libdca-dev libdirectfb-dev libdvbpsi-dev libdvdnav-dev libdvdread-dev libegl1-mesa-dev libfaad-dev libflac-dev libfluidsynth-dev libfreerdp-dev libfreetype6-dev libfribidi-dev libgl1-mesa-dev libgles1-mesa-dev libgles2-mesa-dev libgnutls28-dev libgtk2.0-dev libidn11-dev libiso9660-dev libjack-jackd2-dev libkate-dev liblircclient-dev liblivemedia-dev liblua5.2-dev libmad0-dev libmatroska-dev libmodplug-dev libmpcdec-dev libmpeg2-4-dev libmtp-dev libncursesw5-dev libnotify-dev libogg-dev libomxil-bellagio-dev libopus-dev libpng12-dev libpulse-dev libqt4-dev libraw1394-dev libresid-builder-dev librsvg2-dev libsamplerate0-dev libschroedinger-dev libsdl-image1.2-dev libsdl1.2-dev libshine-dev libshout3-dev libsidplay2-dev libsmbclient-dev libspeex-dev libspeexdsp-dev libssh2-1-dev libswscale-dev libtag1-dev libtheora-dev libtwolame-dev libudev-dev libupnp-dev libv4l-dev libva-dev libvcdinfo-dev libvdpau-dev libvncserver-dev libvorbis-dev libx11-dev libx264-dev libxcb-composite0-dev libxcb-keysyms1-dev libxcb-randr0-dev libxcb-shm0-dev libxcb-xv0-dev libxcb1-dev libxext-dev libxinerama-dev libxml2-dev libxpm-dev libzvbi-dev lua5.2 oss4-dev pkg-config zlib1g-dev libtool build-essential autoconf
I installed Raspbian Stretch with desktop and I run that.
https://www.raspberrypi.org/downloads/raspbian/
For Stretch you should use the following tutorial: https://www.raspberrypi.org/forums/view ... 6&t=195221
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Return to “Raspbian”

Who is online

Users browsing this forum: lssndr and 22 guests