User avatar
BluDragon
Posts: 83
Joined: Thu Sep 05, 2013 7:32 am
Location: 127.0.0.1

[solved] mounting ntfs-3g (not using the options i specify)

Fri Oct 25, 2013 11:00 pm

Code: Select all

sudo mount -t ntfs-3g -o async,noatime,rw,suid,exec,user /dev/sda1 /media/drive1
after entering that command i use "mount" and i get...

Code: Select all

/dev/sda1 on /media/drive1 type fuseblk (rw,nosuid,nodev,noexec,noatime,user_id=0,group_id=0,allow_other,blksize=4096)
the drive has been mounted with nosuid and noexec instead of suid and exec like i specified.
Last edited by BluDragon on Sat Oct 26, 2013 7:10 pm, edited 1 time in total.
"Whenever a separation is made between liberty and justice, neither, in my opinion, is safe." - Edmund Burke
"Men make counterfeit money; in many more cases, money makes counterfeit men." - Sydney J. Harris

wimble
Posts: 34
Joined: Tue Feb 05, 2013 9:52 am

Re: mounting ntfs-3g (not using the options i specify)

Fri Oct 25, 2013 11:15 pm

You've listed your arguments as suid,exec,user.
The man page for mount at http://linux.die.net/man/8/mount says:
user

Allow an ordinary user to mount the filesystem. The name of the mounting user is written to mtab so that he can unmount the filesystem again. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid).
So try moving user in front of the suid and exec options.
(I haven't tested this, just read the page, so I make not guarantees.)

User avatar
BluDragon
Posts: 83
Joined: Thu Sep 05, 2013 7:32 am
Location: 127.0.0.1

Re: mounting ntfs-3g (not using the options i specify)

Sat Oct 26, 2013 7:09 pm

that worked, thanks. i can't mount with user, but that's okay.
"Whenever a separation is made between liberty and justice, neither, in my opinion, is safe." - Edmund Burke
"Men make counterfeit money; in many more cases, money makes counterfeit men." - Sydney J. Harris

Return to “Raspbian”