Wm.A.Weezl
Posts: 12
Joined: Thu Oct 18, 2012 1:54 am

Pi drops ethernet connection

Thu Oct 03, 2013 2:22 am

I am running my Pi headless over ssh as a print- and file server. It was working pretty well with the 2012-09-18-wheezy-raspbian version, then in June I ran apt-get upgrade and ruined everything! After that, any operation that caused a lot of ethernet traffic caused the Pi to drop its network connection or even freeze completely. Trying to ping it gave the result "host unreachable." This would happen when attempting to use apt-get, when trying to send a remote desktop with vnc, or by sending a print job. Sometimes, it would rejoin the network after a long wait (minutes or hours) - especially Server Edition. Sometimes I could get it back on the network by unplugging and reconnecting the ethernet cable. Often my only recourse was to turn its power off and on to make it reboot.

I installed the 2013-07-26, 2013-09-10, and 2013-09-25 versions of Raspbian and had more or less the same result with each of them. I tried Raspbian Server Edition 2.3, no change.

A couple days ago, I went back to the year-old 2012-09-18 Raspbian, and the network problem seems to be gone.

Have others have experienced anything like this? Why would newer versions of Raspbian would work less well than an old version?

Heater
Posts: 17137
Joined: Tue Jul 17, 2012 3:02 pm

Re: Pi drops ethernet connection

Thu Oct 03, 2013 7:54 am

Yes I have.

In two cases:

1) I put raspi-still in a bash shell script loop so it capture pictures regularly. When I started the script I could see that it would complete taking one or two pictures and then the ssh session would break. Clearly the Pi was still running as after rebooting it there were images files that had been created on the SD.

2) I was building GCC on the Pi as a cross-compiler for the Propeller MCU from Parallax. A job that takes about 20 hours and has been done successfully before. The other day I was trying to build a new version of that GCC and the network went down after 6 hours or so.

Case 2) I put down to running out of memory for various reasons.
Case 1) Is still a mystery.

All in all not conclusive yet.
Memory in C++ is a leaky abstraction .

Wm.A.Weezl
Posts: 12
Joined: Thu Oct 18, 2012 1:54 am

Re: Pi drops ethernet connection

Tue Oct 08, 2013 1:34 am

Update 6 days later.
The 2012-09-18 Raspbian is working like a sweet, sweet dream. Which leads me to wonder again, why has newer software been released that is so much worse than the old? Or does the new OS not work on my Pi because it's one of the earliest ones manufactured? Does the newer OS work on newer hardware?

pfeerick
Posts: 2
Joined: Mon Jul 15, 2013 9:08 am

Re: Pi drops ethernet connection

Thu Oct 17, 2013 12:09 pm

I also had the same issue. After replacing a dead SD card, decided to image using the latest Raspbian (2013-09-25). All went ok, setup ssh, left running headless - booted with only ethernet and power connected. SSH session started consistently failing after approximately an hour. Re-imaged, changed settings only via raspi-config (extend fs, set timezone, turn spi on, turn ssh on, set mem to 32 for GPU). Same deal. Reverted back to clean Adafruit Occidentalis v0.2 (based on Raspbian Wheezy August 16 2012)... has been running for several hours without any issues (once again). Don't remember enough linux internals to find out the gremlin, nor do I have the time or patience as it is currently giving me the shivers...

Raspberry Pi Type B rev 2 (512MB)

Kz99
Posts: 1
Joined: Sat Oct 19, 2013 11:46 am

Re: Pi drops ethernet connection

Sat Oct 19, 2013 12:08 pm

Hi,

I have the same problem with the latest Raspbian and firmware update. I'm running my rpi headless and powered from original samsung s4 charger ( 2A rated ), also tried powering it from USB 3.0 port. My ethernet connections drops at random times and sometimes even within 5mins of boot. I tried older images of Raspbian like the 2012-9-18 the RPI worked for longer period before the Ethernet dropped.

I'm currently running the latest Raspbian Image with the latest firmware update.

Code: Select all

$ uname -a 
Linux raspberrypi 3.6.11+ #557 PREEMPT Wed Oct 2 18:49:09 BST 2013 armv6l GNU/Linux
/var/log/syslog shows spam of these errors: ( on all images )


Oct 19 06:45:46 raspberrypi ifplugd(eth0)[1581]: Link beat lost.
Oct 19 06:45:46 raspberrypi kernel: [14550.860903] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Oct 19 06:45:46 raspberrypi kernel: [14550.860933] smsc95xx 1-1.1:1.0: eth0: Error reading MII_ACCESS
Oct 19 06:45:46 raspberrypi kernel: [14550.860950] smsc95xx 1-1.1:1.0: eth0: MII is busy in smsc95xx_mdio_read
Oct 19 06:45:46 raspberrypi kernel: [14550.861109] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Oct 19 06:45:46 raspberrypi kernel: [14550.861133] smsc95xx 1-1.1:1.0: eth0: Error reading MII_ACCESS

this goes for long time. The Rpi functions during this time and i can hook up keyboard and able to write commands.

After sometimes, the rpi goes to sleep or something and only PWR LED is on.

I've googled for hours the above errors and tried all suggested solutions. Nothing worked for me.

My RPI is Model B Rev 2 (512 MB RAM)

cpuinfo shows Revision number: 000f

Edit: I noticed that it starts occurring more frequently after the first time it started. Also, the RPI ethernet functions for a longer period every time i do a fresh install of Raspbian image. Can this problem be related to SD Card?

Wm.A.Weezl
Posts: 12
Joined: Thu Oct 18, 2012 1:54 am

Re: Pi drops ethernet connection

Sun Oct 20, 2013 1:19 pm

In my case, the 2012-09-18 version of Raspbian continues to work well about 3 weeks after re-installing it. The Pi is always powered on and connected to ethernet. I did not experience deteriorating function with the newer versions of Raspbian - they failed to work from the very start.

pfeerick
Posts: 2
Joined: Mon Jul 15, 2013 9:08 am

Re: Pi drops ethernet connection

Mon Oct 21, 2013 1:36 am

Well, the Adafruit Occidentalis v0.2 (Wheezy 2012-08-16) crashed overnight, so before shoving the Raspberry Pi in a box to hide in shame until a later date, I finally checked the voltage at the test points (TP1 & TP2). Surprisingly, the voltage from the power supply had dropped from 5.2v to 4.4v... so outside of the 4.75 - 5.25 specs the raspi likes :} The usb cable I had hacked for power was obviously deficient, so is now reverse-powered via the 5v pin, and is happily running at 5.1v. Probably explains the intermittent 'sleep' / PWR_LED only issue I was also having.

No crashes after 2 days, am now setting up web server + mysql + php again, and then will image another sd card with the latest Raspbian to see it that works now or crashes and burns... :)

User avatar
DavidS
Posts: 4334
Joined: Thu Dec 15, 2011 6:39 am
Location: USA
Contact: Website

Re: Pi drops ethernet connection

Mon Oct 21, 2013 2:44 am

I have experienced similar problems with every version of Raspbian that I have used, with every version of the firmware that I could get to work. I also have the same issue with Puppy Linux.

Though in my case the Ethernet connection is dropped seemingly at random, and I am using it at a local terminal (monitor, Keyboard, and Mouse hooked to the RPi) with remote login dissabled. I must assume that there is some bug in either the Sockets implementation, the dhcp deamon, the network HW modules, or some similar.

I have never had these issues with RISC OS or AROS (native, not the linux hosted), even when using the exact same firmware that causes trouble with Raspbian. This leads me to conclude that it is unlikely to be related to the firmware.

This issue has helped to minimize my use of Linux on the RPi. Though so far Raspbian + Wayland and Puppy are the best two RPi Linux distros for me.
RPi = The best ARM based RISC OS computer around
More than 95% of posts made from RISC OS on RPi 1B/1B+ computers. Most of the rest from RISC OS on RPi 2B/3B/3B+ computers

zepotus
Posts: 1
Joined: Tue Oct 29, 2013 8:43 am

Re: Pi drops ethernet connection

Tue Oct 29, 2013 9:05 am

I can also confirm this. There is problem with network in Raspbian (2013-09-25). I'm using older version 2013-02-09 without problem.

Network may work for a while or drops almost immediately. I had to change to older version.

magic9418
Posts: 2
Joined: Sat Jan 11, 2014 1:56 am

Re: Pi drops ethernet connection

Sat Jan 11, 2014 2:08 am

I have this same issue, I am going to try and go back to the version listed as working on this thread.

shoko1
Posts: 3
Joined: Sun Dec 30, 2012 4:32 am
Location: TN

Re: Pi drops ethernet connection

Mon Feb 16, 2015 12:41 am

just made a post abou tthis. Glad its not just me. I'm using July 2012 raspbian and works fine. All newer version have this issue and it makes it un usable. Back to using a 3 year old version and again working fine. Would love to be able to use a newer version.

jskjj
Posts: 4
Joined: Mon Feb 09, 2015 8:37 am

Re: Pi drops ethernet connection

Thu Apr 09, 2015 12:22 am

I know that this is an older thread, but I'm having the same problem (Eithernet dropping connection upon plugging in the RTL USB Stick). It seems the solution is to use an older version of RTL_TCP.

First question is, how do I uninstall the old driver, and where can I find the one that works? That has to be my issue as the Ethernet goes down (Connector lights even go off) the moment I plug in the RTL Stick. If I start the Pi with the stick in it, i'll never have a connection and the ethernet lights never come on. Of course, all this happens long before I run rtl_tcp.

Suggestions? A walkthrough taking me through the process of uninstalling the new and installing the old would be great. I'm not overly familiar with linux.

Thanks in advance.

jskjj
Posts: 4
Joined: Mon Feb 09, 2015 8:37 am

Re: Pi drops ethernet connection

Thu Apr 09, 2015 1:46 am

Fixed that problem, I was using the wrong adapter, got it mixed up with my phone's. I guess it wasn't enough power. I still get disconnects though that happen often when connecting with SDR#. Usually before the disconnect, I get a loud screeching sound on all frequencies. Not sure what this is.

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Mon Apr 13, 2015 4:15 pm

I just ran into this problem.

I left a Raspberry Pi Model B running in my office over the weekend, and it lost ethernet over the weekend - specifically, eth0 still showed when I ran an ifconfig command, but it did not have an IP address.

I am using the built-in 10/100 Ethernet, going to a TPLINK 8 port gigabit switch, with DHCP being supplied by a Netgear router.

This morning I went to the the Pi in question, and was able to access it with the local keyboard and display.

executing

sudo ifdown eth0
sudo ifup eth0

got it back on the net, however it should not have lost the connection anyway.

I am running the Pi of a 5.2V 2.4A power supply, and the power supply is monitored with a 2mV/bit ADC setup with a precision 4.096V reference (http://www.mikronauts.com/raspberry-pi/ ... and-howto/) with the latest Raspbian, updated last Friday.

The Pi's 5V is reading rock solid at 4.954V and the 3v3 rail reads 3.312V

Any idea why I lost Ethernet?
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Fri Apr 17, 2015 9:26 pm

Has anyone found a solution to the dropped Ethernet yet?
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Pi drops ethernet connection

Fri Apr 17, 2015 9:35 pm

mikronauts wrote:Has anyone found a solution to the dropped Ethernet yet?
You make it sound like a common problem, but it isn't.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Fri Apr 17, 2015 10:33 pm

This thread was created long before I experienced the issue, so it is a known issue.

I am running

Linux RPi2B 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux

and I started having the issue as soon as I started leaving one of my Pi's on 24/7

Local console is still up, however the Pi seems to lose the DHCP lease, or at least somehow lose its IP address.

I could hack a script together to ifdown/ifup if a ping to one of my other machines fails, however I was hoping someone else may have a proper solution.

Given that I am using a stock Raspbian install, with DHCP from a standard router (Netgear 3500L), and none of my non-pi machines exhibit this symptom (mix of Ubuntu and Debian boxes), I consider it extremely likely that the issue still exists for others - and that someone may have come up with the reason, and a proper fix.

For the moment, I will sudo apt-get update & upgrade (which I did when I first posted in this thread), and if I have to, I will write the script to release/renew the dhcp lease.
gkreidl wrote:
mikronauts wrote:Has anyone found a solution to the dropped Ethernet yet?
You make it sound like a common problem, but it isn't.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Tue Apr 21, 2015 5:36 pm

sudo apt-get update & upgrade fixed my issue, I have not had a dropped connection in four days.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Wed Apr 29, 2015 6:01 pm

I spoke too soon.

I lost the Ethernet connection AGAIN last night.

I am doing another update & upgrade but this is REALLY frustrating, I am trying to deploy some of my P1B's to run headless 24/7

The setup is very simple, just a Pi 1 B with some ADC's, no other peripherals.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Wed Apr 29, 2015 6:10 pm

The only other thing I could think of is to do an rpi-update ... it is in progress.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Sat May 02, 2015 5:03 pm

Lost Ethernet AGAIN.

This is very frustrating, and it does not bode well for running Raspberry Pi's 24/7. I am trying to deploy a small network of Pi's (A's & B's) to run 24/7.

Next experiment will be assigning an static IP address to the Pi, and if that does not work, I guess I'll have to write a script to watch for loss of ip then ifdown/ifup and see if that ugly hack will resolve this.

To recap:

I am using Raspbian 2015-02-16, have done rpi-update, update and upgrade, and I am still losing ethernet connectivity in between 4 - 48 hours, the Pi loses its IP address.

My app does not cause a lot of traffic, just logs data to "the cloud" every minute.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Sat May 02, 2015 5:32 pm

Ok, test pi is now running on a static IP address.

If it loses connection now, dhcp is not to blame, it would pretty much have to be the driver or IP stack.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Pi drops ethernet connection

Sat May 02, 2015 6:47 pm

mikronauts wrote:Ok, test pi is now running on a static IP address.

If it loses connection now, dhcp is not to blame, it would pretty much have to be the driver or IP stack.
I've got up to 4 RPis running in my wired network, two of them are always on and I haven't lost a connection in years. There must be something special in your system (router, switch, cabling ...) that causes the drops.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

User avatar
mikronauts
Posts: 2821
Joined: Sat Jan 05, 2013 7:28 pm
Contact: Website

Re: Pi drops ethernet connection

Sun May 03, 2015 2:12 am

Thanks, my best guess is that it is something to do with the dhcp server and the lease for that RPi.

I have an RPi2 that has been running off a USB hd as a development/test box, and test SMB server that does not drop off the net.

The problematic system is hooked up to an eight port gigabit switch, however the same switch is also used by my 24/7 main Linux workstation, so it is unlikely to be the issue.

I can replace the Cat6 cable I am using for the problematic RPi, however I don't see how the cable could cause the issue - particularly since rebooting that Pi when it loses the net connection (without moving/changing the cable clears up the situation).

Heck, logging in locally (kb+monitor) also lets me ifdown/ifup to fix the issue. Weird.
gkreidl wrote:
mikronauts wrote:Ok, test pi is now running on a static IP address.

If it loses connection now, dhcp is not to blame, it would pretty much have to be the driver or IP stack.
I've got up to 4 RPis running in my wired network, two of them are always on and I haven't lost a connection in years. There must be something special in your system (router, switch, cabling ...) that causes the drops.
http://Mikronauts.com - home of EZasPi, RoboPi, Pi Rtc Dio and Pi Jumper @Mikronauts on Twitter
Advanced Robotics, I/O expansion and prototyping boards for the Raspberry Pi

User avatar
DougieLawson
Posts: 40577
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Pi drops ethernet connection

Sun May 03, 2015 8:45 am

1. Un-install isc-dhcp-client, replace it with dhcpcd
2. Change the lease time on your DHCP server to see if the lease time is consistent with the failure.
Any language using left-hand whitespace for syntax is ridiculous

Any DMs sent on Twitter will be answered next month.
Fake doctors - are all on my foes list.

Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Return to “Raspberry Pi OS”