joacliba
Posts: 25
Joined: Sat Jun 08, 2013 4:28 pm

Old versions of raspbian on a new raspberry

Wed Jun 12, 2013 10:11 am

Hi, because I couldn't downgrade kernel to 3.2 in the last raspbian image, I tried old versions with my raspberry without success.

I only can boot 2013 versions of firmware, with 2012 raspberry doesn't boot (black screen). I follow the same procedure and I tried with 2 methods (PiWritter and with dd command on OSX). without luck.

Is there a difference between old firmwares?

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12580
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Old versions of raspbian on a new raspberry

Wed Jun 12, 2013 10:24 am

Old firmwares may not know the configuration parameters of a newer RAM device, that your new PI might use,

The trick is to replace the /boot files of the older distro with the ones used by a new distro.

joacliba
Posts: 25
Joined: Sat Jun 08, 2013 4:28 pm

Re: Old versions of raspbian on a new raspberry

Wed Jun 12, 2013 10:33 am

So If I want to have the kernel of the 16-12-2012 raspbian I need to replace all /boot except the kernel.img? Or there are more files that I don't have to replace in /boot?

Thanks!

User avatar
RaTTuS
Posts: 10530
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Old versions of raspbian on a new raspberry

Wed Jun 12, 2013 10:37 am

possibly you can get away with
bootcode.bin
YMMV

why do you need an old version of raspbian?
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

joacliba
Posts: 25
Joined: Sat Jun 08, 2013 4:28 pm

Re: Old versions of raspbian on a new raspberry

Wed Jun 12, 2013 10:45 am

RaTTuS wrote:possibly you can get away with
bootcode.bin
YMMV

why do you need an old version of raspbian?
I need a working 3.2 kernel because more newer kernels have a bug with my arcade joystick (up and left axis don't work).

I tried to downgrade in the last raspbian without luck, it boots but applications don't work. So I need to try an older firmware with 3.2 kernel.

Now I can boot the 16-12-2012! Let's go to test joystick and advancemame.

Thank you!

EDIT: No, with this configuration I have the 3.2 kernel, the system boots but X doesn't work.

joacliba
Posts: 25
Joined: Sat Jun 08, 2013 4:28 pm

Re: Old versions of raspbian on a new raspberry

Wed Jun 12, 2013 6:24 pm

Trying with the files I see that the file I need to replace for boot the old version is the start.elf.

Replacing only that file (and with all /boot) I can boot the raspberry but not startx (the system freezes).

So now, I can't downgrade the last raspbian to a 3.2 kernel and I can't boot an old version of raspbian with the 3.2 kernel.

No 3.2 kernel for me :(

Any idea?

Return to “Raspbian”