User avatar
kyounger
Posts: 8
Joined: Fri Mar 22, 2013 2:50 pm

upgrade error (isc-dhcp-client) ??

Tue Mar 26, 2013 7:16 pm

So I was doing a normal apt-get update & apt-get upgrade and no dice:

Code: Select all

[email protected]:~# apt-get upgrade
Reading package lists... Done
Building dependency tree        
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 isc-dhcp-client : Depends: isc-dhcp-common (= 4.2.2.dfsg.1-5+deb70u2) but 4.2.2.dfsg.1-5+deb70u3 is installed
E: Unmet dependencies. Try using -f.
[email protected]:~# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libblas3gf liblapack3gf
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  isc-dhcp-client
Suggested packages:
  resolvconf avahi-autoipd
The following packages will be upgraded:
  isc-dhcp-client
1 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
106 not fully installed or removed.
Need to get 0 B/743 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 59235 files and directories currently installed.)
Preparing to replace isc-dhcp-client 4.2.2.dfsg.1-5+deb70u2 (using .../isc-dhcp-client_4.2.2.dfsg.1-5+deb70u3_armhf.deb) ...
Unpacking replacement isc-dhcp-client ...
dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: incorrect data check'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/isc-dhcp-client_4.2.2.dfsg.1-5+deb70u3_armhf.deb (--unpack):
 corrupted filesystem tarfile - corrupted package archive
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/isc-dhcp-client_4.2.2.dfsg.1-5+deb70u3_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~# 
As you can see, currently I cannot cleanly do the "apt-get upgrade"

Any Ideas?

GloW
Posts: 21
Joined: Sat Mar 23, 2013 8:38 pm

Re: upgrade error (isc-dhcp-client) ??

Tue Mar 26, 2013 7:43 pm

looks like the package you have downloaded is coorupted and stored in the apt-get cache.
try :

Code: Select all

ls -la /var/cache/apt/archives |grep isc-dhcp-client
sudo rm /var/cache/apt/archives/package_name.deb
sudo apt-get -f install 

plugwash
Forum Moderator
Forum Moderator
Posts: 3517
Joined: Wed Dec 28, 2011 11:45 pm

Re: upgrade error (isc-dhcp-client) ??

Wed Mar 27, 2013 3:41 pm

Try

rm -f /var/cache/apt/archives/isc-dhcp-client_4.2.2.dfsg.1-5+deb70u3_armhf.deb
apt-get -f install

Return to “Raspbian”