[PANIC] skb_over_panic, Kernel Bug at net/core/skbuff.c:127

11 posts
by GMR » Thu Feb 21, 2013 1:51 am

System: is a Raspian Wheezy, which is up-to-date. (fresh installed and updated)
Kernel: Linux raspberrypi 3.6.11+ #371 PREEMPT Thu Feb 7 16:31:35 GMT 2013 armv6l GNU/Linux

I get this Error, when i try to upload a 8MB file via SFTP. The error occurs within few seconds after the put-command from sftp.

Here is a screenshot: (i cant copy the text, because the system freezes immediately)

Last Lines from dmesg: (it logs no error message)
Code: Select all
[   16.059240] PPP generic driver version 2.4.2
[   16.073595] NET: Registered protocol family 24
[   16.180035] dm9601 1-1.2:1.0: eth1: register 'dm9601' at usb-bcm2708_usb-1.2, Davicom DM9601 USB Ethernet, 00:e0:4c:53:44:58
[   16.199000] usbcore: registered new interface driver dm9601
[   20.399475] mmc0: missed completion of cmd 18 DMA (512/512 [1]/[1]) - ignoring it
[   20.414288] mmc0: DMA IRQ 6 ignored - results were reset
[   22.470255] dm9601 1-1.2:1.0: eth1: link up, 100Mbps, full-duplex, lpa 0xFFFF
[   22.894370] ip_tables: (C) 2000-2006 Netfilter Core Team
[   22.925629] nf_conntrack version 0.5.0 (7012 buckets, 28048 max)
[   24.405514] smsc95xx 1-1.1:1.0: eth0: link up, 100Mbps, full-duplex, lpa 0x4DE1
[   28.798167] Adding 102396k swap on /var/swap.  Priority:-1 extents:1 across:102396k SS

Has anyone a solution or a tip? :)
Posts: 5
Joined: Thu Feb 21, 2013 1:37 am
by GMR » Thu Feb 21, 2013 10:52 am
everytime i handle with larger files (down- or upload), i get this error.

Time to Error after the command:
Upload: immediately (everytime)
Download: few seconds till few minutes

I think the problem is the NIC-Driver:

Output from: ethtool -i eth1 (NIC with DM9601-Chip)
Code: Select all
driver: dm9601                                                                                                                               

version: 22-Aug-2005                                                                                                                                                                         
firmware-version: Davicom DM9601 USB Ethernet                                                                                                                                                 
bus-info: usb-bcm2708_usb-1.3                                                                                                                                                                 
supports-statistics: no                                                                                                                                                                       
supports-test: no
supports-eeprom-access: yes
supports-register-dump: no
supports-priv-flags: no
Posts: 5
Joined: Thu Feb 21, 2013 1:37 am
by GMR » Thu Feb 21, 2013 4:34 pm
Ok, the failure is produced by the DM9601 Driver. I can't even compile the "latest" (=2005) driver (downloaded from Davicom Homepage) without errors.

At my other system (SMP Debian 3.2.35-2 x86_64 GNU/Linux) the NIC is registrated, the module dm9601 is loaded and it works bad (many RX and TX failures). However, it works slow, but i can use it without kernel panic oder skbuff-Error.

Now i bought the Digitus DN-3023 USB3.0 NIC, where the Drivers are up-to-date (last update Dec 2012) and which compile fast und without problems.

I will report soon, if the new card works well.
Posts: 5
Joined: Thu Feb 21, 2013 1:37 am
by Kostja » Sat Feb 23, 2013 8:47 am
Same problem here. I'm using a Davicom DM9601 chip as USB NIC adapter (USBtec brand, http://www.amazon.de/gp/product/B005BY7HSS/)

My system ist a fresh Raspian Wheezy (Kernel 3.6.11+)


Code: Select all
kernel BUG at net/core/skbuff.c:127!
Internal error: Oops - BUG: 0 [#1] PREEMPT ARM
Posts: 3
Joined: Sat Feb 23, 2013 8:41 am
by GMR » Sat Feb 23, 2013 6:30 pm
Hey Kostja,

today i received the new NIC an few minutes ago i compiled the driver for the Digitus DN-3023 USB3.0 1Gbps NIC (=ASIX AX88179 Chip) and it works perfectly.

I think, you must use an other NIC or you must find a person, which can repair the dm9601 driver etc. I can't, so i bought the new nic for ~20 euro.

My installation steps for the DN-3023 (Raspbian Wheezy) were:
  • via aptitude: install kernel linux-image-3.2.0-4-rpi and header linux-headers-3.2.0-4-rpi
  • change the kernel, which will be booted (for example type into console: mv /boot/vmlinuz-3.2.0-4-rpi /boot/kernel.img)
  • Restart (now it boots the 3.2.xx Kernel)
  • download the Asix-AX88179 Driver (http://www.asix.com.tw/FrootAttach/driv ... CE.tar.bz2)
  • unpack the Driver (tar -xf AX88179_178A_LINUX_DRIVER_v1.3.0_SOURCE.tar.bz2)
  • change into the extracted folder (cd AX88179_178A_LINUX_DRIVER_v1.3.0_SOURCE)
  • type make and Enter (now the module will be built automatically)
  • type make install and Enter (now the built module will be installed automatically)
  • edit the file /etc/modules and insert the modulname (for example type: echo ax88179_178a >> /etc/modules and Enter) (now the module ax88179_178a will be loaded while booting)
  • Reboot and you can use the NIC
Posts: 5
Joined: Thu Feb 21, 2013 1:37 am
by Kostja » Tue Feb 26, 2013 9:35 am
Thanks! Good to know that AX88179 based USB NICs work!
Posts: 3
Joined: Sat Feb 23, 2013 8:41 am
by Kostja » Tue Feb 26, 2013 9:41 am
BTW attached is my error screen with the DM9601

20130223_094946.jpg (58.96 KiB) Viewed 7683 times
Posts: 3
Joined: Sat Feb 23, 2013 8:41 am
by GMR » Tue Feb 26, 2013 12:22 pm
few days later i can say, that the ax88179 based NIC works very well. over 2 million send and received packets, but only 10 tx/rx errors.

With the dm9601 i got thousands of errors in few seconds.
Posts: 5
Joined: Thu Feb 21, 2013 1:37 am
by rfreire » Tue Apr 30, 2013 3:24 pm

I ended buying this device and found that Davicom dm9601 is part of Hall of shame, at http://elinux.org/RPi_VerifiedPeriphera ... t_adapters .

Worst, while checking its advertised USB amp requirements, I found that this device, despite of having at least 8 mentions to USB 2.0 in its package, is actually a USB 1.1 device, which means, 12 Mbps throughput to the host, even if the PHY per se is 100 Mbps capable.

Run lsusb -v, seek for bcdUSB field.

Posts: 5
Joined: Tue Apr 30, 2013 3:17 pm
by AndrewJohnson » Fri Aug 09, 2013 7:50 am
I was searching for info on this error and to fix it, what I have tried is to SWITCH OFF the power management on the USB dongle, thus:

Code: Select all
 sudo iwconfig wlan0 power off

You can do this in rc.local - and it seems to improve the "ping" time too!

It's been running fine for about 3 of days now - it crashed with this kernel error after 1 days before... My set up WAS sensitive to the power issue - and worked better when powered from a USB hub, although I could retest it with power from Pi and power management off (ironically).
Posts: 20
Joined: Mon Jul 30, 2012 7:34 am
Location: Derbs UK
by rob+pi » Mon Jan 19, 2015 10:52 pm
Fed up after buying a DM9601 based adaptor I found a Kernel patch
https://github.com/kmtaylor/rpi_patches ... -bug.patch
I could not find anyone blogging about it or how to install the fix.

So after getting it to work I have written up my exploits
http://jumpstation.co.uk/flog/Jan2015.h ... 0120151932
Posts: 15
Joined: Fri Jan 11, 2013 12:17 am