Kuribolt
Posts: 4
Joined: Fri Dec 28, 2012 12:23 pm

Raspbian Laggy/Slow?

Fri Dec 28, 2012 12:30 pm

I finally got myself a Raspberry Pi (For christmas) I was hoping to get Android 4.0 installed but from what i gather broadcom is still working on fixing the Audio at the moment so i decided the next best thing would be Raspbian, i've installed it successfully both myself via the image and via BerryBoot (both latest versions of raspbian) it loads fine and i get to the desktop but its so slow! No so much booting up but once you get to the desktop the cursor lags/jumps, menus are so laggy loading and everything is just killing slow. Is this just because of the Raspberry Pi's lack of power or is something wrong? Both the normal and "Pisces+MATE Images" version of raspbian were really really laggy/so slow! Can anyone shed some light on this?

Also weirdy "RaspRazor" verison was just fine! However a little barebone :'3 I'd really just like either the normal Raspbian or Arch ARM although that looks a little tricky to install.

Any help would be greatly appreciated! :)

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5171
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Raspbian Laggy/Slow?

Fri Dec 28, 2012 12:56 pm

Was the RaspRazor installed on same sdcard? The difference between a good and bad sdcard could explain the problem.

Worth checking dmesg in case usb or sdcard are throwing up errors. These are often caused by an insufficient sdcard, or an incompatible USB device.
http://elinux.org/R-Pi_Troubleshooting# ... r_problems

Cloudcentric
Posts: 982
Joined: Fri Sep 14, 2012 9:13 am

Re: Raspbian Laggy/Slow?

Fri Dec 28, 2012 1:02 pm

I find Raspbian fine, as long one does not multi-task...

Is you Power Supply adequate ie 5v 1A+ ?

Using Class 4,6 or 10 SDCards ?

Have you overclocked and altered the memory split ?

This is my web blog which is very very basic but may give some pointers, also has links to my ARM and Slack blogs which again are very very very basic.

http://debianarmpi.blogspot.co.uk
I know everything about nothing"

Kuribolt
Posts: 4
Joined: Fri Dec 28, 2012 12:23 pm

Re: Raspbian Laggy/Slow?

Fri Dec 28, 2012 5:10 pm

Hi, thanks for the help. I only ever had 1 version of raspbian on the SD can at a time, no dual booting or anything. The SD card is a 16GB class 10 so hopefully not that, Is a Razor gaming mouse which does use alot of power along with a usb logitech so i might be a power issue. If anyone has any more ideas please fire away :3

Edit - I have no split any memory or overclocked it, i have the newest 512mb Pi.

DukeOfTarporley
Posts: 18
Joined: Tue Aug 30, 2011 4:15 pm

Re: Raspbian Laggy/Slow?

Fri Dec 28, 2012 7:26 pm

dont be afraid to use turbo mode/over clock

jfornango
Posts: 113
Joined: Fri Sep 14, 2012 7:46 pm
Location: St. Louis, MO USA
Contact: Yahoo Messenger

Re: Raspbian Laggy/Slow?

Tue Feb 12, 2013 5:25 pm

If you look in the lower right corner, you will see a CPU meter running. Is it maxed out (completely green), or does it look like normal utilization?

If it is maxed, the you'll want to see what process is sucking up all of your cycle time. (You mentioned a gaming mouse. maybe sdriver software that wasn't written for this particular distro?)
I'm only wearing black until they find something darker.

Gomoto
Posts: 106
Joined: Tue Feb 12, 2013 1:21 am

Re: Raspbian Laggy/Slow?

Tue Feb 12, 2013 7:52 pm

Be afraid of turbo mode ;-)
Have been there and trashed my first sd filesystem.

Second day pi user here. I am now using a medium overclock and the recent raspian image (09.Feb.13).

I am on a 1980x1050 screen and removed icons and the background image. I think the new raspian image is a bit snappier as well. But I definitly improved responsiveness by changing to another mouse.

Ok, perhaps I have to adjust to slower response on menu select and button press. But I also have to adjust to absolute silence and 99% less power usage (down from 300 Watt to 3 Watt)

I use netsurf for browsing (tipp: change forum theme) and libre office is really usable as well.

Try medium overclock and the new raspian image with another mouse/keyboard if you got one around.

Gomoto
Posts: 106
Joined: Tue Feb 12, 2013 1:21 am

Re: Raspbian Laggy/Slow?

Wed Feb 13, 2013 1:09 am

I have to confirm there seems to be a usb related problem. With an old Logitech G5 I get even better results than with both of my Razer mice (wired Mamba, Imperator). With the Razer mice the LXDE Menu would loose focus and close itself before I select an entry, especially if i moved them to fast. Not all button clicks with the razers where registered. With the logitech it works flawless, it is not faster but it responds exactly as it should each time.

Gomoto
Posts: 106
Joined: Tue Feb 12, 2013 1:21 am

Re: Raspbian Laggy/Slow?

Wed Feb 13, 2013 11:29 am

Possible solution, worked for me.

add the kernel option:

usbhid.mousepoll=8

to /boot/cmdline.txt

CPU usage while mouse movement down to 50% from 100% without this option.

Return to “Raspbian”