Graylorde
Posts: 3
Joined: Fri Feb 07, 2020 10:55 am

Raspbian on Pi4 suddenly not displaying to hdmi monitor.

Fri Feb 07, 2020 11:19 am

Hello! I'm really distraught as I finally had set up my arcade machine how I wanted and was finally happy with how everything looked and worked.
Yesterday I shut it off using the shut down function in the desktop as normal. I waited a little bit to make sure that the pi had powered off, since it's built into the cabinet I cannot tell by the lights on the board.
I then realized my pc was still connected to the pi via WinSCP, and looking for a connection. I rebooted the pi just to check that I wasn't in the middle of uploading something, but it seems I had just forgotten to disconnect first. And so I powered it back down.

But now I came back to this: https://youtu.be/mG3O1z73TYY
All it displays while on is a underscore in the top left corner.

I still get the NOOBS boot options and I can still connect through WinSCP, so the OS seems to be functioning, but not displaying.
I am currently in the process of backing up the home folder in case I have to reinstall the OS.
But I'm wondering, can I somehow send commands remotely and have it update/reinstall important packages in hopes of reinstalling whatever went wrong? Or do you have any other suggestions?

My most recent change is installing xscreensaver to power off the monitor after 60 minutes. Nothing happened after 1 hour, so I set the screen blanking to turn on after 60 minutes as well (it was previously off) since I'm not sure if the power options are dependent on screen blanking being enabled. I didn't have time to test it out before powering down. Could xscreensaver be confused and powering down the output continously? I did notice earlier when I used an actual screensaver that it would launch with the screensaver already activated.

spl23
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 403
Joined: Fri Dec 26, 2014 11:02 am

Re: Raspbian on Pi4 suddenly not displaying to hdmi monitor.

Fri Feb 07, 2020 1:17 pm

When you are logged in over SCP, check that you haven't filled up the SD card and run out of free space; the symptom you describe (flashing cursor and no desktop) can be caused by a full SD card.

Graylorde
Posts: 3
Joined: Fri Feb 07, 2020 10:55 am

Re: Raspbian on Pi4 suddenly not displaying to hdmi monitor.

Fri Feb 07, 2020 8:46 pm

Interesting. Thanks for the suggestion, my setup supposedly had 9gb's left (on a 256gb card). I deleted some content from my raspberry, and sure enough it booted straight up.

Thanks for your help! I was so certain my arcade cabinet was a lost cause.

Return to “Raspberry Pi OS”