Page 1 of 2

USB dial-up modem

Posted: Wed Dec 19, 2012 11:30 pm
by DIYKiwi
Hi RPi world!

I am a secondary school teacher from Wellington, NZ, trying out the rpi at home before possibly launching it at school next year. Problem is, I don't have broadband/ethernet at home, just the old-fashioned dial-up.

So, I can't use apt-get! :(

My PRi runs Raspbian Wheezy on a 16GB SD card which I built with win32discimager.

In past months I've already had a go at trying to get a Conexant usb dial-up modem going on my laptop with Linux Mint 13KDE, to no avail. I then loaded Puppy Slacko onto my work laptop (deleted Mint) and this distro was easy as it immediately recognised the modem & connected to my ISP. :D I love Puppy for this.

Now I have a new RPi board set up and am struggling once again to get the USB modem working. After googling around a bit on the (dial-up!) laptop, I've tried all the following:
1) Try DPKG, aptitude, to install USB-modeswitch plus data package along with libusb - no joy here either, although libusb-0.1.12 did seem to install fully. I think after this that maybe I don't need USB_modeswitch anyway as it doesn't have windows drivers built into the chip?
2) Try to install the conexant USB modem's linux drivers that came on a disk with the device. I tried installing the .deb plus the .tar.gz versions but neither would install. The dgcmodem-1.13.tar.gz wouldn't even decompress/unzip, saying "unexpected end of file...Child returned status 1...error is not recoverable, etc.
3) Copy the ppp folder from Puppy & try to load this on the RPi - didn't work.

My question is, does anyone know whether it should be possible to get a USB dial-up modem working on the RPi? How does one go about this?

Perhaps, the ARM architecture doesn't support the modem's drivers? Is there a place where I can download an ARM-compatible driver? I couldn't find anything on linuxant. Should I try loading Puppy onto the SD card and use that distro instead of Raspbian Wheezy? Do the versions of Puppy available on this PRi website support dial-up?

Any thoughts from others who've gone down this path would be greatly appreciated.
Kind Regards,
PS: going up to paint the roof now!

Re: USB dial-up modem

Posted: Thu Dec 20, 2012 10:24 pm
by Sander
A Conexant usb modem? Isn't that a so-called winmodem? If so, it could very well that it won't work on Linux-on-ARM. Reason: winmodems were made for Windows, were some of the handling was done on Windows, with Windows-only drivers. Some of them later on worked on Linux (drivers via But ... my guess is those binary drivers are for x86. Not for ARM.

Things to try:

Put in the modem, and type "lsusb". Post and Google the line with the USB-modem.

Furthermore: if it works under Puppy (on X86), you could consider setting up connection sharing so that the Raspi can connect via Wifi/Ethernet via Puppy to Internet. I don't know if that is easy on Puppy.

Other possibilities:
Put a Wifi dongle in your Raspi, and go online via the neighbor's wifi network (if there is)
Put a Wifi dongle in your Raspi, and go online via your Android phone using tethering
Put a 3G dongle in your Raspi
(Long shot) Find a real, old-skool RS232-modem (early/mid-90's) and a USB-to-RS232 connector (see ... sort=Price), and try if you can do a "ATDT"


PS: It was somewhere in the 90's I used a modem for the last time. In 1998 I switched to ISDN, and in 2000 to ADSL. Now on VDSL, and on Fiber in a few months...
I threw away my modems some time ago.

PS2: shows drivers ... with explicitly specced for which platform: x86 or PPC. So that seems to confirm my idea it's binary driver for a specific platform/processor. And not available for Linux on ARM.

Re: USB dial-up modem

Posted: Thu Dec 20, 2012 10:42 pm
by Sander
And now some better news: ... ull.tar.gz is the link to the ... source. Interesting.

I was able to "sudo make install" on my Ubuntu on AMD64. Maybe it works on ARM too? If so, let's hope the hcfpcimodem also understands your USB modem ...

Re: USB dial-up modem

Posted: Fri Dec 21, 2012 9:55 am
by DIYKiwi
Thanks for the tips & ideas. I hadn't thought of tethering my android phone - will try that. I'll give the other ideas a go too & post to say how I got on.
Once again, thanks.

Re: USB dial-up modem

Posted: Fri Dec 21, 2012 6:23 pm
by pksato
You have a laptop, and modem works on it. right?

You can use laptop as "router" to R-Pi.
Need a CAT5 cable (crossover is preferable) to interconnect laptop and R-Pi. And some way to activate connection sharing.
On most linux box, command above share a connection:

Code: Select all

# share a connection on ppp0 (NAT)
iptables -I POSTROUTING -o ppp0 -j MASQUERADE
# route all packets
iptables -I FORWARD -j ACCEPT
# Activate routing on kernel
echo 1 >/proc/sys/net/ipv4/ip_forward

# Configure a ip on laptop ethernet, eth0 
# or use network manage system of distro in use.
ifconfig eth0 netmask
On Rapberry Pi. Login as root (sudo su -)

Code: Select all

# set a ip to eth0 
ifconfig eth0 netmask
# or configure /etc/network/interfaces
# a default route, ip of linux laptop
route add defaut gw
# a name server
echo "nameserver" >>/etc/resolv.conf
# test connection, if have a response, is ok.
ping -c 10
ping -c 10
ping -c
# update raspbian
aptitude update
aptitude full-upgrade
Happy Holidays.

Re: USB dial-up modem

Posted: Fri Dec 21, 2012 8:26 pm
by Bright Sparks NZ
How would a USB/Serial solution go ? I am interested in this approach as a method or serial interfacing for Dial Up and a few other ideas besides. There is a serial UART on the I/O lines as well I hope to investigate for picaxe interfacing. This will need inverting as I suspect it is TTL. Looking forward to learning about Pi and adding Pi to our courses. Planning on some specialist teacher workshops in 2013.
~ Andrew

Re: USB dial-up modem

Posted: Thu Dec 27, 2012 3:49 am
by DIYKiwi
Hi again, hope your Xmas went well :)
I have been playing around a bit with the Conexant USB modem in the spare moments. This modem does work on an HP laptop that dual-boots both Win7 and SlackoPuppy, and the modem runs in both OS (Puppy doesn't even need the driver installed - it must be pre-loaded in the kernel). It won't, however, run on RPI as the chip is ARM architecture, it seems. I know this because when I go to load the linux driver that came with the modem (sudo dpkg -i dgcmodem_1.01_i386.deb) it says "package architecture does not match system (armhf)". So, unless I can find a USB dial-up driver for ARM chipset, that's that! As dial-up is an old technology there is nothing I can find on the web. I may have to splash out in the new year and go broadband, but will need to discuss this with wife first!

As for my Android phone, I can plug this into the USB of the PRI and it will recognise it as an external drive, but won't use it as a modem in 'tethering' mode. I tried switching the phone's wireless on & hopefully connecting to my laptop's wireless, but this was not successful, the security code kept saying error. In any case I don't think that this would connect the RPI to the laptop, only the phone itself to the laptop. I could buy a wifi dongle for the RPI but my wife isn't keen on too many wifi devices and I wisely respect her wishes.

It would be nice to use my Android phone as a tethered modem, it works in Windows but then my Win7 laptop has the LG driver installed. I couldn't find any driver on the web for linux.

Does anyone know whether there is a linux driver available for an Android 2.3.3 phone?

I also tried the RPI-to-laptop as router using a network cable, diligently typed in the code that pksato kindly supplied, but that didn't seem to work. Neither device could talk to the other. I think I need to give this another go when I get a chance.

I'm just about to try the linuxant link that Sander posted & will get back about how that avenue goes.
Bye for now & Happy New Year :D

Re: USB dial-up modem

Posted: Thu Dec 27, 2012 4:20 am
by DIYKiwi
Me Again!
I just tried Sander's linuxant driver suggestion & it was looking good for the install until I came up against the same problem I had with linux mint maya a few months ago - namely it says I need to install a kernel package (before the modem driver will fully configure).

Here's the error & suggestion it spat out:
"No pre-built modules for: Debian-wheezy/sid linux-3.2.27+ armv6l

Trying to automatically build the driver modules...
Please install the 'kernel-headers-3.2.27+' package. You can install it with the 'apt-get install kernel-headers-3.2.27+' command.

Where is the linux source build directory that matches your running kernel?

You see the dilemma I face? Not having an ethernet/broadband connection, I now need one to get a dial-up modem working!!!!!

I guess I could download the kernel headers (slowly) via dial-up on the laptop then transfer & manually install them on a USB drive? Will try that.

Or if I can get the laptop router idea to work then I could download & transfer them quickly with Android phone tethered to laptop Win7 OS.

Back to work then....

Re: USB dial-up modem

Posted: Thu Dec 27, 2012 4:58 pm
by Sander
If you find this a nice project in itself, just continue :-)

However, if this is only a means to get the Raspi online and updated, I would advice to go for broadband (DSL or cable).

Re: USB dial-up modem

Posted: Fri Dec 28, 2012 12:08 am
by DIYKiwi
EXCITING - some Android phone success at last!

I finally got my android phone to tether to the RPI. I tried lots of suggestions but finally it came down to a simple command in the RPI terminal with the phone connected via usb cable & 'tethering' switched on :

sudo dhclient usb0

(I got this from ... 406-3.html)

I was then able to connect to the internet, launch & use NetSurf Web Browser, and, more importantly, type the "apt-get update" command in LXTerminal and get the device to update. Fantastic!

My phone is LG Optimus P500 running Gingerbread.

So, that done, I tried to return to the dial-up modem task & continue installing the hcfpci modem driver that Sander linked to this post.

However, after "sudo make install..." the system said that I had to install kernel headers 3.2.27+.
I found another forum topic, downloaded the kernel headers (via dial-up on laptop!) and transferred & installed them on the RPI with dpkg -i.

Then I had to re-run "hcfpciconfig" as the system had suggested. Unfortunately, the process couldn't complete & the buildlog says that "the installed hcfpci driver package is for i386, this is likely to fail..."

That was a shame, but the journey was interesting & I'm happy that at least the android phone tethering works well. I suspect that no-one has yet created any dial-up usb modem drivers for armv6 architecture. Why would they I suppose? Unless they were like me trying to save a few pennies on a single-income family budget...

Anyway, some succes to celebrate & my RPI is updated :)

Re: USB dial-up modem

Posted: Wed Jan 30, 2013 9:08 pm
by Wessix
hey i got a trendnert usb modem and its regognized by the kernel as conexant modem. Its a trendnet : ... elefon-fax

it gets regognized and shows up at /dev/ttyACM0
i can even dial out and the line gets blocked, at the moment i just get an ppp error and i'm stuck with this, cause i can't find a good tutorial for my ISP to set up a dial up connection in linux.

Don't know if that helps you in anyway. If could export drivers or something.

Re: USB dial-up modem

Posted: Thu Jan 31, 2013 7:23 am
by DIYKiwi
That sounds good, some progress. I have lately tried the newly created Squeezed ARM Puppy OS on my RasPi in the hope that it would be able to utilise my Conexant USB modem. It recognises it allright, and sends a ping to it, but cannot dial out or connect to the ISP. I suspect that the issue comes back once again to drivers for ARMv6. Anyway, good luck & when I get some spare moments I'll look into the trendnert modem drivers to see if it can be loaded & used.

Re: USB dial-up modem

Posted: Thu Jan 31, 2013 11:10 pm
by Wessix
good news here too,
i got it working, i was in the inet via modem !!!!

started from a new installed raspbian and installed gnome-ppp. then i disconected the pi from lan at tried a call by call number and it worked.

Re: USB dial-up modem

Posted: Sat Feb 02, 2013 5:44 am
by tonyhughes
Hey DIYKiwi, Im just up in Hawkes Bay.

A ton of options for internet especially knowing you have a working P500. I used to run FreeSCO on an old 486 with my dialup modem in it, which then fed out internet to 10 PCs on my LAN. It would still work today.

Another option is a WiFi router with 3G port, to plug a USB 3G modem in from Telecom, Vodafone, or 2 Degrees, then you can use WiFi with your PCs and ethernet with your Raspberry Pi.

Of course continuing to tether with your LG might be a good option.

Where do you live? Some ISPs will say you cant get DSL, but just arent trying hard enough...

Re: USB dial-up modem

Posted: Mon Feb 04, 2013 6:45 am
by DIYKiwi
Hi Tony, thanks for the ideas.
Now that Vodafone has upped my mobile data limit, I can use the phone in tethered mode more with RPi running Raspbian. However, since my wife doesn't want wifi (!) I'll have to pass on that option for now. We are in Porirua, Wellington.

Our landline has dial-up so I wanted to set up the RPi to run dial-up for my wife to use, as an eventual replacement for an old XP PC that we currently use with dial-up.

I haven't had a chance to check out the freeSCO option yet but will look at that soon.

I am impressed at how Wessix got a dial-up modem to work. Mine is detected but won't dial. I have modified the interfaces file slightly, plus played around a bit with the wv.dial file. I wonder would Wessix be able to post his/her text from these two files so that I could try emulating the settings?

My USB modem is also detected at /dev/ttyACM0 but something is stopping it from dialling.

Thanks & Kind Regards,

Re: USB dial-up modem

Posted: Mon Feb 04, 2013 6:52 am
by tonyhughes
If your XP machine is successfully dialling up, you should be able to use ICS (Internet Connection Sharing) built into XP to share the dialup connection to the ethernet (network) adapter. Plug the Pi into the XP machines ethernet port, and configure the IP and the Pi should be on the internet.

I don't have a Windows machine here, so I can't test and give you more detailed instructions sorry.

Re: USB dial-up modem

Posted: Tue Feb 05, 2013 9:52 pm
by DIYKiwi

I have my dial-up Conexant USB modem working & am posting this reply with RPi on dial-up!

It's taken two months of persistent fiddling around, but in the end the crucial yet probably very simple problem was my wvdial.conf file in /etc/. I had spent a lot of time playing around with trying to install drivers, fiddling with details in the /etc/ppp/ files, plus trying gnome-ppp, but it seems that wvdial is all I needed (I used android phone tethering to update to wvdial 1.61).

My setup is Raspi B (512MB) with a Dick Smith 13-port USB hub running USB keyboard & mouse, the dial-up modem plugging also into the USB hub.

These are the crucial settings in the wvdial.conf file:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Phone = clearnetprovidernumber
ISDN = 0
Password = mypassword
New PPPD = yes
Username = myusername
Modem = /dev/ttyACM0
Baud = 115200

So thanks to all who posted to this forum - you have all helped on what has been a very educational, sometimes frustrating, but ultimately successful RPi adventure!
Kind Regards,

Re: USB dial-up modem

Posted: Tue Feb 05, 2013 10:19 pm
by dasimpson
if your pc has a network card you could use Internet Connection Sharing on your pc so you would be sharing your dial up to the network card and to the pi

Re: USB dial-up modem

Posted: Thu Feb 07, 2013 7:13 am
by khingcat
What about to use USB dial-up modem on Xbian? Are there anyone try this? I'm completely newbie in Linux OS, so I need a detail guidance.

Re: USB dial-up modem

Posted: Fri Mar 15, 2013 2:38 am
by pixiedelion
Great discussion. I'm facing a RPi modem question myself, and was wondering if you could point me in the right direction. I want to build a thing for the office that logs the calls as they come in, so I can tell if my advertising really has an impact on the number of calls I get. Full caller ID would be great, but even the phone number would work.

So, I need the RPi to listen to the modem for incoming number. Log the call number (time would be nice). I can write the rest of the log parsing stuff, it's just the hardware communication that I don't know at all.

I had expected to use ncid, there isn't any RPi support.

I have a Linux supporting USB modem. Just not sure where to start

Thanks -w

Re: USB dial-up modem

Posted: Sun Mar 17, 2013 4:55 am
by JLPSupport
Very interresting topic. As pixiedelion, I would like to run ncid server on a RPi. But since I heard from it for the first time few days ago, I'm far from knowing anything about it. If anyone could guide me a bit on what usb modem to buy in 2013 and where to start from with the rest. I don't plan to run anything else than ncid from that device, at least for now.

Any help would be greatly appreciated.

Regards, JLPSupport

Re: USB dial-up modem

Posted: Sun Mar 17, 2013 9:49 am
by DIYKiwi
Hi Pixiedelion

It's out of my league to get the RPi to do what you want, but I wonder whether a stand-alone device such as a call logger would be an option. I just saw one at this URL: ... ogger.html. I presume that it would plug in between the phone jack and the RPi modem?

Check it out.


Re: USB dial-up modem

Posted: Sun Mar 17, 2013 6:36 pm
by sdjf
Hey guys, sorry I did not see this thread sooner, because I usually hang out in the Arch subforum.

I have been using a dialup modem on my model B 512 for months now. No need to install special drivers, I just had to get ppp working right.

The first step after plugging a dialup modem in, is to check your logs to see if it is recognized and attached to a driver! If it is, then you get to work, setting up ppp.

Sometimes a particular modem might not be recognized, even though it ought to be. There is a file called something like modules.aliases that assigns drivers to USB devices! So if your modem is not assigned a driver, it gets complicated, but if it is the same chipset as some other device in that file, you can just go in with a text editor and add a line for your modem's Vendor and Product number obtained from lsusb.

Sorry this is not a complete how to, but a start. I can think of three ways to get ppp running: via serial in minicom (or maybe screen?), using wvdial, or just using the pppconfig package.

I am using a USR 5637. In the end, I used either wvdial or pppconfig to start setting up the files, but opted out to just use the scripts in /etc/ppp as that was easier for me, since I already had dialup working on my PDAs and could copy what was needed on my Pi from them to the Pi.

Another thing is that even though I have taken my Pi online, I do not want to tie up the phone line downloading and installing packages for an undeterminate amount of time. So, I download the packages I need from approved repository mirrors and install them later when I want to. I do this with pacman on Arch, and am sure you can do the same thing with apt-get or it's variants. There are posts around the forum talking about offline package installation.

I am writing a guide for Arch users as to how to do that, but it will be a while before it is done, and am not sure it will be of any use to Raspbian/Debian users. But it is certainly possible. For me, dialup is the only way to go! And more power to you for sticking with dialup, it does what is needed, it just takes longer, and is more reasonable on the budget.

Re: USB dial-up modem

Posted: Sun Mar 24, 2013 10:12 pm
by priority
pixiedelion wrote: ...
I had expected to use ncid, there isn't any RPi support.
JLPSupport wrote:...
I would like to run ncid server on a RPi. ...
Take a look at ... 29#p311229 if you want to run ncid on your RPi.

Re: USB dial-up modem

Posted: Thu Feb 20, 2014 7:41 pm
by hugogarro
DIYKiwi wrote:My USB modem is also detected at /dev/ttyACM0 but something is stopping it from dialling.

Thanks & Kind Regards,
We have an old computer always running at my office, it works as a printing server and as a fax machine (It is also the launchroom computer for everyone to check on facebook and stuff). Nowdays we don't receive that many faxes, however once in a blue moon I get call to give a faxtone.

I figure that since this can be handled by a small computer why not a Raspberry Pi, my new project is moving everything form the old computer to a RBP. In the old computer we have a Conexant USB modem and it is running Linux Mint 13. With this I'am telling you that I have done a fair share of compiliing these drivers.

DIYkiwi would you point me into the right direction where to start, should I try a 386i.deb file or should I start with the .tar
file? .... I am guessing 386 is the architecture to start messing around, what worked for you?