mtylerb
Posts: 35
Joined: Sat Apr 07, 2018 3:14 am
Location: Warburg, AB, Canada

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Tue Feb 04, 2020 3:08 pm

drdyer9051 wrote:
Tue Feb 04, 2020 2:50 pm
please help a noob

I have a freshly loaded 4G Pi4 running buster.

cannot get past step 2

Code: Select all

pi@raspberrypi:~/Minecraft $ cd ~/Minecraft && /opt/jdk/jdk1.8.0_211/bin/java -jar Minecraft.jar
Exception in thread "main" java.awt.HeadlessException: 
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
	at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:204)
	at java.awt.Window.<init>(Window.java:536)
	at java.awt.Frame.<init>(Frame.java:420)
	at javax.swing.JFrame.<init>(JFrame.java:233)
	at net.minecraft.bootstrap.Bootstrap.<init>(Bootstrap.java:45)
	at net.minecraft.bootstrap.Bootstrap.main(Bootstrap.java:378)
pi@raspberrypi:~/Minecraft $ 
this is java version

Code: Select all

pi@raspberrypi:~/Minecraft $ java -version
openjdk version "1.8.0_212"
OpenJDK Runtime Environment (build 1.8.0_212-8u212-b01-1+rpi1-b01)
OpenJDK Client VM (build 25.212-b01, mixed mode)
pi@raspberrypi:~/Minecraft $ 
thank you
Bradley
You can't do this over SSH, if that's what is happening. Has to be done from the desktop CLI.

Code: Select all

 No X11 DISPLAY variable was set, but this program performed an operation which requires it. 

drdyer9051
Posts: 6
Joined: Thu Aug 16, 2018 5:55 pm

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Tue Feb 04, 2020 3:44 pm

wow that was quick thank you

I have a 2G Pi4 and it was able to get further

i got error

Code: Select all

pi@raspberrypi:~/Minecraft $ mousepad runMC1_14_4_OptifineF3.sh
bash: mousepad: command not found
clarification I have both a 2G and 4G Pi4's and am trying my best to get one of them running for my 8yo
Last edited by drdyer9051 on Tue Feb 04, 2020 3:56 pm, edited 1 time in total.

User avatar
rpiMike
Posts: 1463
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Tue Feb 04, 2020 3:56 pm

drdyer9051 wrote:
Tue Feb 04, 2020 3:44 pm
wow that was quick thank you

I have a 2G Pi4 and it was able to get further

i got error

Code: Select all

pi@raspberrypi:~/Minecraft $ mousepad runMC1_14_4_OptifineF3.sh
bash: mousepad: command not found
If mousepad isn't installed try leafpad.

Code: Select all

leafpad runMC1_14_4_OptifineF3.sh
Or just use any text editor to edit the file.

drdyer9051
Posts: 6
Joined: Thu Aug 16, 2018 5:55 pm

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Tue Feb 04, 2020 4:19 pm

:D :D :D :D :D

got it working on the 2G Pi4

will restart from ground zero on the 4G Pi4

thank you so much for the help it is greatly appreciated

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Wed Feb 05, 2020 11:27 am

mtylerb wrote:
Fri Jan 03, 2020 7:25 pm
TamaTamaGoGo wrote:
Wed Jan 01, 2020 12:17 pm
mtylerb wrote:
Tue Dec 31, 2019 7:16 pm




Already done... Tutorial/scripts available here... viewtopic.php?f=66&t=260357
Nice :D
Thank you :)
タマタマゴーゴーさん、大歓迎です!
Am...
I downloaded and run your script.
But mine runOptifi~~~.sh is not working.
It says
pi@raspberrypi:~/.minecraft $ /home/pi/.minecraft/runMC1_14_4_OptifineF3.sh
~~~~~~~~~~
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Error occurred during initialization of VM
Could not reserve enough space for 2097152KB object heap
pi@raspberrypi:~/.minecraft $
It says, It can't make? someKB''s file... :?
Could you Check and fix bag? :?:
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

mtylerb
Posts: 35
Joined: Sat Apr 07, 2018 3:14 am
Location: Warburg, AB, Canada

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Wed Feb 05, 2020 2:31 pm

TamaTamaGoGo wrote:
Wed Feb 05, 2020 11:27 am
mtylerb wrote:
Fri Jan 03, 2020 7:25 pm
TamaTamaGoGo wrote:
Wed Jan 01, 2020 12:17 pm


Nice :D
Thank you :)
タマタマゴーゴーさん、大歓迎です!
Am...
I downloaded and run your script.
But mine runOptifi~~~.sh is not working.
It says
pi@raspberrypi:~/.minecraft $ /home/pi/.minecraft/runMC1_14_4_OptifineF3.sh
~~~~~~~~~~
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Error occurred during initialization of VM
Could not reserve enough space for 2097152KB object heap
pi@raspberrypi:~/.minecraft $
It says, It can't make? someKB''s file... :?
Could you Check and fix bag? :?:
How much RAM do you have on this Pi?
Could not reserve enough space for 2097152KB object heap
Seems to indicate a smaller RAM value.

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Thu Feb 06, 2020 10:42 am

mtylerb wrote:
Wed Feb 05, 2020 2:31 pm
TamaTamaGoGo wrote:
Wed Feb 05, 2020 11:27 am
mtylerb wrote:
Fri Jan 03, 2020 7:25 pm


タマタマゴーゴーさん、大歓迎です!
Am...
I downloaded and run your script.
But mine runOptifi~~~.sh is not working.
It says
pi@raspberrypi:~/.minecraft $ /home/pi/.minecraft/runMC1_14_4_OptifineF3.sh
~~~~~~~~~~
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Error occurred during initialization of VM
Could not reserve enough space for 2097152KB object heap
pi@raspberrypi:~/.minecraft $
It says, It can't make? someKB''s file... :?
Could you Check and fix bag? :?:
How much RAM do you have on this Pi?
Could not reserve enough space for 2097152KB object heap
Seems to indicate a smaller RAM value.
Oh no!
I am using Rpi3B+!
I think it have 1GB RAM?
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Thu Feb 06, 2020 11:04 am

About runMC1_14_4_OptifineF3.sh
/opt/jdk/jdk1.8.0_211/bin/java -Xmx2G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn1G -Djava.library.path=/home/pi/lwjgl3arm32 -Dminecraft.launcher.brand=java-minecraft-launcher -Dminecraft.launcher.version=1.6.89-j -cp /home/pi/.minecraft/libraries/optifine/OptiFine/1.14.4_HD_U_F3/OptiFine-1.14.4_HD_U_F3.jar:/home/pi/.minecraft/libraries/optifine/launchwrapper-of/2.1/launchwrapper-of-2.1.jar:/home/pi/.minecraft/libraries/com/mojang/patchy/1.1/patchy-1.1.jar:/home/pi/.minecraft/libraries/oshi-project/oshi-core/1.1/oshi-core-1.1.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/jna/4.4.0/jna-4.4.0.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/platform/3.4.0/platform-3.4.0.jar:/home/pi/.minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar:/home/pi/.minecraft/libraries/com/mojang/javabridge/1.0.22/javabridge-1.0.22.jar:/home/pi/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/5.0.3/jopt-simple-5.0.3.jar:/home/pi/.minecraft/libraries/io/netty/netty-all/4.1.25.Final/netty-all-4.1.25.Final.jar:/home/pi/.minecraft/libraries/com/google/guava/guava/21.0/guava-21.0.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-lang3/3.5/commons-lang3-3.5.jar:/home/pi/.minecraft/libraries/commons-io/commons-io/2.5/commons-io-2.5.jar:/home/pi/.minecraft/libraries/commons-codec/commons-codec/1.10/commons-codec-1.10.jar:/home/pi/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar:/home/pi/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar:/home/pi/.minecraft/libraries/com/mojang/brigadier/1.0.17/brigadier-1.0.17.jar:/home/pi/.minecraft/libraries/com/mojang/datafixerupper/2.0.24/datafixerupper-2.0.24.jar:/home/pi/.minecraft/libraries/com/google/code/gson/gson/2.8.0/gson-2.8.0.jar:/home/pi/.minecraft/libraries/com/mojang/authlib/1.5.25/authlib-1.5.25.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar:/home/pi/.minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar:/home/pi/.minecraft/libraries/it/unimi/dsi/fastutil/8.2.1/fastutil-8.2.1.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-api/2.8.1/log4j-api-2.8.1.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-core/2.8.1/log4j-core-2.8.1.jar:/home/pi/lwjgl3arm32/lwjgl-glfw.jar:/home/pi/lwjgl3arm32/lwjgl-jemalloc.jar:/home/pi/lwjgl3arm32/lwjgl-openal.jar:/home/pi/lwjgl3arm32/lwjgl-opengl.jar:/home/pi/lwjgl3arm32/lwjgl-stb.jar:/home/pi/lwjgl3arm32/lwjgl.jar:/home/pi/lwjgl3arm32/libjemalloc.so:/home/pi/lwjgl3arm32/libopenal.so:/home/pi/lwjgl3arm32/liblwjgl_opengl.so:/home/pi/lwjgl3arm32/libglfw.so:/home/pi/lwjgl3arm32/liblwjgl_stb.so:/home/pi/lwjgl3arm32/liblwjgl.so:/home/pi/lwjgl3arm32/lwjgl-jemalloc-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-openal-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-opengl-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-glfw-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-stb-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-natives-linux-arm64.jar:/home/pi/.minecraft/libraries/com/mojang/text2speech/1.11.3/text2speech-1.11.3.jar:/home/pi/.minecraft/versions/1.14.4-OptiFine_HD_U_F3/1.14.4-OptiFine_HD_U_F3.jar net.minecraft.launchwrapper.Launch \
--username $MINECRAFT_USERNAME \
--accessToken "$MINECRAFT_ATOKEN" \
--uuid "$MINECRAFT_UUID" \
--version $MINECRAFT_VERSION \
--userProperties {} \
--gameDir ~/.minecraft \
--assetsDir ~/.minecraft/assets \
--assetIndex $MINECRAFT_VERSION \
--tweakClass $TWEAK_CLASS
To
/opt/jdk/jdk1.8.0_211/bin/java \
-Xmn128M -Xmx1024M \
-XX:+UseConcMarkSweepGC \
-XX:+CMSIncrementalMode \
-XX:-UseAdaptiveSizePolicy \
-Djava.library.path=$MINECRAFT_NATIVE_PATH \
-cp $CP \
net.minecraft.launchwrapper.Launch \
--username $MINECRAFT_USERNAME \
--accessToken "$MINECRAFT_ATOKEN" \
--uuid "$MINECRAFT_UUID" \
--version $MINECRAFT_VERSION \
--userProperties {} \
--gameDir ~/.minecraft \
--assetsDir ~/.minecraft/assets \
--assetIndex $MINECRAFT_VERSION \
--tweakClass $TWEAK_CLASS
Is that possible? :(

And script what I made is not working...
It says that it can’t find lwjgl3arm32 File...
So if that script can run, I will use it.
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

mtylerb
Posts: 35
Joined: Sat Apr 07, 2018 3:14 am
Location: Warburg, AB, Canada

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Thu Feb 06, 2020 12:28 pm

TamaTamaGoGo wrote:
Thu Feb 06, 2020 11:04 am
About runMC1_14_4_OptifineF3.sh
/opt/jdk/jdk1.8.0_211/bin/java -Xmx2G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn1G -Djava.library.path=/home/pi/lwjgl3arm32 -Dminecraft.launcher.brand=java-minecraft-launcher -Dminecraft.launcher.version=1.6.89-j -cp /home/pi/.minecraft/libraries/optifine/OptiFine/1.14.4_HD_U_F3/OptiFine-1.14.4_HD_U_F3.jar:/home/pi/.minecraft/libraries/optifine/launchwrapper-of/2.1/launchwrapper-of-2.1.jar:/home/pi/.minecraft/libraries/com/mojang/patchy/1.1/patchy-1.1.jar:/home/pi/.minecraft/libraries/oshi-project/oshi-core/1.1/oshi-core-1.1.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/jna/4.4.0/jna-4.4.0.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/platform/3.4.0/platform-3.4.0.jar:/home/pi/.minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar:/home/pi/.minecraft/libraries/com/mojang/javabridge/1.0.22/javabridge-1.0.22.jar:/home/pi/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/5.0.3/jopt-simple-5.0.3.jar:/home/pi/.minecraft/libraries/io/netty/netty-all/4.1.25.Final/netty-all-4.1.25.Final.jar:/home/pi/.minecraft/libraries/com/google/guava/guava/21.0/guava-21.0.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-lang3/3.5/commons-lang3-3.5.jar:/home/pi/.minecraft/libraries/commons-io/commons-io/2.5/commons-io-2.5.jar:/home/pi/.minecraft/libraries/commons-codec/commons-codec/1.10/commons-codec-1.10.jar:/home/pi/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar:/home/pi/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar:/home/pi/.minecraft/libraries/com/mojang/brigadier/1.0.17/brigadier-1.0.17.jar:/home/pi/.minecraft/libraries/com/mojang/datafixerupper/2.0.24/datafixerupper-2.0.24.jar:/home/pi/.minecraft/libraries/com/google/code/gson/gson/2.8.0/gson-2.8.0.jar:/home/pi/.minecraft/libraries/com/mojang/authlib/1.5.25/authlib-1.5.25.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar:/home/pi/.minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar:/home/pi/.minecraft/libraries/it/unimi/dsi/fastutil/8.2.1/fastutil-8.2.1.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-api/2.8.1/log4j-api-2.8.1.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-core/2.8.1/log4j-core-2.8.1.jar:/home/pi/lwjgl3arm32/lwjgl-glfw.jar:/home/pi/lwjgl3arm32/lwjgl-jemalloc.jar:/home/pi/lwjgl3arm32/lwjgl-openal.jar:/home/pi/lwjgl3arm32/lwjgl-opengl.jar:/home/pi/lwjgl3arm32/lwjgl-stb.jar:/home/pi/lwjgl3arm32/lwjgl.jar:/home/pi/lwjgl3arm32/libjemalloc.so:/home/pi/lwjgl3arm32/libopenal.so:/home/pi/lwjgl3arm32/liblwjgl_opengl.so:/home/pi/lwjgl3arm32/libglfw.so:/home/pi/lwjgl3arm32/liblwjgl_stb.so:/home/pi/lwjgl3arm32/liblwjgl.so:/home/pi/lwjgl3arm32/lwjgl-jemalloc-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-openal-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-opengl-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-glfw-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-stb-natives-linux-arm64.jar:/home/pi/lwjgl3arm32/lwjgl-natives-linux-arm64.jar:/home/pi/.minecraft/libraries/com/mojang/text2speech/1.11.3/text2speech-1.11.3.jar:/home/pi/.minecraft/versions/1.14.4-OptiFine_HD_U_F3/1.14.4-OptiFine_HD_U_F3.jar net.minecraft.launchwrapper.Launch \
--username $MINECRAFT_USERNAME \
--accessToken "$MINECRAFT_ATOKEN" \
--uuid "$MINECRAFT_UUID" \
--version $MINECRAFT_VERSION \
--userProperties {} \
--gameDir ~/.minecraft \
--assetsDir ~/.minecraft/assets \
--assetIndex $MINECRAFT_VERSION \
--tweakClass $TWEAK_CLASS
To
/opt/jdk/jdk1.8.0_211/bin/java \
-Xmn128M -Xmx1024M \
-XX:+UseConcMarkSweepGC \
-XX:+CMSIncrementalMode \
-XX:-UseAdaptiveSizePolicy \
-Djava.library.path=$MINECRAFT_NATIVE_PATH \
-cp $CP \
net.minecraft.launchwrapper.Launch \
--username $MINECRAFT_USERNAME \
--accessToken "$MINECRAFT_ATOKEN" \
--uuid "$MINECRAFT_UUID" \
--version $MINECRAFT_VERSION \
--userProperties {} \
--gameDir ~/.minecraft \
--assetsDir ~/.minecraft/assets \
--assetIndex $MINECRAFT_VERSION \
--tweakClass $TWEAK_CLASS
Is that possible? :(

And script what I made is not working...
It says that it can’t find lwjgl3arm32 File...
So if that script can run, I will use it.
The lwjgl3arm32 file is built into my script, but if you're using a RasPi 3B+, this won't work. Needs to be a minimum of 2GB RAM, 4GB is better.

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Fri Feb 07, 2020 1:39 pm

mtylerb wrote:
Thu Feb 06, 2020 12:28 pm
TamaTamaGoGo wrote:
Thu Feb 06, 2020 11:04 am
About runMC1_14_4_OptifineF3.sh
/opt/jdk/jdk1.8.0_211/bin/java -Xmx2G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn1G -Djava.library.path=/home/pi/lwjgl3arm32 -Dminecraft.launcher.brand=java........
To Is that possible? :(

And script what I made is not working...
It says that it can’t find lwjgl3arm32 File...
So if that script can run, I will use it.
The lwjgl3arm32 file is built into my script, but if you're using a RasPi 3B+, this won't work. Needs to be a minimum of 2GB RAM, 4GB is better.
Thanks for your great advice!
Yeah, I am using RasPi 3B+.
So I will play and enjoy with minecraft 1.12.2 :lol:
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Sun Feb 09, 2020 12:47 pm

TamaTamaGoGo wrote:
Fri Feb 07, 2020 1:39 pm
mtylerb wrote:
Thu Feb 06, 2020 12:28 pm
TamaTamaGoGo wrote:
Thu Feb 06, 2020 11:04 am
About runMC1_14_4_OptifineF3.sh


The lwjgl3arm32 file is built into my script, but if you're using a RasPi 3B+, this won't work. Needs to be a minimum of 2GB RAM, 4GB is better.
Thanks for your great advice!
Yeah, I am using RasPi 3B+.
So I will play and enjoy with minecraft 1.12.2 :lol:
I bought raspi4 modelB RAM4GB.
I bought Case and fan too!!
I will try your script.
Thank you :)
🙇

I got Raspi4!
I am trying, and changing!
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4. I am trying to make 1.14.4 forge script && 1.15.2 OptiFine & Forge!

Wed Feb 19, 2020 7:16 am

Hello!
Thank you for your good script!
So, I will Contribution to your projects!

Ok, I will tell you what I am trying to make.
  • Minecraft 1.14.4 with forge - It’s difficult!
  • Minecraft 1.15.2 with OptiFine - It’s easier than making forge script
  • Minecraft 1.15.2 with forge - Same level than Minecraft 1.14.4 for forge
If you have or get any information, Please Tell Me! :idea:

P.S. Now
  • Minecraft Forge sound - Solved
Salawat wrote:
Sun Jan 12, 2020 3:33 am
~~~~~

Code: Select all

cp ~/.minecraft/assets/indexes/1.14.json ~/.minecraft/assets/indexes/1.14.4-forge1.14.4-28.1.0.json
That's it. Music, block sounds, and everything else is working just fine. It's just that the installer from forge forgets to do that little step. Use the run script I posted yesterday, and you should be golden.
~~~~~
  • Research script for running Forge - Now developing
Oh.
I need to try download Forge and OptiFine version to get Minecraft UUID and CLIENTTOKEN.
  • Research script for running OptiFine - Now developing
  • Making tutorial for Minecraft 1.14.4 for Forge - PASS
Minecraft Forge for 1.14.4 to 1.15.2 is ready!
  • Making tutorial for Minecraft 1.15.2 for OptiFine - Not yet
Waiting to OptiFine 1.15.2
  • Making tutorial for Minecraft 1.15.2 for Forge - Not yet
Last edited by TamaTamaGoGo on Thu Mar 12, 2020 3:00 am, edited 5 times in total.
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

mtylerb
Posts: 35
Joined: Sat Apr 07, 2018 3:14 am
Location: Warburg, AB, Canada

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Wed Feb 19, 2020 1:06 pm

Last I checked, OptiFine hasn't been released for Minecraft 1.15.x. So I haven't tried.

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Wed Feb 19, 2020 3:54 pm

mtylerb wrote:
Wed Feb 19, 2020 1:06 pm
Last I checked, OptiFine hasn't been released for Minecraft 1.15.x. So I haven't tried.
Yeah, you are right.
I will prepare to make script to wait OptiFine 1.15.x ...
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Thu Feb 20, 2020 8:50 am

TamaTamaGoGo wrote:
Wed Feb 19, 2020 3:54 pm
mtylerb wrote:
Wed Feb 19, 2020 1:06 pm
Last I checked, OptiFine hasn't been released for Minecraft 1.15.x. So I haven't tried.
Yeah, you are right.
I will prepare to make script to wait OptiFine 1.15.x ...
There has previous version of OptiFine 1.15.x
So, I will try with it.
(I think it’s not work, because previous and recommend version will different IDs)
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Thu Feb 20, 2020 9:03 am

Big News!!
I am trying to make GUI software to setup and download Minecraft

MineCraft for raspberryPi - MCPi

My idea, most or preparing can download with only one click!
I will use your script and other script.
P.S. Am I OK to use your script?

We can start Minecraft launcher, Minecraft game at GUI!

P.S. This idea to show GUI with shell script file.

I will use
tkinter
to show list, progress bar, button and etc.
I will use GitHub.
If you have any idea, please post a reply to MCPi!

URL
https://github.com/TamaTamaGoGo/MCPi--- ... aspberryPi
viewtopic.php?f=78&t=265654
Last edited by TamaTamaGoGo on Thu Feb 27, 2020 12:47 pm, edited 1 time in total.
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

summerdude1011
Posts: 1
Joined: Fri Feb 21, 2020 9:13 am
Location: Australia

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Fri Feb 21, 2020 9:22 am

Hi, I'm very new to using my RPi4 and I was able to successfully follow the tutorial so I must thank you.
I am trying to get 1.15.2 on my Rpi4 so that I can play on realms with my friends. I tried editing my profile to 1.15.2 but it crashed once it loaded, I assume this is due to the fact that that isn't how the code was programmed but I'm unsure. Is there a way to use 1.15.2 on my Raspberry Pi in a similar method to the instructions in the original post?

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Fri Feb 21, 2020 11:05 am

summerdude1011 wrote:
Fri Feb 21, 2020 9:22 am
Hi, I'm very new to using my RPi4 and I was able to successfully follow the tutorial so I must thank you.
I am trying to get 1.15.2 on my Rpi4 so that I can play on realms with my friends. I tried editing my profile to 1.15.2 but it crashed once it loaded, I assume this is due to the fact that that isn't how the code was programmed but I'm unsure. Is there a way to use 1.15.2 on my Raspberry Pi in a similar method to the instructions in the original post?
I am making script with using Forge.
(Because we can’t get OptiFine)
But...
Something is error at minecraft Forge or script or java.
Um...
I will debug it soon.
Please wait until program will run.

P.S. I am making MCPi.
If you have any information when you could run forge 1.15.2, please post to MCPi topic!
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Thu Feb 27, 2020 12:43 pm

Um...
Some thinking, we should set these things to get more FPS.
  • Change -Xmx to your RAM memory size / 2
Like if you are using RAM 4GB and using 500M GPU memory, set 1500M.
  • Overclock your raspi - this code is for raspi4
If you are not using fan, I offer you shouldn’t use this setting!

Overclock is dangerous thing.
Please don’t change it what you are doing!

Overclock make change your raspi spec.
But if you miss or set excess, it may not boot!


Change /boot/config.txt
Add some words

Code: Select all

#overclock script
arm_freq=1750
gpu_freq=600
core_freq=600
force_turbo=1
gpu_freq_min=500
over_voltage=3

That’s all!
Last edited by TamaTamaGoGo on Thu Mar 12, 2020 3:01 am, edited 13 times in total.
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

dhtm15
Posts: 2
Joined: Sun Feb 09, 2020 9:04 am

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Fri Feb 28, 2020 4:21 am

I installed everything according to the tutorial, but there is no sound in the game. I'm not using Forge, just the basic tutorial.

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Fri Feb 28, 2020 11:11 am

dhtm15 wrote:
Fri Feb 28, 2020 4:21 am
I installed everything according to the tutorial, but there is no sound in the game. I'm not using Forge, just the basic tutorial.
Um...
I think you have some missing or other error on your RasPi.
Mine RasPi has all sounds.

Try this!

Code: Select all

# install OpenAL Audio & glxgears demo
sudo apt-get -y install libalut0 libalut-dev && sudo apt-get -y install mesa-utils
Minecraft sounds are working with OpenAL Audio.
May be you don’t have any OpenAL.
But if you not solve, please reply one more time!
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

TamaTamaGoGo
Posts: 52
Joined: Tue Dec 24, 2019 5:54 am
Location: Japan
Contact: Website Twitter

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Sat Feb 29, 2020 5:17 am

Hopefully working!
Thank you very much!
Hello!
I am TamaTama.
I am Japanese, so I am not good at English. :|
Check my raspi site. :D
https://tamatechraspi.tech.blog
I am making a script of Minecraft for rasbian buster.
Search “MCPi” at forums!

SniperKing1SK1
Posts: 1
Joined: Wed Nov 06, 2019 9:56 pm

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Sat Mar 21, 2020 9:23 pm

I can't sign into my account i get this message every time:
Sorry, but we couldn't connect to our servers.
Please make sure that you are online and that minecraft is not blocked.
(SocketTimeoutException: Connect timed out)

mtylerb
Posts: 35
Joined: Sat Apr 07, 2018 3:14 am
Location: Warburg, AB, Canada

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Sat Mar 21, 2020 10:19 pm

SniperKing1SK1 wrote:
Sat Mar 21, 2020 9:23 pm
I can't sign into my account i get this message every time:
Sorry, but we couldn't connect to our servers.
Please make sure that you are online and that minecraft is not blocked.
(SocketTimeoutException: Connect timed out)
Are you behind a router firewall?

lilbytez
Posts: 1
Joined: Sun Mar 29, 2020 4:54 pm

Re: Minecraft 1.14.4 on Raspbian Buster and RPi4

Mon Mar 30, 2020 12:50 am

I had already installed the 1.12.2 version rpiMike made. I thought that was the latest version for the Pi 4. And whenever I open the form on this one where I change my username to normal I see no text. Is there any workaround for this? Thanks.

Return to “Raspberry Pi OS”