User avatar
DavidS
Posts: 4334
Joined: Thu Dec 15, 2011 6:39 am
Location: USA
Contact: Website

Thank you for basing on Debian :) !

Sat Jul 27, 2019 12:43 am

I have gotten fed up with the things we lost going to stretch. So I decided to see what the options are, it turns out that Jessie is an LTS release supported for almost another year (until June 2020).

This gives me plenty of time to find an alternative Linux Distro that still has many of the packages maintained that Jessie has and Stretch lacks. I do not like having to build everything I want to use (spend more time building than using).

So again thank you for basing Raspbian on Debian ARMHF.
RPi = The best ARM based RISC OS computer around
More than 95% of posts made from RISC OS on RPi 1B/1B+ computers. Most of the rest from RISC OS on RPi 2B/3B/3B+ computers

User avatar
scruss
Posts: 2824
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: Thank you for basing on Debian :) !

Sat Jul 27, 2019 12:58 am

There might be package updates copied from Debian, but kernel updates for Jessie have stopped. Any package that has Raspbian-specific work done on it won't be touched either. Also no 3A+/3B+ or 4B support on Jessie.
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

User avatar
DavidS
Posts: 4334
Joined: Thu Dec 15, 2011 6:39 am
Location: USA
Contact: Website

Re: Thank you for basing on Debian :) !

Sat Jul 27, 2019 1:00 am

scruss wrote:
Sat Jul 27, 2019 12:58 am
There might be package updates copied from Debian, but kernel updates for Jessie have stopped. Any package that has Raspbian-specific work done on it won't be touched either. Also no 3A+/3B+ or 4B support on Jessie.
I had forgotten that Jessie predates the RPi 3B+. What about the 3B?
RPi = The best ARM based RISC OS computer around
More than 95% of posts made from RISC OS on RPi 1B/1B+ computers. Most of the rest from RISC OS on RPi 2B/3B/3B+ computers

fruitoftheloom
Posts: 21661
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Thank you for basing on Debian :) !

Sat Jul 27, 2019 1:45 am

DavidS wrote:
Sat Jul 27, 2019 1:00 am
scruss wrote:
Sat Jul 27, 2019 12:58 am
There might be package updates copied from Debian, but kernel updates for Jessie have stopped. Any package that has Raspbian-specific work done on it won't be touched either. Also no 3A+/3B+ or 4B support on Jessie.
I had forgotten that Jessie predates the RPi 3B+. What about the 3B?

Raspbian Jessie will run on a 3B / 2B v1.2 (BCM2837) IF it is updated on an earlier RPi model utilising rpi-update to grab newer kernel / firmware...
Retired disgracefully.....
......to a more gentile life !

jerrm
Posts: 201
Joined: Wed May 02, 2018 7:35 pm

Re: Thank you for basing on Debian :) !

Sat Jul 27, 2019 2:24 am

fruitoftheloom wrote:
Sat Jul 27, 2019 1:45 am
Raspbian Jessie will run on a 3B / 2B v1.2 (BCM2837) IF it is updated on an earlier RPi model utilising rpi-update to grab newer kernel / firmware...
Not quite.

The 3B+ is the first "stretch required" board.

Jessie does NOT need rpi-update for the 3B. The 3B was released during the Jessie period. I doubt an rpi-update is needed for the 2B 1.2, but I don't have one.

Jessie with rpi-update will boot and run on the 3B+ without issue in my experience. We have several 3B+'s still running that config, but the rpi-update for our image was pulled a couple months or so after the 3B+ release. It's possible a current rpi-update might break it, but it should also be possible to force it pull an appropriate version that will work.

No clue about the 3A+.

fruitoftheloom
Posts: 21661
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Thank you for basing on Debian :) !

Sat Jul 27, 2019 5:43 am

jerrm wrote:
Sat Jul 27, 2019 2:24 am
fruitoftheloom wrote:
Sat Jul 27, 2019 1:45 am
Raspbian Jessie will run on a 3B / 2B v1.2 (BCM2837) IF it is updated on an earlier RPi model utilising rpi-update to grab newer kernel / firmware...
Not quite.

The 3B+ is the first "stretch required" board.

Jessie does NOT need rpi-update for the 3B. The 3B was released during the Jessie period. I doubt an rpi-update is needed for the 2B 1.2, but I don't have one.

Jessie with rpi-update will boot and run on the 3B+ without issue in my experience. We have several 3B+'s still running that config, but the rpi-update for our image was pulled a couple months or so after the 3B+ release. It's possible a current rpi-update might break it, but it should also be possible to force it pull an appropriate version that will work.

No clue about the 3A+.

:oops:
Need more sleep
:oops:
Retired disgracefully.....
......to a more gentile life !

hippy
Posts: 6770
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: Thank you for basing on Debian :) !

Sat Jul 27, 2019 12:45 pm

DavidS wrote:
Sat Jul 27, 2019 12:43 am
This gives me plenty of time to find an alternative Linux Distro that still has many of the packages maintained that Jessie has and Stretch lacks.
And those packages would be ... ?
DavidS wrote:
Sat Jul 27, 2019 12:43 am
I do not like having to build everything I want to use (spend more time building than using).
While that may be technically true as stated, I cannot readily believe the effort required would be that great in the grand scheme of things, excepting build problems themselves. I very much doubt you would have to "build everything you want to use".

And I am not convinced you are going to find any other Linux Distro which will really be any better, won't bring 'some effort' requirements with that.

Return to “Raspbian”