Posts: 1
Joined: Mon Jul 22, 2019 12:07 am

Aborted (core dumped) while emulating Raspian OS on QEMU raspi2

Mon Jul 22, 2019 1:13 am

Host details:
  • x86-64 processor
  • Ubuntu 18.04 OS
  • QEMU 4.0.0 and other required libraries

Guest detials:
  • Raspbian OS off the official download site. Version: 2019-07-10-raspbian-buster

QEMU command:

Code: Select all

qemu-system-arm -M raspi2 -kernel bootpart/kernel7.img -dtb bootpart/bcm2709-rpi-2-b.dtb -drive file=2019-07-10-raspbian-buster.img,format=raw,if=sd -append "rw earlyprintk console=ttyAMA0,115200 rootwait memtest=1 loglevel=8 dwc_otg.lpm_enable=0 root=/dev/mmcblk0p2" -serial stdio

Kernel Boot Output:

In detail:
  1. Downloaded Raspbian OS from the official Raspberry Pi website and unzip it

    Code: Select all

  2. Extract boot folder using following steps:

    Code: Select all

    $ mkdir bootpart
    $ guestfish --ro -a 2019-07-10-raspbian-buster.img -m /dev/sda1
    ><fs> copy-out / bootpart/
    ><fs> quit
  3. execute above qemu command
  • I have tried expanding the rootfs at /dev/sda2 and booting, leading to the same error
  • I have tried commenting out /etc/, leading to same error
  • If I don't login to raspberry pi, still the core is dumped, which makes me think that it could be a kernel level problem

I would be glad if someone could hint me towards mitigating the core dump issue. Thank you.

Return to “Raspbian”