nbgh007
Posts: 8
Joined: Tue Aug 20, 2019 7:45 am

Buster fails to (re)boot with powered USB Switch/Hub

Wed Aug 21, 2019 3:14 pm

I wouldn't be surprised of that, although... I will look for that thread.

But I have seen this same problem with a higher end USB Switch 3.0 from Aten... but then I did not have time then to trace the problem.

And RPI 3b+ with Stretch version prior to July 16 does not have such a problem... and RPI 3b+ with that version updated (update/dist-upgrade) to the latest fails... Therefore it has to be with software more than hardware.

I also have read about the RPI 4b implementation of the USB-C... and that rings a similar bell. I forgot to double check if there was a difference of behavior between the USB 3.0 and 2.0 ports on the RPI 4b... I will do that later tonight. But with RPI 3b+ it was through USB 2.0 and it worked before... the latest version of Stretch.

nbgh007
Posts: 8
Joined: Tue Aug 20, 2019 7:45 am

Buster fails to (re)boot with powered USB Switch/Hub

Wed Aug 21, 2019 3:25 pm

Just checked the other thread and it looks very similar although no one seems to have realized that it is about software... Indeed in that thread it still claims no problem with Stretch, but it is not at its latest...

Whilst I would have been tempted to agree on the hardware - that was my first thought - the fact that it worked with a July version of Stretch on RPI 3b+, and then does not work anymore on the same RPI 3b+ with the latest version of Stretch contradicts that first thought...

nbgh007
Posts: 8
Joined: Tue Aug 20, 2019 7:45 am

Buster fails to (re)boot with powered USB Switch/Hub

Wed Aug 21, 2019 4:49 pm

Just tested with the USB 2.0 port of RPI 4b, and I got the same problem.

Retested, for the sake of it, some scenarios without the USB Switch own power supply, and everything seems to be okay as expected.

Hexxter
Posts: 7
Joined: Thu Aug 22, 2019 10:15 am

Re: Buster bug report thread

Thu Aug 22, 2019 10:18 am

Cannot install python3-pip (droken dependency), i think python3-dev is not avalible.

- raspbian Buster
- Linux 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux
- HW Raspberry pi 3

User avatar
rpdom
Posts: 15908
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Buster bug report thread

Thu Aug 22, 2019 1:49 pm

Hexxter wrote:
Thu Aug 22, 2019 10:18 am
Cannot install python3-pip (droken dependency), i think python3-dev is not avalible.

- raspbian Buster
- Linux 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux
- HW Raspberry pi 3
I had no problem. python3-dev is a recommended package, not a dependency and I don't install recommended packages by default, but python3-dev did install without any issues when I tried it.

Did you do apt update first?

What does apt policy python3-pip python3-dev show you?

Hexxter
Posts: 7
Joined: Thu Aug 22, 2019 10:15 am

Re: Buster bug report thread

Thu Aug 22, 2019 2:51 pm

yes i do apt update first

this is the result from sudo apt policy python3-pip python3-dev

python3-pip:
Installiert: (keine)
Installationskandidat: 18.1-5+rpt1
Versionstabelle:
18.1-5+rpt1 500
500 http://archive.raspberrypi.org/debian buster/main armhf Packages
python3-dev:
Installiert: (keine)
Installationskandidat: (keine)
Versionstabelle:

Hexxter
Posts: 7
Joined: Thu Aug 22, 2019 10:15 am

Re: Buster bug report thread

Thu Aug 22, 2019 2:55 pm

i used a new Image downloaded yesterday from raspberrypi.org and after do some stuff (language,...) i do apt update, apt upgrade, and after this i would install python3-pip.

this is my source.list:

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6115
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Buster bug report thread

Thu Aug 22, 2019 3:14 pm

source.list or sources.list?

What's the output of just 'apt policy'?

Hexxter
Posts: 7
Joined: Thu Aug 22, 2019 10:15 am

Re: Buster bug report thread

Thu Aug 22, 2019 3:30 pm

sorry sources.list

sudo apt policy
Paketdateien:
100 /var/lib/dpkg/status
release a=now
500 https://packages.gitlab.com/runner/gitl ... r/raspbian buster/main armhf Packages
release v=1,o=packages.gitlab.com/runner/gitlab-runner,a=buster,n=buster,l=gitlab-runner,c=main,b=armhf
origin packages.gitlab.com
500 http://archive.raspberrypi.org/debian buster/main armhf Packages
release o=Raspberry Pi Foundation,a=testing,n=buster,l=Raspberry Pi Foundation,c=main,b=armhf
origin archive.raspberrypi.org
500 http://raspbian.raspberrypi.org/raspbian buster/rpi armhf Packages
release o=Raspbian,a=stable,n=buster,l=Raspbian,c=rpi,b=armhf
origin raspbian.raspberrypi.org
500 http://raspbian.raspberrypi.org/raspbian buster/non-free armhf Packages
release o=Raspbian,a=stable,n=buster,l=Raspbian,c=non-free,b=armhf
origin raspbian.raspberrypi.org
500 http://raspbian.raspberrypi.org/raspbian buster/contrib armhf Packages
release o=Raspbian,a=stable,n=buster,l=Raspbian,c=contrib,b=armhf
origin raspbian.raspberrypi.org
500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
release o=Raspbian,a=stable,n=buster,l=Raspbian,c=main,b=armhf
origin raspbian.raspberrypi.org
Mit Pinning verwaltete Pakete:

Hexxter
Posts: 7
Joined: Thu Aug 22, 2019 10:15 am

Re: Buster bug report thread

Thu Aug 22, 2019 3:33 pm

here the original ouput of the operation (sorry the lang is german):

sudo apt install python3-pip
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
python3-pip : Hängt ab von: python3-distutils ist aber nicht installierbar
Empfiehlt: python3-dev (>= 3.2) ist aber nicht installierbar
Empfiehlt: python3-setuptools ist aber nicht installierbar
Empfiehlt: python3-wheel ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6115
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Buster bug report thread

Thu Aug 22, 2019 3:53 pm

Not sure what's going on.

Code: Select all

python3-dev:
Installiert: (keine)
Installationskandidat: (keine)
seems to be in conflict with

Code: Select all

500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
release o=Raspbian,a=stable,n=buster,l=Raspbian,c=main,b=armhf
origin raspbian.raspberrypi.org
All I can say is that http://raspbian.raspberrypi.org/raspbia ... f/Packages contains the following snippet:

Code: Select all

Package: python3-dev
Source: python3-defaults
Version: 3.7.3-1
Architecture: armhf
Maintainer: Matthias Klose <[email protected]>
Installed-Size: 17
Depends: python3 (= 3.7.3-1), libpython3-dev (= 3.7.3-1), python3.7-dev (>= 3.7.3-1~), python3-distutils (>= 3.7.2-1~), dh-python
Replaces: python3.1 (<< 3.1.2+20100706-3)
Multi-Arch: allowed
Homepage: https://www.python.org/
Priority: optional
Section: python
Filename: pool/main/p/python3-defaults/python3-dev_3.7.3-1_armhf.deb
Size: 1264
SHA256: b1d5d16fbe2699df54761deb17db5e179179e4927accce321edaeabc69670738
SHA1: 93cb2df420f8614b11c7b40052b417d054c638af
MD5sum: e2a06cba524f3bc885a5e969694c4355
Description: header files and a static library for Python (default)
 Header files, a static library and development tools for building
 Python modules, extending the Python interpreter or embedding Python
 in applications.
 .
 This package is a dependency package, which depends on Debian's default
 Python 3 version (currently v3.7).
So the package is there.

I'm a little suspicious of the extra repo you have for gitlab, but it wouldn't result in python3-dev not showing up for you.

Hexxter
Posts: 7
Joined: Thu Aug 22, 2019 10:15 am

Re: Buster bug report thread

Thu Aug 22, 2019 4:25 pm

if i grep in http://raspbian.raspberrypi.org/raspbia ... f/Packages i found no python3-pip only dependencies to python3-pip.

for python3-dev the same. Is your file in cache?

sorry this was my error after downloading to my desktop i found python3-dev.

Can i reinit my repository oder cache on my raspberry pi?

User avatar
rpdom
Posts: 15908
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Buster bug report thread

Thu Aug 22, 2019 4:44 pm

Something is definitely wrong, but I can't see what.

Meanwhile, you could try installing python3-pip without the "recommended" packages like this:

Code: Select all

sudo apt install -o Install-Recommends=false python3-pip
The sudo apt update is supposed to update your local package cache from the servers.

Hexxter
Posts: 7
Joined: Thu Aug 22, 2019 10:15 am

Re: Buster bug report thread

Thu Aug 22, 2019 4:48 pm

thank you for your support.

it was an error on my raspberry pi installation.

after:
sudo rm -R /var/lib/apt/lists/*

and sudo apt update i could install python3-dev. I think on the first update something goes wrong.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6115
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Buster bug report thread

Thu Aug 22, 2019 5:16 pm

Sounds like maybe some bad files were pushed to Raspbian with a newer timetstamp and then reverted, so apt thinks the bad update was okay.

Raspbian repos aren't handled by us, so I have no idea.

It would be interesting to see the content of one of the cached bad files to make sure there's nothing suspicious going on.

schnee
Posts: 12
Joined: Thu Aug 08, 2019 12:21 am

Re: Buster bug report thread - i2c issue

Fri Aug 23, 2019 12:26 am

Hi,

after the latest buster update my i2c (and other devices) went missing on my pi. I get an error when i try to load modules:

Code: Select all

modprobe: ERROR: could not insert 'i2c_dev': Exec format error
depmod gives lot of errors on modules

Code: Select all

sudo depmod
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/keyboard/matrix_keypad.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/joystick/iforce/iforce.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/joystick/psxpad-spi.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/joystick/xpad.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/joystick/rpisense-js.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/ads7846.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/edt-ft5x06.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/rpi-ft5406.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/egalax_ts.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/exc3000.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/goodix.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/ili210x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/usbtouchscreen.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/touchscreen/stmpe-ts.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/ad714x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/ad714x-i2c.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/ad714x-spi.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/adxl34x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/adxl34x-i2c.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/adxl34x-spi.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/ati_remote2.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/cm109.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/cma3000_d0x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/keyspan_remote.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/powermate.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/rotary_encoder.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/uinput.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/misc/yealink.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/ff-memless.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/input-polldev.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/matrix-keymap.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/joydev.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/evdev.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/algos/i2c-algo-bit.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/busses/i2c-bcm2708.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/busses/i2c-bcm2835.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/busses/i2c-gpio.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/busses/i2c-robotfuzz-osif.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/busses/i2c-tiny-usb.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/muxes/i2c-mux-gpmux.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/muxes/i2c-mux-pca954x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-mux.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/b2c2/b2c2-flexcop.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/siano/smsmdtv.ko: Invalid argument
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/siano/smsdvb.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/videobuf2/videobuf2-common.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/videobuf2/videobuf2-v4l2.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/videobuf2/videobuf2-memops.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/videobuf2/videobuf2-vmalloc.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/videobuf2/videobuf2-dma-contig.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/cx2341x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/tveeprom.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/common/cypress_firmware.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dvb-pll.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx22700.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx24110.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dib3000mb.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dib3000mc.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dibx000_common.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dib7000m.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dib7000p.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dib9000.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx22702.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/drxd.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/bcm3510.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx24123.ko: Invalid argument
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/isl6405.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/isl6421.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dib0070.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/dib0090.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/au8522_common.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/au8522_dig.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/au8522_decoder.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx24113.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/atbm8830.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/af9013.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx24116.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx24117.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cx24120.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/isl6423.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/ec100.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/ds3000.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cxd2820r.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cxd2841er.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/a8293.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/af9033.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/as102_fe.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/gp8psk-fe.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/horus3a.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/ascot2e.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/helene.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/media/dvb-frontends/cxd2099.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/linear.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/raid0.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/raid1.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-bufio.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-bio-prison.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-crypt.ko: Invalid argument
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-delay.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-snapshot.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-mirror.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-log.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-region-hash.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-log-userspace.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-zero.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-raid.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/md/dm-cache-smq.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/leds/trigger/ledtrig-transient.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/leds/trigger/ledtrig-camera.ko: Invalid argument
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/leds/trigger/ledtrig-netdev.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/leds/leds-pca963x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/leds/leds-is31fl32xx.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/serio/serio.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/serio/serport.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/serio/serio_raw.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/gameport/gameport.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/gameport/lightning.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/input/gameport/ns558.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/hwmon.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/ads1015.ko: Invalid argument
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/ds1621.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/gpio-fan.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/ina2xx.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/jc42.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/lm75.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/raspberrypi-hwmon.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/rpi-poe-fan.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/sht21.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/sht3x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/shtc1.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/hwmon/tmp102.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/adc/mcp320x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/adc/mcp3422.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/adc/ti-ads1015.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/buffer/industrialio-buffer-cb.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/buffer/industrialio-triggered-buffer.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/buffer/kfifo_buf.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/common/ms_sensors/ms_sensors_i2c.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/humidity/dht11.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/humidity/hdc100x.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/humidity/htu21.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/imu/inv_mpu6050/inv-mpu6050.ko: Invalid argument
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/imu/inv_mpu6050/inv-mpu6050-i2c.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/light/tsl4531.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/light/veml6070.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/pressure/bmp280.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/pressure/bmp280-i2c.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/pressure/bmp280-spi.ko: Exec format error
depmod: ERROR: failed to load symbols from /lib/modules/4.19.66+/kernel/drivers/iio/industrialio.ko: Invalid argument


Kernel and device info:

Code: Select all

$ uname -r
4.19.66+
ls -l /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko
-rw-r--r-- 1 root root 15868 Aug 19 16:39 /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko

Code: Select all

model B rev 2.0 (512MB)
Some more details in the original post from me: https://www.raspberrypi.org/forums/view ... 0#p1523580

Anybody can help to understand what is going on?

Thanks

nbgh007
Posts: 8
Joined: Tue Aug 20, 2019 7:45 am

Re: Buster bug report thread - i2c issue

Fri Aug 23, 2019 7:43 am

Clearly, your RPI seems to be thinking (uname -r) that it's running kernel 4.19.66+ whilst it should be running the latest 4.19.66-v7l+... I bet that if you look in /lib/modules/4.19.66-v7l+/kernel/drivers/i2c/ you will find all your files...

Have you tried apt-get update/dist-upgrade? Have you tried to revert to an older version of the kernel?

trejan
Posts: 1106
Joined: Tue Jul 02, 2019 2:28 pm

Re: Buster bug report thread - i2c issue

Fri Aug 23, 2019 8:52 am

nbgh007 wrote:
Fri Aug 23, 2019 7:43 am
Clearly, your RPI seems to be thinking (uname -r) that it's running kernel 4.19.66+ whilst it should be running the latest 4.19.66-v7l+...
They're using an old Pi 1 rev 2 so 4.19.66+ is correct. v7l is the LPAE kernel for the Pi 4 and v7 is for the Pi 2/3/3+. The Pi 4 needs LPAE support and the peripheral base address changed between Pi 1, 2/3/3+ and 4 hence the 3 different kernels.

User avatar
rpdom
Posts: 15908
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Buster bug report thread - i2c issue

Fri Aug 23, 2019 9:17 am

Exec format error often happens when the files are for the wrong architecture, such as having file for i386 on an armhf system. Either that or the files are damaged somehow.

Can you check the state of one of the files to see what it shows up as:

Code: Select all

file /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
ls -l /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
should give us details about the contents of the file and its size.

schnee
Posts: 12
Joined: Thu Aug 08, 2019 12:21 am

Re: Buster bug report thread - i2c issue

Fri Aug 23, 2019 11:05 am

rpdom wrote:
Fri Aug 23, 2019 9:17 am
Exec format error often happens when the files are for the wrong architecture, such as having file for i386 on an armhf system. Either that or the files are damaged somehow.

Can you check the state of one of the files to see what it shows up as:

Code: Select all

file /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
ls -l /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
should give us details about the contents of the file and its size.
Here is what it shows for the gpio-keys.ko

Code: Select all

file /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
/lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko: data
[email protected]:~ $ ls -l /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
-rw-r--r-- 1 root root 19760 Aug 19 16:39 /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
And for the i2c driver

Code: Select all

 ls -l /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko 
-rw-r--r-- 1 root root 15868 Aug 19 16:39 /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko
[email protected]:~ $ file /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko 
/lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko: data

schnee
Posts: 12
Joined: Thu Aug 08, 2019 12:21 am

Re: Buster bug report thread - i2c issue

Fri Aug 23, 2019 11:07 am

nbgh007 wrote:
Fri Aug 23, 2019 7:43 am
Clearly, your RPI seems to be thinking (uname -r) that it's running kernel 4.19.66+ whilst it should be running the latest 4.19.66-v7l+... I bet that if you look in /lib/modules/4.19.66-v7l+/kernel/drivers/i2c/ you will find all your files...

Have you tried apt-get update/dist-upgrade? Have you tried to revert to an older version of the kernel?
How can i revert to an older version of the kernel? The last apt upgrade installed he new kernel and afaik removed the old one

trejan
Posts: 1106
Joined: Tue Jul 02, 2019 2:28 pm

Re: Buster bug report thread - i2c issue

Fri Aug 23, 2019 11:17 am

schnee wrote:
Fri Aug 23, 2019 11:05 am
And for the i2c driver

Code: Select all

 ls -l /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko 
-rw-r--r-- 1 root root 15868 Aug 19 16:39 /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko
[email protected]:~ $ file /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko 
/lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko: data
Something strange is going on here. Your modules are the right size but file doesn't think they're ELF binaries.

This is what I get:
$ ls -l /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
-rw-r--r-- 1 root root 19760 Aug 19 15:39 /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko

$ file /lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko
/lib/modules/4.19.66+/kernel/drivers/input/keyboard/gpio_keys.ko: ELF 32-bit LSB relocatable, ARM, EABI5 version 1 (SYSV), BuildID[sha1]=a9e5a8c002e0abe64d1028d3689f7c394e16700f, not stripped
$ ls -l /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko
-rw-r--r-- 1 root root 15868 Aug 19 15:39 /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko

$ file /lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko
/lib/modules/4.19.66+/kernel/drivers/i2c/i2c-dev.ko: ELF 32-bit LSB relocatable, ARM, EABI5 version 1 (SYSV), BuildID[sha1]=24d3a9fdf3aad9fd3c961aa690d8b86b7b98376c, not stripped

thatchunkylad198966
Posts: 134
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

Re: Buster bug report thread

Sun Aug 25, 2019 6:40 pm

Not sure if this has been said already...

Chromium bug where the "frequent" sites you've used all have the same icon instead of the individual one's they should have.
Chromium is also black sometimes, maybe a graphics issue?
One man's trash is another man's treasure! :) Pi's I have; Pi Zero, Pi Zero W, Pi 2 x2, Pi 3 x2, Pi 4 4GB x2.

ejolson
Posts: 4054
Joined: Tue Mar 18, 2014 11:47 am

Re: Buster bug report thread

Mon Aug 26, 2019 2:03 pm

This bug report points out that the package btrfs-progs is busted in Buster, in case you missed the separate thread. Additional details are available here.
Last edited by ejolson on Tue Aug 27, 2019 7:33 pm, edited 1 time in total.

thatchunkylad198966
Posts: 134
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

Re: Buster bug report thread

Tue Aug 27, 2019 7:14 pm

thatchunkylad198966 wrote:
Sun Aug 25, 2019 6:40 pm
Not sure if this has been said already...

Chromium bug where the "frequent" sites you've used all have the same icon instead of the individual one's they should have.
Chromium is also black sometimes, maybe a graphics issue?
Update to this; downgrading/upgrading Chromium from snapshot.debian and the issues go away so it's something to do with the Chromium build for the Pi 4.
One man's trash is another man's treasure! :) Pi's I have; Pi Zero, Pi Zero W, Pi 2 x2, Pi 3 x2, Pi 4 4GB x2.

Return to “Raspbian”