User avatar
rin67630
Posts: 451
Joined: Fri Mar 04, 2016 10:15 am

VNC suddenly gone...

Tue May 21, 2019 3:24 pm

Hi
on a current version of Raspbian (mainly headless) VNC has stopped to work and the VNC icon in the taskbar does not show up.
VNC is enabled in Raspi-config and the attempt to reinstall realvnc over apt-get return that the actual version is already installed.
How can I clear the VNC configuration files to try restarting from scratch?
Thank you!

dl324
Posts: 122
Joined: Mon May 06, 2019 7:33 pm
Location: Pacific Northwest, USA

Re: VNC suddenly gone...

Tue May 21, 2019 3:56 pm

Apparently that icon is to give you information about your VNC session and is only present in vncviewer.
desktopTaskbar.jpg
desktopTaskbar.jpg (13.42 KiB) Viewed 522 times
Have you tried running the vncserver command? One way to see if you have any vncserver sessions running is to check the .pid file(s) in ~/.vnc. If the PID(s) in the files exist, the session is active. The PID for the first session would be ~/.vnc/<hostname>:<display number>.pid .

User avatar
rin67630
Posts: 451
Joined: Fri Mar 04, 2016 10:15 am

Re: VNC suddenly gone...

Tue May 21, 2019 8:16 pm

The icon was previously present with VNC server on the Raspi. Once connectet it turned black. It's gone now.
Why? I don't know.

User avatar
sconemad
Posts: 228
Joined: Thu Apr 28, 2016 1:47 pm
Location: Cambridge, UK
Contact: Website

Re: VNC suddenly gone...

Wed May 22, 2019 10:08 am

That's strange.

It sounds like the VNC server isn't running. Try doing "sudo systemctl status vncserver-x11-serviced" to get the status of it.

If it's not running, "sudo systemctl enable --now vncserver-x11-serviced" should start it running again (which is effectively what the vnc option in raspi-config does).

The config files for the VNC service mode server are in /etc/vnc and /root/.vnc, so clearing these out and reinstalling the package may help.

User avatar
rin67630
Posts: 451
Joined: Fri Mar 04, 2016 10:15 am

Re: VNC suddenly gone...

Fri May 24, 2019 3:00 pm

Thank you, I will check next week. Currently I have got no keyboard to test.

Return to “Raspbian”