Silverlock
Posts: 87
Joined: Wed Apr 10, 2013 3:51 am

Audio playback truncation with kernel packages 1.20190517-1

Sat May 18, 2019 6:52 pm

TL;DR version: audio playback (which was working fine) stops a second or two early after kernel update (package version 1.20190517-1).


Background: I have a Pi 3B headless system running Raspbian Stretch Lite, from 2019-04-08-raspbian-stretch-lite.zip downloaded from https://www.raspberrypi.org/downloads/raspbian. uname shows the kernel version as: 4.14.98-v7+ (and the package version is 1.20190401-1). Can't imagine why it might matter, but it's on a 8G SanDisk Ultra card.

I'm using play from the sox package to play audio files. No problems. This is using the 3.5mm jack, not HDMI.

This morning I did a

Code: Select all

sudo apt-get update;sudo apt-get upgrade
and got yesterday's kernel update. Rebooted the system and immediately noticed audio playback was being consistently truncated. The last second or two of audio was cut off. I was able to reproduce this just using play from the command line to play back a wav file.

Grabbed the 1.20190401-1 deb files from another Pi 3B that I hadn't upgraded and downgraded everything with

Code: Select all

sudo dpkg -i *20190401*.deb
Rebooted and everything was back to normal.


Thoughts? Anyone else experienced anything like this? I do have another spare Pi that I can try the update on and see if it happens there as well but figured I'd ask before diving deeper.
RPi3+external HDD/Raspbian Stretch

Chimneyfactory
Posts: 23
Joined: Sun May 19, 2019 1:30 pm

Re: Audio playback truncation with kernel packages 1.20190517-1

Mon May 20, 2019 12:01 pm

Yes, since the kernel update I've found that audio playback is intermittently choppy on my pi 3B+ desktop machine.

MP3 playback occasionally drops out briefly, also choppy in first few seconds.

Using x-rdp to connect to a windows PC desktop, sound (which used to work fine) is strangely distorted/metallic sounding (but its not a low bit rate type "metallic" sound)

Playback of video in VLC seems more choppy than it used to be (despite hardware acceleration and overall low CPU use during this)

Video editing in Openshot is more jerky than previously.


I was using this version, as installed by apt-get upgrade :

Code: Select all

uname -a
Linux desk 4.19.42-v7+ #1219 SMP Tue May 14 21:20:58 BST 2019 armv7l GNU/Linux
I reverted to what I think is the previous release firmware thus :

Code: Select all

sudo rpi-update a08ece3d48c3c40bf1b501772af9933249c11c5b
and the problems are resolved! Sound is good again, x-rdp sound works fine, video playback improved, mp3s play without dropout.

So I'm currently on this version :

Code: Select all

Linux oslo 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
So it appears to me that something is amiss with the recent firmware / kernel update.

Return to “Raspbian”