sinnlos
Posts: 5
Joined: Fri Jan 25, 2019 4:25 pm

ssh connection via dropbear-initramfs to unlock encrypted root doesn't give a prompt

Sun Mar 03, 2019 3:14 pm

Thanks to this https://www.offensive-security.com/kali ... ncryption/ and many other tutorials I encrypted my root partition on the SD Card. Local unlocking works without any problem. But when I try to connect via ssh to the dropbear-initramfs the SSH Server accepts the connection and the public key, but it doesn't give me a prompt.

Code: Select all

debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /root/.ssh/id_rsa
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 535
debug2: input_userauth_pk_ok: fp df:0f:8d:85:e1:62:01:ad:2f:14:42:f2:77:bb:40:8e
debug1: Authentication succeeded (publickey).
Authenticated to 192.168.10.10 ([192.168.10.10]:22).
debug1: channel 0: new [client-session]
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: fd 3 setting TCP_NODELAY
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
debug2: channel 0: request env confirm 0
debug2: channel 0: request shell confirm 1
debug2: callback done
debug2: channel 0: open confirm rwindow 24576 rmax 32759
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0


^CError reading passphrase.
As you see in the SSH Debugging, no prompt is presented, but when I press enter or Strg+c there appears once this "Error reading passphrase". If I try to enter the password, nothing happens.
The SSH connection stays in this state for a very long time, probably until something times out.

Any idea what could be the problem? Thanks for your help!


Return to “Raspberry Pi OS”