drmullins
Posts: 43
Joined: Fri Jun 23, 2017 9:22 pm

Chromium-browser and Bleachbit

Fri Feb 08, 2019 12:06 pm

I am finding that after running Bleachbit, the new version of chromium-browser fails to start and has to be removed and reinstalled in order for it to work properly. This was not a problem with earlier versions. Does anyone else have this problem ?

Andyroo

Re: Chromium-browser and Bleachbit

Fri Feb 08, 2019 12:38 pm

Never needed to run this on a Linux box to be honest (Windwoes is a different story).

You may do best to ask on their support forum https://www.bleachbit.org/forum

drmullins
Posts: 43
Joined: Fri Jun 23, 2017 9:22 pm

Re: Chromium-browser and Bleachbit

Sun Feb 10, 2019 9:27 am

It's a problem with chromium-browser 65.0.3325.181-0+rpt4 and fontconfig. Chromium is very slow to start after the clearing the cache to recover disk space if many fonts have been installed.

To reproduce :
- install josm (java open street map) which requires installation of a large number of fonts
- remove all directories under ~/.cache
- start chromium-browser
Chromium-browser takes about THREE MINUTES (!) to start because it is slow at regenerating ~/.cache/fontconfig

I clear the cache using bleachbit rather than by doing a manual deletion. My fix is to run bleachbit from a script which saves and restores~/.cache/fontconfig as follows :

#!/bin/bash
cp --preserve -r /home/pi/.cache/fontconfig /home/pi/
bleachbit
cp --preserve -r /home/pi/fontconfig /home/pi/.cache/

This was not a problem with chromium 60.0.3112.89-0ubuntu0.14.04.1.1010+1

firefox-esr does not have this issue at all.

Return to “Raspbian”