brunp
Posts: 9
Joined: Fri Jan 11, 2019 6:10 pm

Locale Warning during Raspbian Build

Sat Jan 19, 2019 2:54 am

Hi gents,

Who do get rid of this issue during the build? I know it is a warning, but would very much like to fix the warning? Idea's?

apt-listchanges: Can't set locale; make sure $LC_* and $LANG are correct!
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.


I get it all over the place in the build logs.

Paul

User avatar
Botspot
Posts: 153
Joined: Thu Jan 17, 2019 9:47 pm
Location: Texas
Contact: Yahoo Messenger

Re: Locale Warning during Raspbian Build

Sat Jan 19, 2019 4:46 pm

Had the same problem until I set the locale by running

Code: Select all

sudo raspi-config
and then (with the arrow keys) selecting

Code: Select all

localization options
Make sure all four options are set correctly, that should solve your problem.
My doctor told me my brain is as useful as a Raspberry Pi. Is that a compliment?

Vinny_fox
Posts: 2
Joined: Sat Jan 19, 2019 3:39 pm

Re: Locale Warning during Raspbian Build

Sat Jan 19, 2019 5:12 pm

Code: Select all

dpkg-reconfigure locales

Code: Select all

dpkg-reconfigure tzdata

Return to “Raspbian”