Spretti
Posts: 2
Joined: Mon Jun 11, 2018 12:15 pm

Cannot automount Synology NAS server folder

Mon Jun 11, 2018 12:23 pm

Hi, been trying to make automount of folder withut success, I can mount the directory ok with command sudo mount -t cifs -o username=++++++++,password=++++++++ //192.168.1.100/photo/pictures/2001 /home/pi/NASphoto
But i have unsuccessfully tried different variations in sudo nano /etc/fstab
//192.168.1.100/photo/pictures/2001 /home/pi/NASphoto cifs username=++++++,password=++++++++++,iocharset=utf8,sec=ntlm 0 0
I just cannot get it working. :?:

Spretti
Posts: 2
Joined: Mon Jun 11, 2018 12:15 pm

Re: Cannot automount Synology NAS server folder

Tue Jun 12, 2018 10:47 am

Anyone? :idea: Just to mount the folder during start, should be a piece of cake. Using the latest Rasbian.

drmullins
Posts: 44
Joined: Fri Jun 23, 2017 9:22 pm

Re: Cannot automount Synology NAS server folder

Tue Jun 12, 2018 6:15 pm

I prefer to use autofs - see following
viewtopic.php?f=66&t=213496#p1316059

User avatar
thagrol
Posts: 2000
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Cannot automount Synology NAS server folder

Tue Jun 12, 2018 10:24 pm

Try configuring wait for network in raspi-config's boot options and/or adding _netdev to the mount options in your fstab entry.
Attempts to contact me outside of thes forums will be ignored unless signed in triplicate, sent in, sent back, queried, lost, found, subjected to public enquiry, lost again, and finally buried in soft peat for three months and recycled as firelighters

Return to “Raspbian”