SimonBlake
Posts: 11
Joined: Fri Feb 13, 2015 4:33 pm

Raspbian 2018-04-18 desktop preferences

Wed Apr 25, 2018 9:08 am

Is it just me, or is it now impossible to remove the Wastebasket icon from the desktop in the latest Raspbian, or change the wallpaper? When I select Desktop Preferences, the Wastebasket option isn't ticked, although the icon is on the screen, and I'm told No Image is selected as wallpaper. I can navigate to a new image, but selecting that has no effect on the wallpaper.

Simon

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5790
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Raspbian 2018-04-18 desktop preferences

Wed Apr 25, 2018 9:29 am

Seems to work without problems on this end.

k-pi
Posts: 922
Joined: Sun Feb 12, 2017 1:46 pm
Location: Upper Hale, Surrey, UK.

Re: Raspbian 2018-04-18 desktop preferences

Wed Apr 25, 2018 9:33 am

Maybe you got a bad download(?).

I had a day of difficulty (on the 20th) trying to download this version, (got a copy the other day), but as of yet, haven't tried it out.

User avatar
bensimmo
Posts: 4129
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: Raspbian 2018-04-18 desktop preferences

Wed Apr 25, 2018 10:32 am

All worked for me on teh original April image, and then worked for me again after a desktop update that comes down.

viewtopic.php?f=66&t=211846 I know as I had to redo it again, and will have to on all my other images as they 'update' :|

SimonBlake
Posts: 11
Joined: Fri Feb 13, 2015 4:33 pm

Re: Raspbian 2018-04-18 desktop preferences

Wed Apr 25, 2018 11:46 am

Thanks, guys.

The problem seems to occur if you try to change the Desktop Preferences immediately after running apt update and apt upgrade. This procedure puts a pi-conf-backup.desktop file in /home/p/.config/autostart that, when run, tells you that Raspbian has been updated and some configuration files may have been overwritten. If you execute that (the easiest way is to reboot the Pi), you can then once again change the Desktop Preferences.

It's not the end of the world, but this behaviour is, I think, new.

Return to “Raspbian”