gimliflea
Posts: 76
Joined: Fri Nov 18, 2011 4:14 pm

libgcc1 gone missing

Sat Oct 20, 2012 11:36 pm

Hi
I've been using raspbian wheezy for some time now with great sucesss.
However when I tried to download gimp I got an error saying that I had unmet dependencies
on lbc6 for libgcc1. Nothing I do seems to be able to correct this.

sudo apt-get -f install comes back and asks me if I want to do this when I say y it comes back to prompt immediately but does not appear to have dome anything as I still get same
error when trying upgrade.

Any Ideas?

plugwash
Forum Moderator
Forum Moderator
Posts: 3522
Joined: Wed Dec 28, 2011 11:45 pm

Re: libgcc1 gone missing

Sun Oct 21, 2012 12:05 am

What happens when you try

wget http://archive.raspbian.org/raspbian/po ... _armhf.deb
dpkg -i libgcc1_4.7.1-8+rpi1_armhf.deb

gimliflea
Posts: 76
Joined: Fri Nov 18, 2011 4:14 pm

Re: libgcc1 gone missing

Sun Oct 21, 2012 12:16 am

Tx plugwash
wget command has been contracted by forum I suspect, can you fill in the dots for me?

gimliflea
Posts: 76
Joined: Fri Nov 18, 2011 4:14 pm

Re: libgcc1 gone missing

Sun Oct 21, 2012 12:26 am

Sorry tried wget with this address

http://archive.raspbian.org/raspbian/po ... _armhf.deb

Which seemed to work correctly.
Then got

[email protected] ~ $ sudo dpkg -i libgcc1_4.7.1-8+rpi1_armhf.deb
dpkg: regarding libgcc1_4.7.1-8+rpi1_armhf.deb containing libgcc1:armhf, pre-dependency problem:
libgcc1 pre-depends on multiarch-support
multiarch-support is unpacked, but has never been configured.

dpkg: error processing libgcc1_4.7.1-8+rpi1_armhf.deb (--install):
pre-dependency problem - not installing libgcc1:armhf
Errors were encountered while processing:
libgcc1_4.7.1-8+rpi1_armhf.deb
[email protected] ~ $

Is libgcc1 critical?

plugwash
Forum Moderator
Forum Moderator
Posts: 3522
Joined: Wed Dec 28, 2011 11:45 pm

Re: libgcc1 gone missing

Sun Oct 21, 2012 12:45 am

Yes libgcc1 is critical

Ok can you try

wget http://archive.raspbian.org/raspbian/pool/main/e/eglibc/multiarch-support_2.13-35_armhf.deb
dpkg -i --force-depends multiarch-support_2.13-35_armhf.deb
dpkg -i libgcc1_4.7.1-8+rpi1_armhf.deb
apt-get -f install

gimliflea
Posts: 76
Joined: Fri Nov 18, 2011 4:14 pm

Re: libgcc1 gone missing

Sun Oct 21, 2012 1:04 am

wget seems to work.

dpkg gives


[email protected] ~ $ sudo dpkg -i libgcc1_4.7.1-8+rpi1_armhf.deb
dpkg: regarding libgcc1_4.7.1-8+rpi1_armhf.deb containing libgcc1:armhf, pre-dependency problem:
libgcc1 pre-depends on multiarch-support
multiarch-support is unpacked, but has never been configured.

dpkg: error processing libgcc1_4.7.1-8+rpi1_armhf.deb (--install):
pre-dependency problem - not installing libgcc1:armhf
Errors were encountered while processing:
libgcc1_4.7.1-8+rpi1_armhf.deb

and then apt-get gives


[email protected] ~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libgcc1
The following NEW packages will be installed:
libgcc1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/54.5 kB of archives.
After this operation, 209 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
[email protected] ~ $

sudo apt-get upgrade still gives


[email protected] ~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6 : Depends: libgcc1 but it is not installed
E: Unmet dependencies. Try using -f.
[email protected] ~ $

I have started a new download of raspbian so I can build a brand new sd card, but it would be nice to fix this so I don't have to re-install a whole bunch of stuff.

plugwash
Forum Moderator
Forum Moderator
Posts: 3522
Joined: Wed Dec 28, 2011 11:45 pm

Re: libgcc1 gone missing

Sun Oct 21, 2012 1:07 am

plugwash wrote: dpkg -i --force-depends multiarch-support_2.13-35_armhf.deb
[
You don't seem to have posted the results of this command

gimliflea
Posts: 76
Joined: Fri Nov 18, 2011 4:14 pm

Re: libgcc1 gone missing

Sun Oct 21, 2012 1:20 am

'cos I missed executing it. silly me :o

[email protected] ~ $ sudo dpkg -i --force-depends multiarch-support_2.13-35_armhf.deb
(Reading database ... 439 files and directories currently installed.)
Preparing to replace multiarch-support 2.13-35 (using multiarch-support_2.13-35_armhf.deb) ...
Unpacking replacement multiarch-support ...
dpkg: multiarch-support: dependency problems, but configuring anyway as you requested:
multiarch-support depends on libc6 (>= 2.13-5); however:
Package libc6:armhf is not configured yet.

Setting up multiarch-support (2.13-35) ...


Having now followed your instructions carefully, that seems to have fixed the problem thank you for your help and patience.

takobaba
Posts: 1
Joined: Fri May 03, 2013 7:40 am
Contact: Yahoo Messenger

Re: libgcc1 gone missing

Wed Jun 04, 2014 6:59 am

thanks it solved my libgcc1-libc6 debconf perl base, all of my problems

HvdW
Posts: 19
Joined: Tue Jun 17, 2014 12:41 pm

Re: libgcc1 gone missing

Tue Jun 17, 2014 7:29 pm

Thanks for the solution.
Everything works now.
Slight difference:
wget etc.
changed to
wget http://archive.raspbian.org/raspbian/po ... _armhf.deb

trdough
Posts: 14
Joined: Tue Nov 11, 2014 12:16 am

Re: libgcc1 gone missing

Fri Nov 14, 2014 6:17 pm

plugwash wrote:Yes libgcc1 is critical

Ok can you try

wget http://archive.raspbian.org/raspbian/po ... _armhf.deb
dpkg -i --force-depends multiarch-support_2.13-35_armhf.deb
dpkg -i libgcc1_4.7.1-8+rpi1_armhf.deb
apt-get -f install

When I try this it says HTTP request sent, awaiting response...404 not found. Im sure I typed it in correctly. Is there another one I should try? I also have lost my libgcc1.

User avatar
rpdom
Posts: 16088
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: libgcc1 gone missing

Fri Nov 14, 2014 7:12 pm

trdough wrote:When I try this it says HTTP request sent, awaiting response...404 not found. Im sure I typed it in correctly. Is there another one I should try?
This is because you are following advice that is two years old and seems to be out of date now.

The current file is http://archive.raspbian.org/raspbian/po ... _armhf.deb

Lope
Posts: 70
Joined: Tue Jul 02, 2013 7:53 pm

Re: libgcc1 gone missing

Sat May 02, 2015 4:40 pm

After upgrading to jessie I had this problem
Here are the newest commands as of today (that worked for me)
wget http://archive.raspbian.org/raspbian/po ... _armhf.deb
(by the way if you read this in future just browse http://archive.raspbian.org/raspbian/po ... /e/eglibc/ to find the latest multiarch file)

then I already had a libgcc1 in my /var/cache/apt/archives
I had to run dpkg -i --force-depends libgcc1_1%3a4.9.2-10_armhf.deb
to get it to work.
then apt-get install.

Return to “Raspbian”