jwollaston
Posts: 5
Joined: Wed Oct 17, 2012 11:40 pm

Raspbian distro with cifs support?

Wed Oct 17, 2012 11:56 pm

Hi,

I am looking for a Raspbian distribution with cifs support, but have been unable to find much information in this regard. Does such a thing exist? or should I be using a different distribution?

I am trying to mount a cifs share from my DNS-323 network attached storage device and keep getting an error message saying that it is not supported by the system. Apparently I need kernel support for this and the version that I am using doesn't have it.

Any help greatly appreciated.

Regards,

James.

Aydan
Posts: 742
Joined: Fri Apr 13, 2012 11:48 am
Location: Germany, near Lake Constance

Re: Raspbian distro with cifs support?

Thu Oct 18, 2012 4:13 pm

do "apt-cache search cifs" and you should get candidate packages to install.
I installed cifs support on both my pi's but don't remember the exact package name.
It might be cifs-utils.

Regards
Aydan

User avatar
Sander
Posts: 174
Joined: Wed Aug 31, 2011 1:01 pm

Re: Raspbian distro with cifs support?

Thu Oct 18, 2012 4:16 pm

It would be useful if you posted which exact commands you used, and which messages/errors you got.

blinkymike
Posts: 5
Joined: Sat Sep 01, 2012 4:04 am

Re: Raspbian distro with cifs support?

Fri Oct 19, 2012 4:57 am

James,

From the FAQ.
How do I mount a directory from a Windows server? Where's smbmount and smbfs?
smbfs has been replaced in Debian (and Raspbian) by cifs. The utility mount.cifs is in the package cifs-utils.
Also, the kernel you are using must be built to support mounting SMB/CIFS volumes.

To add until the next reboot do this
So you run "sudo apt-get install cifs-utils" to make sure you have support, make a directory under under your home directory or where ever lets say "Granola" under the pi home directory so "mkdir ~/Granola"
and then "sudo mount -t cifs -o username=UserNAME,password=SuperPASS //192.168.1.1/ServerFolder ~/Granola"
And that mounts a directory to /home/pi/Granola

For now I have that in a script until I add it on boot when I get done playing because I have about 12 different volumes mounted and being lazy ATM.

Somebody else probably has a better way maybe easier/faster including auto-mounting in fstab but it all depends on what you are wanting to do.

jwollaston
Posts: 5
Joined: Wed Oct 17, 2012 11:40 pm

Re: Raspbian distro with cifs support?

Fri Oct 19, 2012 7:13 am

Thanks for your replies.

Note that it is the Raspbian distribution that I am looking for as I have cifs-utils already installed and mount still fails.

The mount command that I have been using is:

Code: Select all

sudo mount //nas/Volume_2 /mnt/nas2 -o user=blah,password=blah,domain=network
I note that mount autodetects the type (cifs), as I was originally using the -t cifs option.
Note that nas is an entry in the hosts file, and correctly resolves for the ping command.

When I issue this command I get the following error:

Code: Select all

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

plugwash
Forum Moderator
Forum Moderator
Posts: 3748
Joined: Wed Dec 28, 2011 11:45 pm

Re: Raspbian distro with cifs support?

Fri Oct 19, 2012 4:07 pm

what happens if you try "modprobe cifs" ?

jwollaston
Posts: 5
Joined: Wed Oct 17, 2012 11:40 pm

Re: Raspbian distro with cifs support?

Sun Oct 21, 2012 11:10 am

When logged in as root, modprobe cifs returns:

Code: Select all

libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file '/lib/modules/3.1.9+/modules.dep.bin'

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: Raspbian distro with cifs support?

Sun Oct 21, 2012 11:52 am

Hmmm I am mounting my FreeNAS with:

Code: Select all

sudo /bin/mount -t cifs //192.168.1.35/network /media/network -o user=user -o password=PASS
sudo /bin/mount -t cifs //192.168.1.35/unix /media/unix -o user=user -o password=PASS
sudo /bin/mount -t cifs //192.168.1.35/pisource /media/src -o user=user -o password=PASS
I didn't load anything special to get this to work.

I use:

Code: Select all

sudo mount -t cifs //192.168.1.12/movie-iso /media/iso -o user=USER -o password=PASS
to mount an ISO directory on my Win7 workstation on the RPi as well.

They all show up like:

Code: Select all

//192.168.1.35/network    452G  263G  153G  64% /media/network
//192.168.1.35/unix       452G  263G  153G  64% /media/unix
//192.168.1.35/pisource    10G    1G   99G   1% /media/src
//192.168.1.12/movie-iso  299G  276G   24G  93% /media/iso
modprobe cifs
doesn't return anything when I try it.
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

plugwash
Forum Moderator
Forum Moderator
Posts: 3748
Joined: Wed Dec 28, 2011 11:45 pm

Re: Raspbian distro with cifs support?

Sun Oct 21, 2012 12:43 pm

jwollaston wrote:When logged in as root, modprobe cifs returns:

Code: Select all

libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file '/lib/modules/3.1.9+/modules.dep.bin'
It seems the kernel you are using has got out of step with the modules you have installed. Which image did you use? have you attempted to update the kernel at any point and if-so how?

jwollaston
Posts: 5
Joined: Wed Oct 17, 2012 11:40 pm

Re: Raspbian distro with cifs support?

Mon Oct 22, 2012 10:04 pm

Current plan is to set up a new boot SD with the 2012-09-18 version of Raspbian Wheezy. Will post back here if that makes the difference.

What does surprise me is the lack of information regarding cifs support in the kernel build. The FAQ makes it clear that to mount a cifs share you will need the cifs-utils package and kernel support but I can't find any information in the various linux distros for the Pi in this regard.

Am I missing something here?

itimpi
Posts: 1090
Joined: Sun Sep 25, 2011 11:44 am
Location: Potters Bar, United Kingdom
Contact: Website

Re: Raspbian distro with cifs support?

Mon Oct 22, 2012 10:10 pm

I have never had any trouble with cifs in any of the Raspbian builds without installing anything extra. I always add an cifs entry to /etc/fstab to pick up my software Archives from my NAS. Adding it to /etch stab means that it is auto-mounted by the system as part of the booting process which is convenient.

jwollaston
Posts: 5
Joined: Wed Oct 17, 2012 11:40 pm

Re: Raspbian distro with cifs support?

Tue Oct 23, 2012 10:43 am

Thanks for your replies guys.

Installing latest version (per post above) did the trick.

uname -a now reports:
Linux raspberrypi 3.2.27+ #160 PREEMPT Mon Sep 17 23:18:42 BST 2012 armv6l GNU/Linux

and my mount command works without a hitch.

Yippee.

priority
Posts: 22
Joined: Sat Mar 16, 2013 6:26 pm

Re: Raspbian distro with cifs support?

Thu Dec 19, 2013 12:14 am

Bumped into the exact same error, but I had a rather complex setup that I didn't want to reinstall at the moment. Here's what did the trick for me:

Code: Select all

sudo rpi-update
sudo reboot

petez69
Posts: 2
Joined: Thu Dec 26, 2013 5:20 am

Re: Raspbian distro with cifs support?

Thu Dec 26, 2013 5:22 am

Thanks for the info, that fixed my problem....

Pete

SonarJetLens
Posts: 1
Joined: Sun Jan 05, 2014 9:51 am

Re: Raspbian distro with cifs support?

Sun Jan 05, 2014 9:53 am

Just as a note: I have just run into this same problem with a new pi (bought a month ago) and the thing that fixed it for me was the rpi-update/reboot trick

mcfan
Posts: 2
Joined: Mon Jan 06, 2014 1:23 am

Re: Raspbian distro with cifs support?

Mon Jan 06, 2014 1:29 am

I have the same problem. I tried your hint of updating the firmware, but doesn't work yet! I have described my problem with all the details here http://raspberrypi.stackexchange.com/qu ... red-folder
Someone can help me?

plugwash
Forum Moderator
Forum Moderator
Posts: 3748
Joined: Wed Dec 28, 2011 11:45 pm

Re: Raspbian distro with cifs support?

Mon Jan 06, 2014 4:59 pm

umm, you should be using -t cifs not -t ntfs-3g

mcfan
Posts: 2
Joined: Mon Jan 06, 2014 1:23 am

Re: Raspbian distro with cifs support?

Mon Jan 06, 2014 9:11 pm

Eventually I have solved my problem putting sec=ntlm in the options of call.

Return to “Raspberry Pi OS”