gordonendersby
Posts: 34
Joined: Fri Jun 22, 2012 4:04 pm
Location: Croydon, Surrey

Wheezy 2012-9-18 locking up usb and networking

Tue Oct 16, 2012 11:11 am

Hi all,

Just tried a new install of Raspbian wheezy 2012-9-18.
Everything seemed to work out of the box.
Wireless setup works great. Using RTL8188CUS 802.11n.
I installed mysql, lighttpd, and my perl scripts to communicate to an arduino collecting temperature, pressure and humidity. This has all been working fine headless on the previous version for some time without any intervention.

But with the new 9-18 version it locked up overnight.
In syslog it shows errors for eth0 which Im not using as Im using a wireless adaptor.
Syslog show:

Code: Select all

Oct 16 01:36:38 raspberrypi dhclient: DHCPREQUEST on wlan0 to 192.168.0.1 port 67
Oct 16 01:36:39 raspberrypi dhclient: DHCPACK from 192.168.0.1
Oct 16 01:36:39 raspberrypi dhclient: bound to 192.168.0.34 -- renewal in 1619 seconds.
Oct 16 02:03:38 raspberrypi dhclient: DHCPREQUEST on wlan0 to 192.168.0.1 port 67
Oct 16 02:03:39 raspberrypi dhclient: DHCPACK from 192.168.0.1
Oct 16 02:03:39 raspberrypi dhclient: bound to 192.168.0.34 -- renewal in 1737 seconds.
Oct 16 02:17:01 raspberrypi /USR/SBIN/CRON[3357]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Oct 16 02:32:36 raspberrypi dhclient: DHCPREQUEST on wlan0 to 192.168.0.1 port 67
Oct 16 02:32:37 raspberrypi dhclient: DHCPACK from 192.168.0.1
Oct 16 02:32:37 raspberrypi dhclient: bound to 192.168.0.34 -- renewal in 1663 seconds.
Oct 16 02:55:25 raspberrypi kernel: [23668.794596] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Oct 16 02:55:30 raspberrypi kernel: [23673.794704] smsc95xx 1-1.1:1.0: eth0: Failed to write register index 0x00000114
Oct 16 02:55:35 raspberrypi kernel: [23678.794804] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Oct 16 02:55:40 raspberrypi kernel: [23683.794895] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000118
Oct 16 02:55:45 raspberrypi kernel: [23688.794987] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
and a bit later:

Code: Select all

Oct 16 03:00:05 raspberrypi kernel: [23948.960495] ftdi_sio ttyUSB0: urb failed to clear flow control
Oct 16 03:00:06 raspberrypi kernel: [23949.800524] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000118
Oct 16 03:00:10 raspberrypi kernel: [23953.960584] ftdi_sio ttyUSB0: urb failed to clear flow control
Oct 16 03:00:12 raspberrypi kernel: [23955.800652] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Is this hinting at a usb failure, as both the wireless and ethernet adaptors are on the usb buss?
Is there any known problems or fixes I can have a look at and try?

For my overnight test I left the usb hub, mouse, keyboard, wireless adapter and arduino plugged in where normally I just have the wireless adaptor and arduino only.
This hasnt been a problem before but could it be something about the latest raspbian that doesnt like it?

Thanks for reading

Gordon

gordonendersby
Posts: 34
Joined: Fri Jun 22, 2012 4:04 pm
Location: Croydon, Surrey

Re: Wheezy 2012-9-18 locking up usb and networking

Wed Oct 17, 2012 10:37 am

I removed the usb hub, keyboard and mouse.
Left the Arduino and wireless adaptor.
Nearly 24 ours now headless and no lockup.
No obvious errors in syslog.

So maybe this was a problem with power or a usb driver problem with the hub.
Ill keep an eye on it and see how it goes as the idea is to leave this running 24/7 collecting data in mysql and the webserver as the interface to the device.

Gordon

Aglet
Posts: 2
Joined: Thu Oct 18, 2012 12:41 pm

Re: Wheezy 2012-9-18 locking up usb and networking

Thu Oct 18, 2012 12:55 pm

I also have been seeing similar errors. My PI is running headless with only a USB drive connected. I am using it as a samba server to store files. I can pull down files without error, but when I upload files, I get the following errors.

Oct 18 06:58:25 raspberrypi kernel: [287074.526818] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Oct 18 07:05:41 raspberrypi kernel: [287510.504051] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Oct 18 08:11:33 raspberrypi kernel: [291462.443117] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000118

So far, I've tried Wheezy 2012-9-18 & Wheezy 2012-8-18 with no difference. I have also tried different USB drives with no difference. I even left my PI converting .wav to .mp3 for a week with no errors, but as soon as I upload files I get the errors, it will eventually lock and require a cold boot.

gordonendersby
Posts: 34
Joined: Fri Jun 22, 2012 4:04 pm
Location: Croydon, Surrey

Re: Wheezy 2012-9-18 locking up usb and networking

Thu Oct 18, 2012 6:51 pm

Well its Thursday now and the raspi has been on all the time.
Mysql, lighttpd and perl scrips running all ok.
No lock ups or errors since I removed the usb hub, keyboard and mouse.

Code: Select all

[email protected] ~ $ uptime
19:49:04 up 2 days,  7:36,  2 users,  load average: 0.02, 0.12, 0.13
Could be a problem for other uses where a keyboard, mouse and wireless adaptor are needed.

Gordon

gordonendersby
Posts: 34
Joined: Fri Jun 22, 2012 4:04 pm
Location: Croydon, Surrey

Re: Wheezy 2012-9-18 locking up usb and networking

Sat Oct 20, 2012 10:40 am

Nope, not solved, went down just after 11.00pm last night.
Same problem. It lost usb so wireless stopped working and couldnt pick any data up from the arduino.
This was headless with just the wireless adapter and Arduino.
The arduino has just 3 very low power devices attached. 2 DHT22 temp/humidity sensors and 1 bmp085 breakout board and sensor.
I have a decent quality power supply.

This is quite frustrating as there seems to be no fix or explanation of why its happening.
I cant see how it could be power related.

I think Ill have to go back to the earlier wheezy even though it was a bit fiddlier to set up with wireless support.


Gordon

User avatar
with ice cream
Posts: 175
Joined: Mon Jul 30, 2012 7:25 am

Re: Wheezy 2012-9-18 locking up usb and networking

Sat Oct 20, 2012 11:15 am

My (headless) Pi also freezes after 6 to 12 hours of uptime (sometimes in the middle of the night). There are no visible anomalies in the syslog. It is not just the network (wifi) that freezes, all LEDs that usually show activity stay either on or off, the LCD keychain display (lcd4linux driven) freezes. So I assume that the whole devices stops operating. There are no potential triggers that I am aware of.

I am now running sysstat to see if the data collected provides any clues.

User avatar
with ice cream
Posts: 175
Joined: Mon Jul 30, 2012 7:25 am

Re: Wheezy 2012-9-18 locking up usb and networking

Mon Oct 22, 2012 10:04 am

I found the culprit. It is a USB thermometer. My Pi is stable ever since I unplugged it. The device kept disconnecting and got a new ID assigned every two to five minutes. The remaining question: should such mildly misbehaving USB devices really bring the Pi to the fall?

hormiguero
Posts: 9
Joined: Mon Sep 17, 2012 1:31 pm

Re: Wheezy 2012-9-18 locking up usb and networking

Mon Oct 22, 2012 5:41 pm

I've had a similar problem... I'm using an FTDI USB->Serial (FT232R) to drive an LCD display on a headless Pi doing checks on my VPN and local network. I had a failure on the eth0 and saw the following IP addresses...

Code: Select all

Oct 20 17:16:48 keylimepi ntpd[1947]: Deleting interface #3 eth0, 192.168.2.101#123, interface stats: received=647, sent=649, dropped=0, active_time=104530 secs
Oct 20 17:16:48 keylimepi ntpd[1947]: 206.210.192.32 interface 192.168.2.101 -> (none)
Oct 20 17:16:48 keylimepi ntpd[1947]: 199.249.224.123 interface 192.168.2.101 -> (none)
Oct 20 17:16:48 keylimepi ntpd[1947]: 198.110.48.12 interface 192.168.2.101 -> (none)
Oct 20 17:16:48 keylimepi ntpd[1947]: 204.45.7.82 interface 192.168.2.101 -> (none)
Oct 20 17:16:48 keylimepi ntpd[1947]: peers refreshed
Oct 20 17:16:48 keylimepi kernel: [105734.104710] smsc95xx 1-1.1:1.0: eth0: Failed to write register index 0x00000014
Oct 20 17:16:48 keylimepi kernel: [105734.104743] smsc95xx 1-1.1:1.0: eth0: Failed to write HW_CFG_LRST_ bit in HW_CFG register, ret = -110
Where do these IP addresses come from?? I've tried tracing them, but haven't gotten a resolution... I've also installed watchdog as indicated in the tutorials and have not generated a reboot - tried to use watchdog to check the network and get continuous reboot. I've read postings that the ping in watchdog doesn't work, what are the other options to generate a reboot??

meufeu
Posts: 6
Joined: Wed Dec 19, 2012 8:36 am

Re: Wheezy 2012-9-18 locking up usb and networking

Sun Jan 06, 2013 10:09 pm

hi from france
i'm interrested in a way to restart when the issue occurs !
do you have anything ?

sturi
Posts: 1
Joined: Thu Jan 17, 2013 9:16 am

Similar problem

Thu Jan 17, 2013 9:26 am

I've a similar problem: my PI freezes after 1 or 2 days.
I've connect PI to a weather Station via USB in order to retrieve data using a java program.
My OS is Linux raspberrypi 3.2.27+ #250 PREEMPT Thu Oct 18 19:03:02 BST 2012 armv6l

Can anyone recommend a more solid OS?
Thanks

Aglet
Posts: 2
Joined: Thu Oct 18, 2012 12:41 pm

Re: Wheezy 2012-9-18 locking up usb and networking

Thu Jan 17, 2013 4:38 pm

My issue turned out to be the polyfuse. The unit uses an NCP1117-3V3 regulator, this regulator has a 1.2 Volt minimum between the input voltage and the regulated voltage. I calculate the minimum required voltage of 3.3 + 1.2 = 4.5volts required after the polyfuse. My USB supply was producing 5.10 Volts, but with my keyboard and mouse connected, I was dropping 0.61 volts accross the polyfuse to leave only 4.49Volts on the input of the regulator (measured at TP1). Once you consider noise, it's a wonder that it ever worked. My solution was to solder a wire accross the polyfuse bringing the voltage on the input of the regulator (TP1) up to 5.10 volts. My PI no longer crashes and I have had it running as long as 63 days before I shut it down to try another Linux distro.

Return to “Raspbian”