kudbuloken
Posts: 2
Joined: Sun Dec 10, 2017 6:49 pm

[SOLVED] Issue with libcairo2-dev package installation

Sun Dec 10, 2017 7:42 pm

Hello,

I'm using the last Raspbian Stretch Lite on a Raspberry Pi 3.
I've tried to install the libcairo2-dev package from default repository but it failed. I have the famous message :

Code: Select all

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libcairo2-dev : 
Depends: libfontconfig1-dev (>= 2.2.95) but it is not installable
Depends: libfreetype6-dev (>=2.1.10) but it is not installable
Depends: libpng-dev but it is not installable
E: Unable to correct problems, you have held broken packages.

I have checked broken packages. My own current installed packages are :
- libfontconfig1-dev (2.11.0-6.7)
- libfreetype6-dev (2.6.3-3.2)
- libpng-dev (1.6.28-1)

In /etc/apt/sources.list, I have the two following lines :

Code: Select all

deb http://mirrordirector.raspian.org/raspbian/ stretch main contrib non-free $
deb-src http://archive.raspian.org/raspbian/ stretch main contrib non-free rpi
I don't understand why this package could not be installed.
Is there any problem with this package in Stretch ? Does this issue come from Raspian Lite only and does not appear in Raspian (I'm not using any desktop) ?

Thank you for your help
Vincent
Last edited by kudbuloken on Mon Dec 11, 2017 3:19 pm, edited 1 time in total.

kudbuloken
Posts: 2
Joined: Sun Dec 10, 2017 6:49 pm

Re: Issue with libcairo2-dev package installation

Mon Dec 11, 2017 3:11 pm

The problem is solved

The problem occured when I tried to install the astrometry.net 's plate solver in a Raspberry Pi, according to astrometry.net manual (http://astrometry.net/doc/build.html#build). The command is :

Code: Select all

$ sudo apt-get install libcairo2-dev libnetpbm10-dev netpbm libpng12-dev libjpeg-dev python-numpy python-pyfits python-dev zlib1g-dev libbz2-dev swig cfitsio-dev
If you try this as-is, it fails and returns the error displayed on my first message.
You have to get package one after one and it works.

Code: Select all

sudo apt-get install libcairo2-dev
sudo apt-get install libnetpbm10-dev ...
Vincent

Return to “Raspbian”

Who is online

Users browsing this forum: No registered users and 23 guests