Page 2 of 3

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Apr 16, 2018 9:59 pm
by DougieLawson
jtmoderate876 wrote:
Sun Apr 15, 2018 11:58 pm
Feels like xrdp is no longer practical on rpi.
serious bummer.
What's wrong with using RealVNC?

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sat Apr 21, 2018 10:02 pm
by jtmoderate876
Continued bummer...
XRDP is still broken on 2018-04-18 release of stretch.
Still can't get past login.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sun Apr 22, 2018 9:00 pm
by jtmoderate876
DougieLawson wrote:
Mon Apr 16, 2018 9:59 pm
What's wrong with using RealVNC?
Sorry for the delayed response @DougieLawson

It's just I use RDP to access everything else - servers and computers running locally, in Azure, AWS, my company cloud, and this use to work pretty perfectly (recently adding better mouse support and copy/paste).

But I guess I need to move to RealVNC for raspberry.
Thx.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sun Apr 22, 2018 9:39 pm
by jtmoderate876
GOT XRDP WORKING AGAIN with the help from another forum that mentioned enabling VNC for XRDP setups.

I've not had to do that previously - but it worked.
So to configure a new stretch install for XRDP:

#use raspi-config to enable VNC so XRDP will work (new step for 2018-04)
#attach to wifi network
sudo apt-get install xrdp
# to repair xrdp append '@xhost si:localuser:root' to /home/pi/.config/lxsession/LXDE-pi/autostart othterwise sudo gui like
echo '@xhost si:localuser:root' | sudo tee -a /home/pi/.config/lxsession/LXDE-pi/autostart
sudo reboot # required
# and RDP using XRDP should work again

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Apr 23, 2018 12:59 pm
by jtmoderate876
MORE PROBLEMS with XRDP:

If I change the password from the default (pi/raspberry) I can no longer XRDP.

Yet if I change the password back to raspberry I can XRDP.

This is repeatable - back and forth.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Apr 23, 2018 1:11 pm
by jtmoderate876
I gave up on XRDP and switched to RealVNC.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sun Apr 29, 2018 1:23 am
by jtmoderate876
I have to pare down my use of pi because of this lack of xrdp support, the time consuming process of realizing that, trying to fix XRDP, giving up and adapting to RealVNC.

I know "RealVNC is better" and XRDP is dead and all, but..

The different VNC installs, learning curve (can't get true full screen, graphics still dithered, workflow different than cloud RDP computers, etc.) ...
... are causing me to depart from this previously enjoyable raspberry pi platform.

I was using these for expanding my testing options and instances but it has become combersome and the cloud options, while probably a little more costly, are now preferable.

The work here is so neat but I started to pull it in for professional things and that isn't working out without RDP.
There are plenty of great things about PI but also plenty of learning curves and time sinks for someone coming from windows.

It's too bad that raspbian became incompatible with RDP.
You guys should review this issue.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sun Apr 29, 2018 3:52 am
by fruitoftheloom
jtmoderate876 wrote:
Sun Apr 29, 2018 1:23 am
I have to pare down my use of pi because of this lack of xrdp support, the time consuming process of realizing that, trying to fix XRDP, giving up and adapting to RealVNC.

I know "RealVNC is better" and XRDP is dead and all, but..

The different VNC installs, learning curve (can't get true full screen, graphics still dithered, workflow different than cloud RDP computers, etc.) ...
... are causing me to depart from this previously enjoyable raspberry pi platform.

I was using these for expanding my testing options and instances but it has become combersome and the cloud options, while probably a little more costly, are now preferable.

The work here is so neat but I started to pull it in for professional things and that isn't working out without RDP.
There are plenty of great things about PI but also plenty of learning curves and time sinks for someone coming from windows.

It's too bad that raspbian became incompatible with RDP.
You guys should review this issue.

The xRDP package is the responsibility of the Debian Maintainers nothing to do with RPT / RPF, contact them if broken:

https://packages.debian.org/stretch/xrdp

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Apr 30, 2018 9:09 am
by loopyludo
First off many thanks for everyone that has contributed to this post so far, it has been an education for me as I searched for an alternative to VNC.

jtmoderate876 may I suggest that you try the backport xrdp package. I have successfully just installed this and it has worked for me.

You will need to add the backports source first to /etc/apt/sources.list
deb http://ftp.debian.org/debian stretch-backports main

Then install the backport xrdp
sudo apt-get -t stretch-backports install xrdp

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Apr 30, 2018 3:22 pm
by jtmoderate876
THANK YOU loopyludo ! THAT WORKED!

My exact steps were:

Code: Select all

sudo leafpad /etc/apt/sources.list
# and add the following excluding #:
# deb http://ftp.debian.org/debian stretch-backports main
sudo apt-get update
sudo apt-get -t stretch-backports install xrdp

# to repair xrdp  to allow elevated apps like rasperry configure, etc. append '@xhost si:localuser:root' to /home/pi/.config/lxsession/LXDE-pi/autostart othterwise sudo gui like 
echo '@xhost si:localuser:root' | sudo tee -a /home/pi/.config/lxsession/LXDE-pi/autostart
sudo reboot # required

Can you briefly describe what that did?
Is a backport the version of XRDP for the "NEXT" release of debian - pulled forward into this current stretch release?
So that would mean someone has already fixed it for the future?

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Apr 30, 2018 3:51 pm
by loopyludo
jtmoderate876 Glad that worked for you, to be fair I am not exactly sure what the backports are, I believe what has happened is that someone has recompiled the xrdp package from the next unstable release however using the current stable release libraries.

I do hope that would mean that it will work in the future releases.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Apr 30, 2018 4:03 pm
by jtmoderate876
Thanks again - wish I met you a couple weeks ago!

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Oct 22, 2018 6:02 am
by mohsenganj
Image

this may help you find a solution:

1. first, use the "Logout" Button from "Shutdown Options" Dialogue to logout
2. then Log in again
3. now yo can use Shutdown and Reboot Buttons

it is strange but working

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Oct 22, 2018 8:48 am
by mohsenganj
loopyludo wrote:
Mon Apr 30, 2018 9:09 am
First off many thanks for everyone that has contributed to this post so far, it has been an education for me as I searched for an alternative to VNC.

jtmoderate876 may I suggest that you try the backport xrdp package. I have successfully just installed this and it has worked for me.

You will need to add the backports source first to /etc/apt/sources.list
deb http://ftp.debian.org/debian stretch-backports main

Then install the backport xrdp
sudo apt-get -t stretch-backports install xrdp
it is NOT working for me

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Tue Oct 23, 2018 1:05 am
by devenh
As much as I'd like to get the Shutdown options dialog to work, I gave up trying and simply created these two scripts and placed them on my desktop:

shutdown.sh

Code: Select all

#!/bin/bash
sudo shutdown -h now
reboot.sh

Code: Select all

#!/bin/bash
sudo reboot

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sun Nov 04, 2018 10:00 pm
by noobinpi
You can get the Buttons working, just change the line 'Logout=lxde-pi-shutdown-helper' to 'Logout=gksudo lxde-pi-shutdown-helper'
in '/home/pi/.config/lxpanel/LXDE-pi/config'.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sun Nov 04, 2018 10:12 pm
by noobinpi
Just change 'Logout=lxde-pi-shutdown-helper' in '/home/pi/.config/lxpanel/LXDE-pi/config' to 'Logout=gksudo lxde-pi-shutdown-helper' and all buttons are working.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Fri Nov 09, 2018 10:26 am
by tony_lock
The reason why the shutdown doesn't work even after running as sudo is it seems to check who the real user is. The program actually running is lxde-pi-shutdown-helper, which is called via /home/pi/.config/lxpanel/LXDE-pi/config commenting out the Logout=lxde-pi-shutdown-helper in the config file produces a much more useful logout menu which prompts for a password on Shutdown and Reboot but does do it.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Fri Nov 09, 2018 10:01 pm
by ejolson
tony_lock wrote:
Fri Nov 09, 2018 10:26 am
The reason why the shutdown doesn't work even after running as sudo is it seems to check who the real user is.
Where I am xrdp is used to allow many people to simultaneously log into Linux running on a fairly well provisioned Xeon server from their Windows office computers. It would be a disaster if the shutdown menu actually worked. I suspect permissions for the menu options that shut the system down rely on which user currently owns the console. Since people logging in remotely don't have physical access, it makes sense that they not be allowed to reboot.

Because the old versions in the repositories don't work very well, I've always resorted to compiling xorg and xorgrdp from source. It appears to be good code that is surprisingly easy to compile. Using the version from backports sounds like a reasonable compromise between the old package in Raspbian and compiling the latest version yourself.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sun Dec 09, 2018 6:50 am
by bctf1
I am interested in this thread as a xrdp user on my 3B+ running stretch. The primary issue I have with xrdp is the lack of access to Preferences/Raspberry Pi Configuration. I have workarounds in place for most of the other menu options that require sudo permission during remote sessions.

I tried jagoliveira's suggestion from this thread where he said "In order to run 'Raspberry PI Configuration' tool and others that need 'sudo' to run in Remote GUI, I inserted X authorization of 'xhost' for 'root' in:
/home/pi/.config/lxsession/LXDE-pi/autostart --> Insert '@xhost si:localuser:root' as last line."

There was no file named autostart at this folder location (yes, I displayed hidden files) so I used nano to create it and then added the line '@xhost si:localuser:root' and saved the file. My 3B+ would not boot afterwards until I deleted the autostart file.

This fix worked for ktm_91 but did not for me. I have not tried adding the the backports source/backport xrdp install option. Additional suggestions would be appreciated.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Dec 10, 2018 5:42 am
by mohsenganj
Raspbian Stretch with desktop and recommended software
Version: November 2018
Release date: 2018-11-13
Kernel version: 4.14

New release of raspbian rtretch is available
did they fix this problem or not?

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Dec 10, 2018 11:23 am
by fbe
bctf1 wrote:
Sun Dec 09, 2018 6:50 am
I am interested in this thread as a xrdp user on my 3B+ running stretch. The primary issue I have with xrdp is the lack of access to Preferences/Raspberry Pi Configuration.
...
Additional suggestions would be appreciated.

Code: Select all

gksudo rc_gui

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Mon Dec 10, 2018 6:39 pm
by bctf1
fbe wrote:
Mon Dec 10, 2018 11:23 am
bctf1 wrote:
Sun Dec 09, 2018 6:50 am
I am interested in this thread as a xrdp user on my 3B+ running stretch. The primary issue I have with xrdp is the lack of access to Preferences/Raspberry Pi Configuration.
...
Additional suggestions would be appreciated.

Code: Select all

gksudo rc_gui
Thanks fbe for your suggestion but after using VNC over the last few days as my primary remote connection tool, I have decided that it works just as well or better than xrdp and it suffers from none of the sudo permissions problems. The only drawback I see so far with VNC is that it does not support audio from the Pi which I can live with. I will however continue to monitor this thread for further xrdp developments.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sat Dec 15, 2018 1:10 pm
by jtmoderate876
It seems that the 2018-11-13 release of raspbian has again messed up my xrdp workarounds.

The previous autostart file is gone at:
/home/pi/.config/lxsession/LXDE-pi/autostart

so this no longer works:
echo '@xhost si:localuser:root' | sudo tee -a /home/pi/.config/lxsession/LXDE-pi/autostart

Once again, sadly, without xrdp.

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

Posted: Sat Dec 15, 2018 3:04 pm
by spl23
jtmoderate876 wrote:
Sat Dec 15, 2018 1:10 pm
It seems that the 2018-11-13 release of raspbian has again messed up my xrdp workarounds.

The previous autostart file is gone at:
/home/pi/.config/lxsession/LXDE-pi/autostart

so this no longer works:
echo '@xhost si:localuser:root' | sudo tee -a /home/pi/.config/lxsession/LXDE-pi/autostart

Once again, sadly, without xrdp.
Your autostart file is backed up in /home/pi/oldconf/.config/lxsession/LXDE-pi/autostart - just copy it back to where you had it before.

As explained in the blog post for this release, the intention was to try to get to the point where we didn't have to change user config in future when we were updating themes and the like, but to do that, we did need to do one final backup of user files.

Autostart suffered from some bizarre behaviour in lxsession - there is a local autostart file and a global one, where the local file overrules the global one if it exists. Unfortunately, the lxsession authors made the decision to copy the global file into the local location if there wasn't one there already, which means it is impossible for further changes in the global file to take effect. I've modified the relevant code to not do this any more, but in order to make sure most people did see future changes to the global file, it was necessary to remove the local one.