seth.raspi
Posts: 2
Joined: Mon Aug 14, 2017 9:04 pm

apt-get 404...

Mon Aug 14, 2017 9:10 pm

I just got a pi and did my updates and upgrades. Everything was fine for a day or so, then I wanted to install/update python to use the gpio functions. I was getting 404s, so ran update again:

Code: Select all

Ign http://mirrordirector.raspbian.org jessie InRelease
Ign http://archive.raspberrypi.org jessie InRelease
Ign http://mirrordirector.raspbian.org jessie Release.gpg
Ign http://archive.raspberrypi.org jessie Release.gpg
Ign http://mirrordirector.raspbian.org jessie Release
Ign http://archive.raspberrypi.org jessie Release
Err http://archive.raspberrypi.org jessie/main armhf Packages
  404  Not Found
Err http://archive.raspberrypi.org jessie/ui armhf Packages
  404  Not Found
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Err http://mirrordirector.raspbian.org jessie/main armhf Packages
  404  Not Found
Err http://mirrordirector.raspbian.org jessie/contrib armhf Packages
  404  Not Found
Err http://mirrordirector.raspbian.org jessie/non-free armhf Packages
  404  Not Found
Err http://mirrordirector.raspbian.org jessie/rpi armhf Packages
  404  Not Found
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/jessie/main/binary-armhf/Packages  404  Not Found

W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/jessie/contrib/binary-armhf/Packages  404  Not Found

W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/jessie/non-free/binary-armhf/Packages  404  Not Found

W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/jessie/rpi/binary-armhf/Packages  404  Not Found

W: Failed to fetch http://archive.raspberrypi.org/debian/dists/jessie/main/binary-armhf/Packages  404  Not Found

W: Failed to fetch http://archive.raspberrypi.org/debian/dists/jessie/ui/binary-armhf/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
Servers down or some other error?

Thanks! Seth

Heater
Posts: 7615
Joined: Tue Jul 17, 2012 3:02 pm

Re: apt-get 404...

Mon Aug 14, 2017 9:35 pm

Those links work fine from here. You seem to have a network problem.

User avatar
DougieLawson
Posts: 29387
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: apt-get 404...

Tue Aug 15, 2017 1:11 am

Try sudo apt-get update then try again.

If that doesn't work you have a network problem.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.

seth.raspi
Posts: 2
Joined: Mon Aug 14, 2017 9:04 pm

Re: apt-get 404...

Tue Aug 15, 2017 12:17 pm

All my fault. iptables rules had been applied to all interfaces, etc.

in3vrr
Posts: 16
Joined: Sat Oct 08, 2016 1:30 pm

Re: apt-get 404...

Sun Sep 10, 2017 5:02 pm

I have the same problem !!!
With RPI3 Raspbian Jessie
Kernell 4.4.26-v7+ #915 SMP Thu Oct 20 17:08:44 BST 2016 armv7l GNU/Linux

After "sudo apt-get update" I have these errors:

Ign http://archive.raspberrypi.org jessie InRelease
Ign http://mirrordirector.raspbian.org jessie InRelease
Ign http://archive.raspberrypi.org jessie Release.gpg
Ign http://mirrordirector.raspbian.org jessie Release.gpg
Ign http://archive.raspberrypi.org jessie Release
Ign http://mirrordirector.raspbian.org jessie Release
Err http://archive.raspberrypi.org jessie/main armhf Packages
404 Not Found [IP: 93.93.130.214 80]
Err http://archive.raspberrypi.org jessie/ui armhf Packages
404 Not Found [IP: 93.93.130.214 80]
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Err http://mirrordirector.raspbian.org jessie/main armhf Packages
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org jessie/contrib armhf Packages
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org jessie/non-free armhf Packages
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org jessie/rpi armhf Packages
404 Not Found [IP: 93.93.128.193 80]
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
W: Failed to fetch http://archive.raspberrypi.org/debian/d ... f/Packages 404 Not Found [IP: 93.93.130.214 80]
W: Failed to fetch http://archive.raspberrypi.org/debian/d ... f/Packages 404 Not Found [IP: 93.93.130.214 80]
W: Failed to fetch http://mirrordirector.raspbian.org/rasp ... f/Packages 404 Not Found [IP: 93.93.128.193 80]
W: Failed to fetch http://mirrordirector.raspbian.org/rasp ... f/Packages 404 Not Found [IP: 93.93.128.193 80]
W: Failed to fetch http://mirrordirector.raspbian.org/rasp ... f/Packages 404 Not Found [IP: 93.93.128.193 80]
W: Failed to fetch http://mirrordirector.raspbian.org/rasp ... f/Packages 404 Not Found [IP: 93.93.128.193 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

sudo ping www.google.com works !
sudo ping 93.93.130.214 works !
sudo ping archive.raspberrypi.org works !
On SD I have 8GB available
even with "sudo apt-get clean" does not change anything

Anyone can tell me how to fix this problem
Thank you
Bob

in3vrr
Posts: 16
Joined: Sat Oct 08, 2016 1:30 pm

Re: apt-get 404...

Wed Sep 13, 2017 7:19 pm

in3vrr wrote:
Sun Sep 10, 2017 5:02 pm
I have the same problem !!!
With RPI3 Raspbian Jessie
Kernell 4.4.26-v7+ #915 SMP Thu Oct 20 17:08:44 BST 2016 armv7l GNU/Linux

After "sudo apt-get update" I have these errors:

Ign http://archive.raspberrypi.org jessie InRelease
Ign http://mirrordirector.raspbian.org jessie InRelease
Ign http://archive.raspberrypi.org jessie Release.gpg
Ign http://mirrordirector.raspbian.org jessie Release.gpg
Ign http://archive.raspberrypi.org jessie Release
Ign http://mirrordirector.raspbian.org jessie Release
Err http://archive.raspberrypi.org jessie/main armhf Packages
404 Not Found [IP: 93.93.130.214 80]
....cut....

Anyone can tell me how to fix this problem
Thank you
Bob
---------------------------------
Maybe can I fix this problem by modifying sources.list (sudo nano /etc/apt/sources.list)????

This is my sources.list:
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

What changes should I do?

I have two RPI3, the first one with ADSL and the second (on a remote site) with router + USB 4G key.
The strange thing is this:
1) The RPI3-first with ADSL 'sudo apt-get update' works
2) The RPI3-second with the 4G USB Stick has the problem described in my post above
The two sources.list files are the same

As already written, with RPI3-second there are no problems because:
On SD I have 8GB available
sudo ping www.google.com works !
sudo ping 93.93.130.214 works !
sudo ping archive.raspberrypi.org works !

Perhaps 'sudo apt-get update' does not find the right directories?
How does the system work?

There are some raspberry/Jessie 'guru' who know how to fix this problem ???
Thank you
Bob

in3vrr
Posts: 16
Joined: Sat Oct 08, 2016 1:30 pm

Re: apt-get 404...

Sun Sep 17, 2017 8:28 am

in3vrr wrote:
Wed Sep 13, 2017 7:19 pm
..... CUT
What changes should I do?

I have two RPI3, the first one with ADSL and the second (on a remote site) with router + USB 4G key.
The strange thing is this:
1) The RPI3-first with ADSL 'sudo apt-get update' works
2) The RPI3-second with the 4G USB Stick has the problem described in my post above
The two sources.list files are the same

....CUT
My two RPI3s are located on two different sites about 500km away
I tried to do ping on both and these are the results:
"sudo ping mirrordirector.raspbian.org" both point to the same IP: 93.93.128.193
"sudo ping archive.raspberrypi.org" IP 93.93.128.133 the RPI that with "sudo apt-get update" works; IP 93.93.130.104 the RPI that with "sudo apt-get update" does NOT work
Perhaps to divide traffic on different servers this thing is also correct....
But could this be one of the causes of "sudo apt-get update" failure?

Any suggestions for solving these problems?
Thank you
Bob

Return to “Raspbian”

Who is online

Users browsing this forum: gyoezoe and 23 guests