sadoldgeek
Posts: 2
Joined: Tue Oct 02, 2012 7:37 pm

NFS mount gives segmentation error

Tue Oct 02, 2012 7:50 pm

Hello, I have tried to mount an NFS share on my Raspberry using the instructions at http://www.raspbian.org/RaspbianFAQ#How ... S_share.3F. The resulting output is: "Starting rpcbind daemon...Segmentation fault". The subsequent mount command itself doesn't produce any errors but the share will not mount. I know the share is good because I can mount it on my Mac and Ubuntu machines. Any thoughts on why the rpcbind service gives this error. (using Linux raspberrypi 3.1.9+ #272 PREEMPT Tue Aug 7 22:51:44 BST 2012 armv6l)

ski522
Posts: 394
Joined: Sun Sep 30, 2012 2:22 pm

Re: NFS mount gives segmentation error

Tue Oct 02, 2012 11:35 pm

Seems like a lot of extra steps in those instructions. All you should need to do is:

Code: Select all

sudo nano /etc/default/nfs-common
add the line "NEED_STATD=yes"
reboot PI or /etc/init.d/nfs-common restart
mount [IP Address]:/[directory] /[local directory]

sadoldgeek
Posts: 2
Joined: Tue Oct 02, 2012 7:37 pm

Re: NFS mount gives segmentation error

Wed Oct 03, 2012 7:26 pm

Hi ski522, thanks for the response. I tried your suggestion. On executing line 3 I get the following output:
[email protected] ~ $ /etc/init.d/nfs-common restart
[ ok ] Stopping NFS common utilities: idmapd statd.
[....] Starting NFS common utilities: statd/etc/init.d/nfs-common: line 134: 1954 Segmentation fault /usr/sbin/rpcinfo -p > /dev/null 2>&1

[warn] Not starting: portmapper is not running ... (warning).

Return to “Raspbian”