mehstg
Posts: 25
Joined: Tue Oct 02, 2012 4:28 pm

Changing Window Manager on Raspbian

Tue Oct 02, 2012 5:28 pm

Hi all

Just a quick question, as I am struggling here and I can't seem to find much info searching through the forums.

I am attempting to swap the default window manager from LXDE (Openbox) to Ratpoison, however I am obviously editing the wrong file, as when I reboot, it still opens LXDE.

I have installed Ratpoison via apt-get, I then run the following:

Code: Select all

update-alternatives --config x-window-manager
I am given three options. Openbox Auto, Openbox Manual and Ratpoison. I select Ratpoison and exit.

Any ideas. I am guessing it is controlled by a different file, however I cannot work it out. Some posts refer to a $HOME/.xinitrc however I co not have this file in my home folder.

Paul

Metatronin
Posts: 55
Joined: Sat Aug 04, 2012 5:19 am

Re: Changing Window Manager on Raspbian

Tue Oct 02, 2012 10:02 pm

No, you most likely changed it to Ratpoison. LXDE is the desktop environment, where as Ratpoison, Openbox, Fluxbox, etc, are the window manager.

mehstg
Posts: 25
Joined: Tue Oct 02, 2012 4:28 pm

Re: Changing Window Manager on Raspbian

Thu Oct 04, 2012 7:10 am

I'm not so sure. That was my initial thought, however I then proceeded to uninstall LXDE. I am now presented with the LightDM login box, it has only one option on it (Openbox).

Is anyone able to point me in the right direction? I am basically looking to strip LXDE from raspbian. I am trying to get it so it boots straight in to Ratpoison. (I'll be using the Pi to run a single app fullscreen)

penoycentral
Posts: 1
Joined: Wed Nov 21, 2012 8:01 am

Re: Changing Window Manager on Raspbian

Wed Nov 21, 2012 8:14 am

Hiya.. i've been using raspbian+ratpoison automatically starting a web browser in a kiosk mode. might not be direct but maybe similar on your needs.

Start user pi at startup

Code: Select all

[email protected]:~$ grep pi /etc/inittab 
1:2345:respawn:/bin/login -f pi tty1 </dev/tty1 >/dev/tty1 2>&1

Code: Select all

[email protected]:~$ cat /home/pi/.bash_profile 
if [ -z "$DISPLAY" ] && [ $(tty) == /dev/tty1 ]; then
    startx
fi

====
Set ratpoison's config file

Code: Select all

[email protected]:~$ cat /home/pi/.xinitrc 
exec ratpoison 

Code: Select all

[email protected]:~$ cat /home/pi/.ratpoisonrc
exec <what-ever-your-program>
this will automatically start ratpoison with exec to a program. hopefully it will give you idea on how to solve your issue ;)

obiwan
Posts: 1
Joined: Sat May 25, 2013 6:52 pm

Re: Changing Window Manager on Raspbian

Sat May 25, 2013 7:09 pm

Raspbian is a Debian Linux version, so as Debian, there is specific command to change settings (update-alternatives), to configure (dpkg-reconfigure) and to manage (apt-get, dpkg).
That's safer than personal scripts which can be erased by default setting at reconfiguration or reinstallation, and which can break Debian configuration.

To change default x-session-manager just use the command :

Code: Select all

$ sudo update-alternatives --config x-session-manager
You will see it was by default set to lxde. The x-session-manager manage the x-window-manager. By default it is lxde session-manager with openbox window-manager (and lxde desktop environment inside openbox... but you can use openbox without desktop environment, which is nice too, and faster with key shortcuts, context menu, and lightness. Take a look at openbox website.)

Above all, there is the display-manager. Raspbian use LightDM display manager (see /etc/X11/default-display-manager), So configuration, like auto-start user, can be found in /etc/lightdm/lightdm.conf.

User avatar
satan
Posts: 1
Joined: Sun Jun 09, 2013 10:15 pm
Contact: Website

Re: Changing Window Manager on Raspbian

Wed Jun 12, 2013 12:47 am

obiwan wrote:Raspbian is a Debian Linux version, so as Debian, there is specific command to change settings (update-alternatives), to configure (dpkg-reconfigure) and to manage (apt-get, dpkg).
That's safer than personal scripts which can be erased by default setting at reconfiguration or reinstallation, and which can break Debian configuration.

To change default x-session-manager just use the command :

Code: Select all

$ sudo update-alternatives --config x-session-manager
You will see it was by default set to lxde. The x-session-manager manage the x-window-manager. By default it is lxde session-manager with openbox window-manager (and lxde desktop environment inside openbox... but you can use openbox without desktop environment, which is nice too, and faster with key shortcuts, context menu, and lightness. Take a look at openbox website.)

Above all, there is the display-manager. Raspbian use LightDM display manager (see /etc/X11/default-display-manager), So configuration, like auto-start user, can be found in /etc/lightdm/lightdm.conf.

Dude you just changed my life. Thank you

mehstg
Posts: 25
Joined: Tue Oct 02, 2012 4:28 pm

Re: Changing Window Manager on Raspbian

Wed Sep 04, 2013 8:12 pm

Sorry for the late reply, thanks for all your help. I found out what was stopping ratpoison from loading. Removing lxsession and adding 'exec ratpoison' to the .xinitrc file allowed ratpoison to start.

Thanks for all your help

Eshaan7
Posts: 1
Joined: Wed May 23, 2018 9:41 am

Re: Changing Window Manager on Raspbian

Wed May 23, 2018 9:46 am

Dude you just changed my life. Thank you

Mine too!

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25466
Joined: Sat Jul 30, 2011 7:41 pm

Re: Changing Window Manager on Raspbian

Wed May 23, 2018 11:22 am

Eshaan7 wrote:
Wed May 23, 2018 9:46 am
Dude you just changed my life. Thank you

Mine too!
Please avoid resurrecting very old threads.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

Return to “Raspbian”