malonecc
Posts: 9
Joined: Sat Sep 29, 2012 8:15 pm

Last update with many "version magic" errors

Sat Sep 29, 2012 8:44 pm

Today I update my Raspbian, and since updating I can see many errors on dmesg:
XXX: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '

Since update, I can't work with 802.1q, if I do "modprobe 8021q" I get :

ERROR: could not insert '8021q': Exec format error

Also, my wireless keyboard don't work anymore.

more info:
$ dmesg|grep "version magic"
[ 5.405723] i2c_bcm2708: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 5.472453] i2c_bcm2708: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 5.511015] spi_bcm2708: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 5.820896] asix: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 5.869017] evdev: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 5.933604] evdev: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 18.245952] llc: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 26.423404] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 26.470091] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 26.953751] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 27.010713] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 27.134302] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 27.787423] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 27.844748] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 27.983440] nfsd: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 29.059253] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 29.284816] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 32.013943] nfsd: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 35.886850] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 36.972305] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 38.143085] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 39.042638] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 39.224505] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 884.530849] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 1554.967309] llc: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 1886.791324] ipv6: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 2560.801486] llc: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 2583.879247] llc: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[ 3723.763336] llc: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
proenotec@siena:~$


¿Any ideas to solve that problem?

plugwash
Forum Moderator
Forum Moderator
Posts: 3697
Joined: Wed Dec 28, 2011 11:45 pm

Re: Last update with many "version magic" errors

Sat Sep 29, 2012 10:21 pm

How exactly did you update?

malonecc
Posts: 9
Joined: Sat Sep 29, 2012 8:15 pm

Re: Last update with many "version magic" errors

Sun Sep 30, 2012 7:25 am

I updated via apt-get update && apt-get upgrade -y

also apt-get dist-upgrade
and via rpi-update with no success.

plugwash
Forum Moderator
Forum Moderator
Posts: 3697
Joined: Wed Dec 28, 2011 11:45 pm

Re: Last update with many "version magic" errors

Sun Sep 30, 2012 12:15 pm

Can you try apt-get install --reinstall raspberrypi-bootloader

malonecc
Posts: 9
Joined: Sat Sep 29, 2012 8:15 pm

Re: Last update with many "version magic" errors

Sun Sep 30, 2012 1:44 pm

Ok, I do it but I get exactly same errors.

plugwash
Forum Moderator
Forum Moderator
Posts: 3697
Joined: Wed Dec 28, 2011 11:45 pm

Re: Last update with many "version magic" errors

Sun Sep 30, 2012 3:50 pm

asb, any thoughts on this? the foundation kernel packaging is your department IIRC.

Mantrid
Posts: 33
Joined: Thu Jun 21, 2012 8:44 am
Location: Middlesbrough/Armagh

Re: Last update with many "version magic" errors

Fri Oct 05, 2012 12:51 pm

Hm I have the same error when I try to use motion with my two (Previously working) webcams, their drivers are coming up with the version magic issue same as above

First time I've seen someone else get it on the forum, was beginning to think i'd used apt-get wrong somehow :/

Return to “Raspberry Pi OS”