CianHa
Posts: 17
Joined: Sun Jul 29, 2012 9:10 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 8:25 pm

Have I killed my Pi?

Turbo enabled, 1GHz overclock. It ran fine for a while, (temps about 65C) until I rebooted, and it failed to restart. I get the Power LED, and OK flashes, but no progress beyond that...

http://twitvid.com/D1Y47

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5285
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 9:04 pm

CianHa wrote:Have I killed my Pi?

Turbo enabled, 1GHz overclock. It ran fine for a while, (temps about 65C) until I rebooted, and it failed to restart. I get the Power LED, and OK flashes, but no progress beyond that...

http://twitvid.com/D1Y47
The Pi is not dead but the sdcard may be corrupted. It should work if you reimage it.

CianHa
Posts: 17
Joined: Sun Jul 29, 2012 9:10 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 9:13 pm

Thanks Dom, after a few calming breaths I counted the 6 flashes, googled it, and discovered the start.elf was corrupted. Panic over!

Synthetic_Darkness
Posts: 30
Joined: Sun Sep 23, 2012 12:22 pm
Location: JHB, South Africa
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 12:36 pm

Update worked fine. Thanks to everyone involved.

Regarding the SD card corruption when selecting an overclocking option. I have narrowed it down to having the Ethernnet cable plugged in. Every time I had the ethernet cable plugged in and changed overclocking setting, using raspi-config, my config.txt file would become corrupt. I confirmed this was the issue by running "sync" and then "dmesg".

Anyone else having this issue, try changing overclock settings without having a network cable plugged in.
http://codefridge.com/ - where cool code comes to chill.

urra901109
Posts: 34
Joined: Sun Sep 23, 2012 4:48 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 12:47 pm

hi guys
just a question.. if i use this method "sudo apt-get update && sudo apt-get install raspberrypi* raspi-config" does it include the "FIQ usb fix"? for now i think i might want to hold to adafruits occidentalis as the new 2012-09-19 image breaks my wifi.(micronext wd152b). but the usb fix is very tempting ~up to 20% performance increase.

DevelopNow
Posts: 6
Joined: Fri Aug 17, 2012 8:07 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 2:40 pm

I have the same problem as "der-don".
When I set clock up to any value with
sudo raspi-config
after reboot min, current and max cpufreq in dmesg is still 700000.
I did all the described installation steps (update from Aug Weezy).
Does anyone has an idear or solution for that behaviour?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5285
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 2:43 pm

DevelopNow wrote:I have the same problem as "der-don".
When I set clock up to any value with
sudo raspi-config
after reboot min, current and max cpufreq in dmesg is still 700000.
I did all the described installation steps (update from Aug Weezy).
Does anyone has an idear or solution for that behaviour?
Can you look at config.txt on a PC? Is arm_freq uncommented (without a preceding #) and set to a value bigger than 700?
Does it work if you edit it on PC and then boot Pi?

User avatar
Ed Raket
Posts: 164
Joined: Mon Apr 30, 2012 4:28 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 2:54 pm

DevelopNow wrote:I have the same problem as "der-don".
When I set clock up to any value with
sudo raspi-config
after reboot min, current and max cpufreq in dmesg is still 700000.
I did all the described installation steps (update from Aug Weezy).
Does anyone has an idear or solution for that behaviour?
Maybe your config.txt got scrambled. can you type:

Code: Select all

sudo nano /boot/config.txt
and check the last line for: @^@^@^@^@^@^@^ caracters, and the presence of the "arm_freq=" setting please?

kavi96
Posts: 13
Joined: Tue Aug 28, 2012 10:28 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 3:08 pm

I can't work out how to set a static ip address for wlan0 after using the gui wifi setup. My /etc/network/interfaces looks like this:

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
I tried changing it to

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet static
address 192.168.0.200
netmask 255.255.255.0
gateway 192.168.0.1
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
But when I did that it wouldn't connect. What should I change to get a static ip?

DevelopNow
Posts: 6
Joined: Fri Aug 17, 2012 8:07 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 4:20 pm

Thanks a lot for your fast feedback dom and Ed Raket.

Yes there were some strange characters/symbols in the file config.txt in the comment line above the line with the arm_freq=...
First I tried to remove the strange characters with nano. But after reboot there were even more strange characters. So I deleted the hole file

Code: Select all

rm /boot/config.txt
After that I started the config tool again

Code: Select all

sudo raspi-config
And activated the overclock.
Going out of the raspi-config tool, I said No to the reboot question, checked again the config.txt file.

Code: Select all

cat /boot/config.txt
After my first try, the entrance arm_freq was missing, so I set again a differen overclock mode in the raspi-config tool. After that, all 4 entrance

Code: Select all

arm_freq
core_freq
sdram_freq
overclock_voltage 
were there. Now I rebooted manualy

Code: Select all

sudo reboot
And finaly after reboot, I see in dmesg cpufreq max=950000 so overcklock should be active now!

ovacikar
Posts: 1
Joined: Tue Aug 07, 2012 5:43 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 4:23 pm

Hello,

I have the custom installer version of raspbian, to boot from sdcard and online install on a usb key.

But I am having trouble getting the upgrades and new packages, what am i doing wrong (PS: my apt.sources is the one from RaspbianFAQ) ?


uname -a
Linux rpi 3.2.27+ #165 PREEMPT Thu Sep 20 22:28:17 BST 2012 armv6l GNU/Linux

cat /etc/apt/sources.list
deb http://archive.raspbian.org/raspbian wheezy main contrib non-free rpi
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free rpi


sudo apt-get update && sudo apt-get install raspberrypi* raspi-config
Hit http://archive.raspbian.org wheezy InRelease
Hit http://archive.raspbian.org wheezy/main Sources
Hit http://archive.raspbian.org wheezy/contrib Sources
Hit http://archive.raspbian.org wheezy/non-free Sources
Hit http://archive.raspbian.org wheezy/rpi Sources
Hit http://archive.raspbian.org wheezy/main armhf Packages
Hit http://archive.raspbian.org wheezy/contrib armhf Packages
Hit http://archive.raspbian.org wheezy/non-free armhf Packages
Hit http://archive.raspbian.org wheezy/rpi armhf Packages
Ign http://archive.raspbian.org wheezy/contrib Translation-en_US
Ign http://archive.raspbian.org wheezy/contrib Translation-en
Ign http://archive.raspbian.org wheezy/main Translation-en_US
Ign http://archive.raspbian.org wheezy/main Translation-en
Ign http://archive.raspbian.org wheezy/non-free Translation-en_US
Ign http://archive.raspbian.org wheezy/non-free Translation-en
Ign http://archive.raspbian.org wheezy/rpi Translation-en_US
Ign http://archive.raspbian.org wheezy/rpi Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package raspberrypi*
E: Couldn't find any package by regex 'raspberrypi*'
E: Unable to locate package raspi-config

User avatar
Ed Raket
Posts: 164
Joined: Mon Apr 30, 2012 4:28 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 4:24 pm

@ DevelopNow; Good to hear you got it going! may i ask what kind of SD card you use?

User avatar
rleyden
Posts: 70
Joined: Thu Jun 14, 2012 2:17 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 6:48 pm

After upgrading, two separate python gpio programs stopped working.
I have a 1-wire temperature probe and I was using the ablib.py provided by Acme systems. Apparently, the os.path call didn't return correctly and I got "1-wire bus not found". I could manually find the path to the sensor so I just patched the correct path into ablib.py. That worked but certainly isn't elegant.

Secondly, I added a MCP3008 ADC chip following Adafruit's tutorial. This no longer works either. The line "import RPi.GPIO as GPIO" gives an error "No module named RPi.GPIO". I tried re-installing ( "pip install rpi.gpio" , successful) but python still can't find the module.

If this is due to the upgrade someone else must has experienced this, however I couldn't find mention of it elsewhere in the forums. Please point me in the right direction.

User avatar
mister_wavey
Posts: 98
Joined: Sun Sep 02, 2012 8:23 am
Location: Abergavenny, Wales, UK
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 6:55 pm

I had this too with python2. I downloaded and installed the RPi.GPIO package manually to fix it. http://pypi.python.org/pypi/RPi.GPIO/#downloads if you want to do the same.

simplesi
Posts: 2327
Joined: Fri Feb 24, 2012 6:19 pm
Location: Euxton, Lancashire, UK
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 7:10 pm

I upgraded one system and have installed the latest on another card and both carried on working fine with the Rpi.GPIO library in Python 2.

However, I get the no module named Rpi.GPIO if I upgrade to using 0.4.0.a_1 - but it works fine again on downgrading back to the previous 0.3 version

regards

Simon
Seeking help with Scratch and I/O stuff for Primary age children
http://cymplecy.wordpress.com/ @cymplecy on twitter

User avatar
rleyden
Posts: 70
Joined: Thu Jun 14, 2012 2:17 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 7:46 pm

mister_wavey wrote:I had this too with python2. I downloaded and installed the RPi.GPIO package manually to fix it. http://pypi.python.org/pypi/RPi.GPIO/#downloads if you want to do the same.
This was very helpful. I'm still confused about whether I'm using python2 or python3 (mentioned in the included install.txt). I tried both. After doing the python3 install, I have progress. I no longer get the "RPi.GPIO not found" error. However, I get a new error "RuntimeWarning: This channel is already in use.". This occurs in my code where the pins are assigned.

Code: Select all

# SPI port on the ADC to the Cobbler
SPICLK = 18
SPIMISO = 23
SPIMOSI = 24
SPICS = 25
# set up the SPI interface pins
GPIO.setup(SPIMOSI, GPIO.OUT)
GPIO.setup(SPIMISO, GPIO.IN)
GPIO.setup(SPICLK, GPIO.OUT)
GPIO.setup(SPICS, GPIO.OUT)
The program ignores the "in use warning" but doesn't see any output.
Do I have to re-assign the pins?

DevelopNow
Posts: 6
Joined: Fri Aug 17, 2012 8:07 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 8:17 pm

@Ed Roket: I'm using a 4 GB "MAX 133x" SD Card. It's an 'old' card that I used before in my camera. It is for sure 2 to 3 years old.
Is there an SD Card recomendation list?

simplesi
Posts: 2327
Joined: Fri Feb 24, 2012 6:19 pm
Location: Euxton, Lancashire, UK
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 8:25 pm

@croston has posted a short term fix if your using 0.4.0.a_1

Code: Select all

sudo touch /usr/lib/python2.7/dist-packages/RPi/__init__.py
Just tried it on mine and I'm back working again :)

regards

Simon
Seeking help with Scratch and I/O stuff for Primary age children
http://cymplecy.wordpress.com/ @cymplecy on twitter

User avatar
Ed Raket
Posts: 164
Joined: Mon Apr 30, 2012 4:28 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sun Sep 23, 2012 9:38 pm

DevelopNow wrote:@Ed Roket: I'm using a 4 GB "MAX 133x" SD Card. It's an 'old' card that I used before in my camera. It is for sure 2 to 3 years old.
Is there an SD Card recomendation list?
Yes... and no, there is this list of compatible SD cards: http://elinux.org/RPi_VerifiedPeriphera ... g_SD_Cards but... the specific problem popped up with the latest version of Raspbian, so this list is not relevent anymore. So, i suppose we make a new list for (out of the box) compatible hardware (anyway SD cards) for the latest version of raspbian ;)

chillywillycd
Posts: 20
Joined: Fri Feb 24, 2012 8:34 pm
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 3:14 am

I have assumed that if I'm running as a user other than 'pi' that i'd want to execute

Code: Select all

 adduser <myuser> netdev
is that correct?

Thanks!
--chillywilly

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 4:52 am

rpi-update is not in the new image?
Used to be located in /usr/bin/rpi-update

Is this a change?
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

Synthetic_Darkness
Posts: 30
Joined: Sun Sep 23, 2012 12:22 pm
Location: JHB, South Africa
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 5:52 am

Dweeber wrote:rpi-update is not in the new image?
Used to be located in /usr/bin/rpi-update

Is this a change?
I dont think that rpi-update was ever included in the image. I could be wrong though.
http://codefridge.com/ - where cool code comes to chill.

der-don
Posts: 10
Joined: Fri Sep 21, 2012 8:58 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 6:08 am

DevelopNow wrote:Thanks a lot for your fast feedback dom and Ed Raket.

Yes there were some strange characters/symbols in the file config.txt in the comment line above the line with the arm_freq=...
First I tried to remove the strange characters with nano. But after reboot there were even more strange characters. So I deleted the hole file

Code: Select all

rm /boot/config.txt
After that I started the config tool again

Code: Select all

sudo raspi-config
And activated the overclock.
Going out of the raspi-config tool, I said No to the reboot question, checked again the config.txt file.

Code: Select all

cat /boot/config.txt
After my first try, the entrance arm_freq was missing, so I set again a differen overclock mode in the raspi-config tool. After that, all 4 entrance

Code: Select all

arm_freq
core_freq
sdram_freq
overclock_voltage 
were there. Now I rebooted manualy

Code: Select all

sudo reboot
And finaly after reboot, I see in dmesg cpufreq max=950000 so overcklock should be active now!
Did the same thing now. I deleted the config.txt and ran the raspi-config again. First I tried to set the speed to 900 MHz. A new config.txt was written, with this content:
core_freq=500
sdram_freq=500
over_voltage=6
Then, without booting, I ran the raspi-config again and set the speed to 1000 MHz. After that, the config.txt looked like this:
core_freq=500
sdram_freq=500
over_voltage=6
arm_freq=1000
After a reboot, the PI is running at up to 1000 MHz. :)

User avatar
Ed Raket
Posts: 164
Joined: Mon Apr 30, 2012 4:28 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 6:25 am

@DevelopNow
@der-don

Great that you guys got things working by re-writing the "config.txt"! Could you check in a day or two if those settings/that file remains intact? (unscrambled)

kavi96
Posts: 13
Joined: Tue Aug 28, 2012 10:28 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 6:34 am

kavi96 wrote:I can't work out how to set a static ip address for wlan0 after using the gui wifi setup. My /etc/network/interfaces looks like this:

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
I tried changing it to

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet static
address 192.168.0.200
netmask 255.255.255.0
gateway 192.168.0.1
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
But when I did that it wouldn't connect. What should I change to get a static ip?
Any ideas on how to get this working?

Return to “Raspbian”