dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5282
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Fri Sep 21, 2012 9:48 pm

der-don wrote:I measure it using cpufreq-info (you have to install cpufrequtils to use that). It shows the minimum frequency, the maximum frequency and the current frequency and they're all set to 700 MHz. And I measured speed with this command: time echo "scale=2000; a(1)*4" | bc -l It took about 29 seconds on the default RasPi and about 20 with 900 MHz. Now it's taking ~28 sec. again :(
What does this report:

Code: Select all

dmesg |grep cpufreq

Hikerd
Posts: 1
Joined: Mon Sep 17, 2012 4:53 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 4:38 am

Could someone help me out with using Python? Just need a simple import of the CPU temp/Freq into a print command. I've got the concept but my syntax is incorrect and I can't find it using google/wiki... for the moment.

Thanks,
H

cloud_strife84
Posts: 31
Joined: Wed Jun 13, 2012 1:38 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 8:42 am

How can I set manual ip address in this new distro?

User avatar
slabua
Posts: 95
Joined: Tue Sep 11, 2012 7:00 pm
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 9:09 am

How about CEC support, upgrading from a July Raspbian image?
I read that CEC is supported since the August Raspbian image, do I need to install any further package?
Salvatore La Bua - www.slblabs.com
DICGIM - University of Palermo, Italy

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 10:07 am

Hikerd wrote:Could someone help me out with using Python? Just need a simple import of the CPU temp/Freq into a print command. I've got the concept but my syntax is incorrect and I can't find it using google/wiki... for the moment.

Thanks,
H
Try over in the [url=ttp://www.raspberrypi.org/phpBB3/viewforum.php?f=32]Python Thread[/url]

Also helps to see what you tried.
Last edited by Dweeber on Sat Sep 22, 2012 10:18 am, edited 1 time in total.
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

User avatar
wallarug
Posts: 460
Joined: Mon May 14, 2012 8:21 am
Location: Sydney, Australia

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 10:16 am

cloud_strife84 wrote:How can I set manual ip address in this new distro?
Same as in the old Raspbian distro.
Type:

Code: Select all

sudo nano /etc/network/interfaces
into a terminal or command line. Then in that file change:

Code: Select all

auto eth0
iface eth0 inet dhcp
to:

Code: Select all

auto eth0
iface eth0 inet static
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.254
If this doesn't work try with indenting:

Code: Select all

auto eth0
iface eth0 inet static
     address 192.168.1.5
     netmask 255.255.255.0
     gateway 192.168.1.254
Hope this helps.

Good Luck.
Last edited by wallarug on Sat Sep 22, 2012 10:27 am, edited 1 time in total.

cloud_strife84
Posts: 31
Joined: Wed Jun 13, 2012 1:38 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 10:21 am

Thanks for the reply! But i need to set up wifi and not ethernet

User avatar
wallarug
Posts: 460
Joined: Mon May 14, 2012 8:21 am
Location: Sydney, Australia

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 10:29 am

cloud_strife84 wrote:Thanks for the reply! But i need to set up wifi and not ethernet
Replace eth0 with wlan0 (or the number of the device that you are using.)

bloodline
Posts: 76
Joined: Sun Jun 10, 2012 8:44 pm
Location: London - England

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 10:42 am

If I select Turbo mode in the raspi-config, even though it overvolts the core... I won't invalidate my warranty? Is this correct?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5282
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 10:48 am

bloodline wrote:If I select Turbo mode in the raspi-config, even though it overvolts the core... I won't invalidate my warranty? Is this correct?
Yes.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5282
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 10:51 am

Ed Raket wrote:I tried a new install on an other SD card i found, it is an older Sandisk "extreme III" 2gb... And the "scrambling" problem is gone! Turbo mode works fine, no corruption of the filesystem anymore :D

Maybe we should open a wiki section for "turbo mode compatible" SD card's?
There's more discussion on sdcard corruption here:
http://www.raspberrypi.org/phpBB3/viewt ... 27#p179227
Try leaving the overclock in place, but editing core_freq back to 250. Report any results on the linked thread.

bloodline
Posts: 76
Joined: Sun Jun 10, 2012 8:44 pm
Location: London - England

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 11:52 am

dom wrote:
bloodline wrote:If I select Turbo mode in the raspi-config, even though it overvolts the core... I won't invalidate my warranty? Is this correct?
Yes.
Excellent!

Seems my board won't cope with Turbo mode, it crashes after a few seconds of heavy CPU load... High (950Mhz) seems to be working so far... my Board is quite an early one (I got it on June the 1st) so it might not have the headroom of newer ones.

bloodline
Posts: 76
Joined: Sun Jun 10, 2012 8:44 pm
Location: London - England

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 12:02 pm

The apt-get update and upgrade doesn't seem to give me the CPU temp and freq monitors on my desktop... where can I get them from?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5282
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 1:38 pm

bloodline wrote:The apt-get update and upgrade doesn't seem to give me the CPU temp and freq monitors on my desktop... where can I get them from?
Did you run:

Code: Select all

sudo apt-get update && sudo apt-get install raspberrypi* raspi-config
suggested in the first post? Did you then run rasp-config, enable overclock and reboot?

marosg
Posts: 25
Joined: Sat Jul 07, 2012 2:41 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 2:02 pm

Hm, is that just me ? After apt-get upgrade I see the same problem which was here couple of months ago - after some time, deluged fails. I don't remember what was the solution last time. I was running deluged without a problem since start of August.

bloodline
Posts: 76
Joined: Sun Jun 10, 2012 8:44 pm
Location: London - England

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 2:12 pm

dom wrote:
bloodline wrote:The apt-get update and upgrade doesn't seem to give me the CPU temp and freq monitors on my desktop... where can I get them from?
Did you run:

Code: Select all

sudo apt-get update && sudo apt-get install raspberrypi* raspi-config
suggested in the first post? Did you then run rasp-config, enable overclock and reboot?
Yes, I have realised I just needed to add them to my dock pannel... :)

Right... now I think I might be getting SD-Card write corruption... time to do some more testing... :)

der-don
Posts: 10
Joined: Fri Sep 21, 2012 8:58 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 2:22 pm

dom wrote:
der-don wrote:I measure it using cpufreq-info (you have to install cpufrequtils to use that). It shows the minimum frequency, the maximum frequency and the current frequency and they're all set to 700 MHz. And I measured speed with this command: time echo "scale=2000; a(1)*4" | bc -l It took about 29 seconds on the default RasPi and about 20 with 900 MHz. Now it's taking ~28 sec. again :(
What does this report:

Code: Select all

dmesg |grep cpufreq
[email protected] ~ $ dmesg |grep cpufreq
[ 1.958928] bcm2835-cpufreq: min=700000 max=700000 cur=700000
[ 1.964768] bcm2835-cpufreq: switching to governor powersave
[ 1.977757] bcm2835-cpufreq: switching to governor powersave
[ 21.208659] bcm2835-cpufreq: switching to governor ondemand
[ 21.208687] bcm2835-cpufreq: switching to governor ondemand
[ 25.219175] bcm2835-cpufreq: switching to governor ondemand
[ 25.219212] bcm2835-cpufreq: switching to governor ondemand
[ 28.647181] bcm2835-cpufreq: switching to governor ondemand
[ 28.647217] bcm2835-cpufreq: switching to governor ondemand

As I mentioned, it should use the 1 GHz Turbo mode.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5282
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 2:46 pm

der-don wrote:[ 1.958928] bcm2835-cpufreq: min=700000 max=700000 cur=700000
max should be more than 700000 for overclocking. Have you selected an overclock option from raspi-config?
You could just edit /boot/config.txt and ensure arm_freq=900 (or similar).

User avatar
dliloch
Posts: 168
Joined: Wed Jun 27, 2012 6:28 pm
Location: cleveland, ohio usa

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 3:10 pm

It's "working" as you will see from my measurements .. but real world stuff like midori I get
zero performance improvement... is the latency too large? something is preventing the governor from
recognizing that it should switch up..

Code: Select all

[email protected] ~ $ stress -c 1 & sleep 3; echo "CPU freq: "; cat /sysdevices/system/cpu/cpu0/cpufreq/scaling_cur_freq ; cpufreq-info; killall stress
[1] 2561
stress: info: [2561] dispatching hogs: 1 cpu, 0 io, 0 vm, 0 hdd
CPU freq: 
950000
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to [email protected], please.
analyzing CPU 0:
  driver: BCM2835 CPUFreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 355 us.
  hardware limits: 700 MHz - 950 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 700 MHz and 950 MHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 950 MHz.
[1]+  Terminated              stress -c 1
[email protected] ~ $ uname -a
Linux raspberrypi 3.2.27+ #160 PREEMPT Mon Sep 17 23:18:42 BST 2012 armv6l GNU/Linux

mikerr
Posts: 2770
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 4:20 pm

While playing, open another SSH terminal (or console window)
and run this in it:

Code: Select all

watch  "/opt/vc/bin/vcgencmd measure_temp && cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq"
Nice to watch the guv'nor at work:

Every 2.0s: /opt/vc/bin/vcgencmd measure_temp && ca... Sat Sep 22 17:19:50 2012

temp=46.0'C
1000000
Android app - Raspi Card Imager - download and image SD cards - No PC required !

milhouse
Posts: 631
Joined: Mon Jan 16, 2012 12:59 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 4:27 pm

I created a simple script to monitor the overclock settings, you can download it with:

Code: Select all

wget http://www.nmacleod.com/public/bcmstat.sh
chmod +x bcmstat.sh
It takes an optional delay parameter (seconds), eg.

Code: Select all

./bcmstat.sh 5
to display details every 5 seconds (default is 2).

In Raspbian it requires you to install gawk (apt-get install gawk) as the default awk is from the dinosaur era. Works fine as-is in OpenELEC.

User avatar
dliloch
Posts: 168
Joined: Wed Jun 27, 2012 6:28 pm
Location: cleveland, ohio usa

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 4:52 pm

solved... downloaded the new 9/18/2012 image of raspbian and before I "modified" anything
I set the clock to HI 950mhz.. works perfect... so I don't know what I did to mess it up but
I will start putting in my apps now one by one and test after each one .. midori works great and
the applet does indeed show it @950mhz while coming up. Midori is now usable .. great job!!!

I am also copying a huge file from my old SD to the new sd.. I hover over the freq applet which does change on hover .. and it will not go beyond 700mhz .. now the cpu is pegged here according to the usage indicator .. so I am wondering if IO bound workloads are excluded somehow.. due to the large amount of relative wait time ??
went over to midori to see if I clicked it would it increase the speed .. system crashed ..
more than crashed .. SD image corrupted.. so refreshed image .. I really think there is an
issue with I/O and the overclocking ... I will try a slower speed next ...
Last edited by dliloch on Sat Sep 22, 2012 5:20 pm, edited 1 time in total.

der-don
Posts: 10
Joined: Fri Sep 21, 2012 8:58 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 5:08 pm

dom wrote:
der-don wrote:[ 1.958928] bcm2835-cpufreq: min=700000 max=700000 cur=700000
max should be more than 700000 for overclocking. Have you selected an overclock option from raspi-config?
You could just edit /boot/config.txt and ensure arm_freq=900 (or similar).
Yes, I did that. It worked for the first time when I increased frequency to 900 MHz. Now, not even that increase works. Now I edited the /boot/config.txt using "sudo nano /boot/config.txt" and changed the value to 900. But after a reboot, the change is gone and there's a # at the beginning of the line again. What else do I have to do to edit the file?

I already checked if my SD-Card has it's write protection set to locked, but it's not locked.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5282
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 5:16 pm

der-don wrote:Yes, I did that. It worked for the first time when I increased frequency to 900 MHz. Now, not even that increase works. Now I edited the /boot/config.txt using "sudo nano /boot/config.txt" and changed the value to 900. But after a reboot, the change is gone and there's a # at the beginning of the line again. What else do I have to do to edit the file?

I already checked if my SD-Card has it's write protection set to locked, but it's not locked.
Can you try editing the file on a windows or linux machine and see if that works.

mikerr
Posts: 2770
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Sat Sep 22, 2012 6:38 pm

der-don wrote: And I measured speed with this command:

Code: Select all

time echo "scale=2000; a(1)*4" | bc -l 
It took about 29 seconds on the default RasPi and about 20 with 900 MHz.
17 seconds with Turbo.
Android app - Raspi Card Imager - download and image SD cards - No PC required !

Return to “Raspbian”