moelski
Posts: 63
Joined: Wed Jan 09, 2013 8:16 am

Chromium no longer startable over X11 Server

Fri Mar 03, 2017 7:33 am

Hi !

I recenty updated my Raspian and get the latest release of chromium which is 56.
Normally I use my pi in headless mode and connect via SSH and use a X11 server if I need an graphical application. (I use MobaXTerm btw ...)
In the past that worked like a charm with Chromium. But with the latest update I got this:

Code: Select all

[email protected]:~ $ chromium-browser
bootstrap_helper: /usr/lib/chromium-browser/nacl_helper: Cannot open ELF file!  errno=2
[1:1:0303/072924.874290:ERROR:nacl_fork_delegate_linux.cc(315)] Bad NaCl helper startup ack (0 bytes)
[5870:5870:0303/072924.943894:ERROR:browser_main_loop.cc(495)] Failed to put Xlib into threaded mode.
[5870:5870:0303/072924.957006:ERROR:browser_main_loop.cc(272)] Gtk: cannot open display:
It worked well with the previous versions of chromium.
Any idea what´s wrong here ?

regards Dominik

moelski
Posts: 63
Joined: Wed Jan 09, 2013 8:16 am

Re: Chromium no longer startable over X11 Server

Fri Mar 03, 2017 8:49 am

Hi !

Just saw that my X Server was not working. But anyway after fixing that the problem still exists:

Code: Select all

[email protected]:~ $ chromium-browser
bootstrap_helper: /usr/lib/chromium-browser/nacl_helper: Cannot open ELF file!  errno=2
[1:1:0303/083458.248927:ERROR:nacl_fork_delegate_linux.cc(315)] Bad NaCl helper startup ack (0 bytes)
Received signal 11 SEGV_MAPERR 000000000094
#0 0x00005664f450 <unknown>
#1 0x00005664f3c8 <unknown>
#2 0x0000758ab1a0 <unknown>
[end of stack trace]

(chromium-browser:1027): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Failed to connect to socket /tmp/dbus-AHc6HRPBep: Verbindungsaufbau abgelehnt
[8:8:0100/000000.713469:ERROR:broker_posix.cc(41)] Invalid node channel message
[7:7:0100/000000.712941:ERROR:broker_posix.cc(41)] Invalid node channel message
Speicherzugriffsfehler

moelski
Posts: 63
Joined: Wed Jan 09, 2013 8:16 am

Re: Chromium no longer startable over X11 Server

Tue Mar 07, 2017 5:37 am

Hi !

Has nobody an idea about this topic?
I can reproduce this on several raspberries ... :cry:

btw: Other applications like geany or monodevelop work like a chram. So it´s not the x11 forwarding which causes the problems.

Update:
Just installed a frisch Raspbian Image to a new SD card ... Same behaviour. :cry:

mob-i-l
Posts: 276
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Google+ Twitter YouTube

Re: Chromium no longer startable over X11 Server

Fri Mar 10, 2017 3:53 pm

I couldn't start Chromium, but then i did dist-upgrade and now I can start, but I get errors:

Code: Select all

$ chromium-browser
bootstrap_helper: /usr/lib/chromium-browser/nacl_helper: Cannot open ELF file!  errno=2
[1:1:0310/164529.455362:ERROR:nacl_fork_delegate_linux.cc(315)] Bad NaCl helper startup ack (0 bytes)
[2701:2701:0310/164541.538171:ERROR:sandbox_linux.cc(343)] InitializeSandbox() called with multiple threads in process gpu-process. 
[2592:2633:0310/164611.771146:ERROR:upload_data_presenter.cc(77)] Not implemented reached in virtual void extensions::RawDataPresenter::FeedNext(const net::UploadElementReader &)
[2592:2633:0310/164614.152129:ERROR:upload_data_presenter.cc(77)] Not implemented reached in virtual void extensions::RawDataPresenter::FeedNext(const net::UploadElementReader &)
[2592:2764:0310/164626.997611:ERROR:object_proxy.cc(583)] Failed to call method: org.freedesktop.NetworkManager.GetDevices: object_path= /org/freedesktop/NetworkManager: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
Chromium: Version 56.0.2924.84 Built on Ubuntu 14.04, running on Raspbian 8.0
Have Pi0&1A&1B&1B+&2B&3B&4B w/ Raspbian. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

plagasul
Posts: 8
Joined: Mon Dec 12, 2016 12:20 am

Re: Chromium no longer startable over X11 Server

Sat Mar 11, 2017 12:24 am

I am having exactly the same problem.

I need to start chromium headless on boot. But I cannot even start it through CLI, the error is the same:

Code: Select all

bootstrap_helper: /usr/lib/chromium-browser/nacl_helper: Cannot open ELF file!  errno=2
[1:1:0311/011456.810221:ERROR:nacl_fork_delegate_linux.cc(315)] Bad NaCl helper startup ack (0 bytes)
[11710:11710:0311/011457.178206:ERROR:browser_main_loop.cc(495)] Failed to put Xlib into threaded mode.
[11710:11710:0311/011457.190579:ERROR:browser_main_loop.cc(272)] Gtk: cannot open display: 
If I run a vncserver, and log into it with another computer remotely, I see the GUI, I can open a terminal and start chromium. Then it does start.

To be able to do this is crucial for what I am doing at the moment.

Any help would be greatly appreciated.

plagasul
Posts: 8
Joined: Mon Dec 12, 2016 12:20 am

Re: Chromium no longer startable over X11 Server

Sat Mar 11, 2017 10:49 am

running DISPLAY=:0 before chromium, seems to work for me

someone should point us to some good useful X info

thx

moelski
Posts: 63
Joined: Wed Jan 09, 2013 8:16 am

Re: Chromium no longer startable over X11 Server

Wed Mar 15, 2017 6:24 am

Hi !
running DISPLAY=:0 before chromium, seems to work for me
Don´t understand the sense of this ...

Display 0 is usually the attached display and not the display for the x11 forwarding.
So this won´t help at all ...

Dominik

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6084
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Chromium no longer startable over X11 Server

Wed Mar 15, 2017 1:44 pm


moelski
Posts: 63
Joined: Wed Jan 09, 2013 8:16 am

Re: Chromium no longer startable over X11 Server

Fri Mar 17, 2017 8:31 am

@ShiftPlusOne:
I opened that issue on github ;)

But there is also no solution available ... :cry:

At the moment it seems that this problem only occurs on Windows Systems.
But that´s all I can tell right now ...

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6084
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Chromium no longer startable over X11 Server

Fri Mar 17, 2017 5:25 pm

The John (the dev) has reproduced the issue and has a fix in mind. I think it might be fixed with the next image, or shortly after.

Return to “Raspbian”