User avatar
knuxyl
Posts: 33
Joined: Sun Feb 26, 2017 1:42 am

Help installing "xserver-xorg-input-xwiimote"

Tue Feb 28, 2017 12:06 pm

I have been messing with this for hours and I cannot seem to get this to install.
These have already been done
sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y dist-upgrade && sudo rpi-update && sudo reboot

And now I'm trying to install an input driver for the Wiimote and I've already installed the libxwiimote2 package.

I'm getting this error
xserver-xorg-input-xwiimote : Depends: xorg-input-abi-21

xorg-input-abi-21 is a virtual package provided by xserver-xorg-core. It cannot be installed and my entire system is up to date as of now.

I've tried building this thing from source and I just get the same error in ./configure

Does anybody know what this means and what I can do to fix this? Thanks

User avatar
knuxyl
Posts: 33
Joined: Sun Feb 26, 2017 1:42 am

Re: Help installing "xserver-xorg-input-xwiimote"

Tue Feb 28, 2017 12:10 pm

This could probably be fixed if I just install the xserver-xorg-core from Debian Jessie repositories, but I have no idea if that will work. Anybody know?

ktb
Posts: 1447
Joined: Fri Dec 26, 2014 7:53 pm

Re: Help installing "xserver-xorg-input-xwiimote"

Tue Feb 28, 2017 12:32 pm

I dunno. If you check the original repo, the project hasn't been active since 2014.

Check the fork activity: https://github.com/dvdhrm/xf86-input-xwiimote/network

Return to “Raspberry Pi OS”