Page 1 of 1

Disable IPv6

Posted: Thu Nov 10, 2016 5:00 pm
by PieterG
My rPI3 is behind my own router in an IPv4 network only.
Raspbian (Debian Linux 8.0) is installed and as well as Webmin 1.820 and Virtualmin 5.04
That works all fine.
I have a monitor tool that probes external sites for their availability and up time. Again, so far so good.

Though in my syslog I see errors like

Code: Select all

error (address not available) resolving 'domain.com/DS/IN': 2001:7c8:605::85#53
To me that seems it is trying to resolve a domain to an IPv6 address.
As my local network is IPv4 only this is not gonna work.
IPv6 in Debian (and other distros) is preferred by default. So I tried changing the priority
Tried disabling in several ways. From disabling in Bind9 to disabling it completely on boot.

See the info I used thusfar.

http://askubuntu.com/questions/32298/pr ... v6-lookups

viewtopic.php?f=36&t=138899

https://wiki.debian.org/DebianIPv6#How_to_turn_off_IPv6

http://askubuntu.com/questions/309461/h ... ermanently

(Ubuntu being comparable to Debian)

Anyone that can shine a light on what I missed out on or did wrong? Or just don't understand, me being the noob... ;)

Tx,

Re: Disable IPv6

Posted: Fri Nov 11, 2016 9:52 am
by Gerd
viewtopic.php?f=36&t=138899 should shed some light on this

Re: Disable IPv6

Posted: Fri Nov 11, 2016 8:06 pm
by PieterG
None of the proposed solutions in that link worked.

Re: Disable IPv6

Posted: Sat Nov 12, 2016 2:00 am
by malicious
Configuring IPv6 support in the kernel and user space applications are separate. Settings such as

net.ipv6.conf.all.disable_ipv6
net.ipv6.conf.default.disable_ipv6
etc.

set IPv6 kernel support but applications will try to use IPv6 regardless if configured to do so. Whatever program is generating those syslog error entries will need to have its own settings adjusted.

Re: Disable IPv6

Posted: Sat Nov 12, 2016 10:05 am
by DougieLawson
Personally, I'd leave it alone as it fails quietly. Some time in the next twenty years we may all switch to the twenty year old "new" IPv6 protocol (which is already running on my network with a Hurricane Electric tunnel on my RPi B+).

It may be better to build your own HE tunnel rather than disabling IPv6.
https://tunnelbroker.net/

Other brokers are available
https://en.wikipedia.org/wiki/List_of_I ... el_brokers

Some ISPs have begun the switch to IPv6 and it will "just work" without any changes.

Re: Disable IPv6

Posted: Sat Nov 12, 2016 10:11 am
by PieterG
It is "named" (bind9) that fails "quietly".

So because the target domains do not have an IPv6 address (yet) it fails? Is that correct?
It now says "error" it should be "info" then right?

Anyone knows a way to disable this message in the log file (or at least change it to "INFO")?

Re: Disable IPv6

Posted: Sat Nov 12, 2016 10:37 am
by DougieLawson
Have you got the forwarders and/or root servers defined in your /etc/bind/named.config.options?

Code: Select all

options {
        forwarders{
        // GoogleDNS
                  8.8.8.8;
                  8.8.4.4;
                };
 // ... other stuff goes here ...
};

Code: Select all

// prime the server with knowledge of the root servers
zone "." {
        type hint;
        file "/etc/bind/db.root";
};

Re: Disable IPv6

Posted: Sat Nov 12, 2016 12:56 pm
by PieterG
That's IT! setting forwarders.
I actually thought it would pick up the DNS from the network settings (as there is DNS set there)
Apparantly not.

Thanks!