Malman35
Posts: 425
Joined: Sun Nov 30, 2014 4:51 am

Is there a material design theme/icons for raspbian jessie

Sun Aug 14, 2016 8:03 am

Hi all,
Recently I've been looking to see if there is a theme and icons that are similar to material design (I'm absolutely crazy about material design :D ). I am running Raspbian Jessie on a RPi 2. I came across this.
https://github.com/nana-4/Flat-Plat
But I am not so sure if it would work due to the requirements.
Does anybody know if this would work? If not is there another material design theme out there that would work on in Raspbian Jessie. Tanks for your time.

User avatar
r3d4
Posts: 984
Joined: Sat Jul 30, 2011 8:21 am
Location: ./

Re: Is there a material design theme/icons for raspbian jess

Sun Aug 14, 2016 11:25 am

Malman35 wrote: But I am not so sure if it would work due to the requirements.
if you can install GTK3, GTK2 it will work !
Malman35 wrote: Does anybody know if this would work? If not is there another material design theme out there that would work on in Raspbian Jessie. Tanks for your time.
Afaik Raspbian Jessie uses lxde

Malman35
Posts: 425
Joined: Sun Nov 30, 2014 4:51 am

Re: Is there a material design theme/icons for raspbian jess

Sun Aug 14, 2016 1:07 pm

r3d4 wrote:
Malman35 wrote: But I am not so sure if it would work due to the requirements.
if you can install GTK3, GTK2 it will work !
Malman35 wrote: Does anybody know if this would work? If not is there another material design theme out there that would work on in Raspbian Jessie. Tanks for your time.
Afaik Raspbian Jessie uses lxde
That is great to hear that it will work but when I tried to install gtk3 I got this

Code: Select all

pi@malman ~ $ sudo apt-get install libgtk-3-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.27.1) but it is not installable
                Depends: libpango1.0-dev (>= 1.36.7) but it is not going to be installed
                Depends: libatk1.0-dev (>= 2.7.5) but it is not installable
                Depends: libatk-bridge2.0-dev but it is not installable
                Depends: libcairo2-dev (>= 1.10.0) but it is not going to be installed
                Depends: libxinerama-dev but it is not installable
                Depends: libxi-dev but it is not installable
                Depends: libxrandr-dev but it is not installable
                Depends: libxcursor-dev but it is not installable
                Depends: libxcomposite-dev but it is not installable
                Depends: libwayland-dev (>= 1.4.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
I read that using aptitude fixes it for you but this is what I got when I ran that

Code: Select all

pi@malman ~ $ sudo aptitude install libgtk-3-dev
The following NEW packages will be installed:
  libcairo-script-interpreter2{a} libcairo2-dev{ab} libgtk-3-dev{b} libpango1.0-dev{ab} libpixman-1-dev{a} 
0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,620 kB of archives. After unpacking 15.7 MB will be used.
The following packages have unmet dependencies:
 libpango1.0-dev : Depends: libfontconfig1-dev (>= 2.10.91) which is a virtual package.
                   Depends: libharfbuzz-dev (>= 0.9.9) which is a virtual package.
                   Depends: libxft-dev which is a virtual package.
                   Depends: libxrender-dev which is a virtual package.
 libcairo2-dev : Depends: libcairo2 (= 1.14.0-2.1rpi1rpi1g) but 1.14.0-2.1+deb8u1 is installed.
                 Depends: libcairo-gobject2 (= 1.14.0-2.1rpi1rpi1g) but 1.14.0-2.1+deb8u1 is installed.
                 Depends: libfontconfig1-dev (>= 2.2.95) which is a virtual package.
                 Depends: libxrender-dev (>= 0.6) which is a virtual package.
                 Depends: libxcb-shm0-dev which is a virtual package.
 libgtk-3-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.27.1) which is a virtual package.
                Depends: libatk1.0-dev (>= 2.7.5) which is a virtual package.
                Depends: libatk-bridge2.0-dev which is a virtual package.
                Depends: libxinerama-dev which is a virtual package.
                Depends: libxi-dev which is a virtual package.
                Depends: libxrandr-dev which is a virtual package.
                Depends: libxcursor-dev which is a virtual package.
                Depends: libxcomposite-dev which is a virtual package.
                Depends: libwayland-dev (>= 1.4.0) which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libcairo2-dev [Not Installed]                      
2)     libgtk-3-dev [Not Installed]                       
3)     libpango1.0-dev [Not Installed]                    



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
                                   
I tried running the original apt-get command again but with no success. Could you help me fix whatever is going on here. Thanks so much for the info you gave! :)

Edit: I've moved this question to another thread due to the fact that it is unrelated to the original question. Here is the link to the new thread. viewtopic.php?f=66&t=157211

Return to “Raspberry Pi OS”