Page 1 of 1

lirc question

Posted: Fri May 27, 2016 11:43 pm
by evilkitty
So i have this in my log

Code: Select all

[   20.984068] lirc_rpi: auto-detected active high receiver on GPIO pin 18
i have no IR receiver here (or anywhere else for that matter)
well technically i do but it is in a bag in a box
anyway i have pin 18 (aka board pin 12) connected to a 2N2222A transistor that controls a salved PC buzzer
how do i set lirc to not look for a receiver?

Re: lirc question

Posted: Sat May 28, 2016 12:02 am
by rzusman
Are you using lirc?
If not, just disable it.

Re: lirc question

Posted: Sat May 28, 2016 1:04 am
by evilkitty
i am using lirc to send data, just not receive

Re: lirc question

Posted: Sat May 28, 2016 8:49 am
by DirkS
If you're using the device tree overlay then you could try adding the parameter

Code: Select all

gpio_pin_in_pin=none

Re: lirc question

Posted: Sat May 28, 2016 3:03 pm
by evilkitty
does the device tree exist in the 3.12.36+ kernel?
I was using 4.4 then 4.9 but i reverted back to see if the a issue still happens
edit: how do i get lirc to work without the device tree?
i have this in /etc/modules but my led does not flash when i use the irsend command

Code: Select all

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

# Enable IR LED/Receiver (next 2 lines)
lirc_dev
lirc_rpi gpio_out_pin=26 gpio_pin_in_pin=none