Page 1 of 4

On screen keyboard

Posted: Thu Aug 16, 2012 5:07 pm
by matbos
Is there an on-screen for raspbian?

Re: On screen keyboard

Posted: Fri Aug 17, 2012 12:17 am
by JeremyF

Code: Select all

sudo apt-get install matchbox-keyboard
or download this file:
http://ftp.us.debian.org/debian/pool/ma ... _armhf.deb
and

Code: Select all

sudo dpkg -i matchbox*

Re: On screen keyboard

Posted: Fri Aug 17, 2012 10:19 am
by matbos
Thanks, that worked fine.

Re: On screen keyboard

Posted: Fri Aug 17, 2012 10:22 am
by jackokring
Now if it included a joystick to mouse driver, then it would be perfec. :D

Cheers Jacko

Re: On screen keyboard

Posted: Sun Oct 28, 2012 2:08 am
by VK4ZW
I am new to Linux and Raspberry Pi. I downloaded the onscreen keyboard as you instructed using the direct download. How do I now get to the onscreen keyboard and how do I pin an icon on the desktop?

Thanking you very much in advance.

Regards,

Ray

Re: On screen keyboard

Posted: Sun Apr 07, 2013 5:39 pm
by Wertox123
type

sudo matchbox-keyboard

to open it

Re: On screen keyboard

Posted: Sat Apr 20, 2013 10:58 am
by paenny
create a file on the Desktop called keyboard.sh

write in the file
#!/bin/bash
matchbox-keyboard

Then open a terminal and
write :
cd Desktop
chmod +x keyboard.sh

Now you can double click the file and your keyboard will appear.

Re: On screen keyboard

Posted: Fri May 24, 2013 6:13 pm
by fboteroh
I'm also beginer :| . I've tried it all but after typing sudo matchbox-keyboard nothing happens. What should I do? Tks!

Re: On screen keyboard

Posted: Wed Aug 14, 2013 8:53 am
by bantayan
It is suddenly working :)
Possible due to a reboot..

-------------
Hi, I have the same problem
sudo matchbox-keyboard
does not work

Re: On screen keyboard

Posted: Thu Aug 15, 2013 11:45 am
by texy
Are you in X ?

Texy

Re: On screen keyboard

Posted: Mon Jan 27, 2014 2:57 am
by ErFillion
Hey guys, for those who does not have direct internet access to their pi, or just want to download the keyboard to install it indirectly, here are the sources :
http://mirrordirector.raspbian.org/rasp ... _armhf.deb
http://mirrordirector.raspbian.org/rasp ... _armhf.deb
http://mirrordirector.raspbian.org/rasp ... _armhf.deb . Those worked for me, do not forget to type : sudo matchbox-keyboard or to create the keyboard.sh to activate the on screen keyboard as directed by the other users. You welcome.

Re: On screen keyboard

Posted: Fri Mar 14, 2014 7:48 pm
by thak
Hi

Does anyone knows how to change the default layout?
I already know that e few other layout are inclued with matchbox keyboard (like the "Finger" one named keyboard-fi.xml) but i don't understand how we can change the standart layout with an another one...
The read me file explain how to create a layout but i don't see something about changing it or i miss something...

thx for your help!

Re: On screen keyboard

Posted: Thu Jul 31, 2014 4:43 pm
by nachiketh
Hi Folks,
This is a great little tool for a touch keyboard, can we make this keyboard overlay on an application say a browser, right now what is happening is that I can run either the keyboard or the application(browser). So can we run this application in "always in the front" mode. :roll:
Thanks & Regards,
Nachiketh

Re: On screen keyboard

Posted: Sat Aug 30, 2014 8:33 am
by dae87
I installed matchbox-keyboard from ssh, and ran command 'matchbox-keyboard'. Nothing happens.
Actually command needs to be run locally, NOT from ssh.

Re: On screen keyboard

Posted: Sat Aug 30, 2014 8:36 am
by dae87
thak wrote:Hi

Does anyone knows how to change the default layout?
I already know that e few other layout are inclued with matchbox keyboard (like the "Finger" one named keyboard-fi.xml) but i don't understand how we can change the standart layout with an another one...
The read me file explain how to create a layout but i don't see something about changing it or i miss something...

thx for your help!
There is layout variant command line argument to matchbox-keyboard

Re: On screen keyboard

Posted: Wed Jun 17, 2015 5:06 pm
by Davies
when I run this keyboard program any files or folders on my desktop disappear and cannot be seen until a restart, has anyone else had this issue? anyone know a fix?

Re: On screen keyboard

Posted: Sun Aug 02, 2015 4:51 pm
by InsideJob
I think it defaults to docking whih makes everything disappear for me too. Undock it and then use the upper left icon in the title bar to make it always on the top layer. If you've got a stylus you might prefer the keyboard that comes with cell writer though.

sudo apt-get install cellwriter
key2.png
key2.png (18.95 KiB) Viewed 192230 times
key.png
key.png (32.5 KiB) Viewed 192230 times

Re: On screen keyboard

Posted: Mon Aug 31, 2015 1:25 am
by MelvinProject
This post has been moved to its own topic
matchbox-keyborad Is a great tool for development. But what about user end usage? I have a full screen Python tkInter program and I need something similar that can be called and killed from the shell. It also needs to NOT have keys like Control, Alt, and the function keys. So just ASCII Characters, Backspace, Space and Enter will be great.

Any help is appreciated. If matchbox-keyboard can be modified for this detailed instructions would be best.

Have a nice day

Re: On screen keyboard

Posted: Wed Sep 16, 2015 8:16 pm
by bmeredit
paenny wrote:create a file on the Desktop called keyboard.sh

write in the file
#!/bin/bash
matchbox-keyboard

Then open a terminal and
write :
cd Desktop
chmod +x keyboard.sh

Now you can double click the file and your keyboard will appear.
It seems that every time I execute this file, all my desktop icons disappear. Upon reboot, they are present. I'm a novice at anything code related. Could you break down any reasons why executing this file would result in my desktop icons disappearing?

Re: On screen keyboard

Posted: Thu Oct 01, 2015 9:54 am
by Onira
Yes, I have the same
My desktop icons disappear

Re: On screen keyboard

Posted: Tue Oct 20, 2015 1:14 am
by Dexodrill
Is there a way to prevent the desktop icons from disappearing? Im trying to set up a touchscreen keyboard for use with the Raspberry Pi that will allow me to touch a text input box and have a keyboard come up. Im hopeing that this will be the answer as Iv read that if you run the keyboard as a daemon it should work.

Re: On screen keyboard

Posted: Sun Nov 29, 2015 9:34 pm
by summikogurashi
I had a similar problem with the icons disappearing.

However I've changed the script to this (mine is named keyboard.sh):

<code>
#!/bin/bash

matchbox-keyboard &
</code>

I leave this on the desktop and it works. Also remember to chmod +x keyboard.sh for it to be executable.

Best Regards,

sumikogurashi

Re: On screen keyboard

Posted: Wed Dec 02, 2015 8:47 am
by iyosch
Does anyone knows how to set the position of the matchbox-keyboard?

I got it from sudo apt-get matchbox-keyboard. It says it is the newest version and it only has little options. When I checked it, it was version 0.1 . I found another one from xlab for matchbox-keyboard, it says version 1.5 and has more options. The problem is I can not compile nor install it. Does anyone knows how? or Do you know you to set any virtual keyboard so it will stay at a specific location when it was executed.

Re: On screen keyboard

Posted: Wed Dec 02, 2015 8:26 pm
by tvjon
¨or Do you know you to set any virtual keyboard so it will stay at a specific location when it was executed.¨

On small screens, where there isn´t of course, much room, I use

xvkbd

http://homepage3.nifty.com/tsato/xvkbd/


It can be invoked by something like:

@xvkbd -secure -geometry 400x130+100+100

placed in

/home/pi/.config/lxsession/LXDE-pi/autostart

Additionally, to prevent ¨casual users¨ inadvertently moving it, & coincidentally freeing up more space, edit:

/home/pi/.config/openbox/lxde-pi-rc.xml

to include


<application class="*">
<decor>no</decor>
</application>


after the existing line

</application>

which in my file (on Jessie) is at line 675.


HTH

Re: On screen keyboard

Posted: Tue Dec 08, 2015 11:37 pm
by Gabo353
I had a similar problem with the icons disappearing.
However I've changed the script to this (mine is named keyboard.sh):
<code>
#!/bin/bash
matchbox-keyboard &
</code>
I leave this on the desktop and it works. Also remember to chmod +x keyboard.sh for it to be executable.
Best Regards,
the

The code is not working.
syntax error.