timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

,h264 playback - help !

Wed May 04, 2016 8:03 am

I'm a proud owner of the latest Pi complete with WiFi and a 8MP camera

After a bit of hassle with getting a 64GB sd card with Raspbian 18th March 2016 working on it, I tried this:-

raspivid -t 25000 -o video.h264

and lo a file duly arrived in the home directory ! Brill

Never having heard of .h264 left me with a struggle to find something to play it on.

Moving the file to Ubuntu 14.04 and downloading smplayer I could now watch 25 seconds of video ! I had hoped ! *LOL*

yes it played ! in about 5 seconds !

Any thoughts on what I have to do to watch this video at the right frame rate for smplayer...., would be greatly appreciated !

:? :? :?

Tim

DirkS
Posts: 9876
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: ,h264 playback - help !

Wed May 04, 2016 8:06 am


timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: ,h264 playback - help !

Wed May 04, 2016 8:56 am

Many thanks for that info, I will try it out !

by the way how do I install omxplayer ?

is it

sudo apt-get install omxplayer

???

Many thanks again,

:D :D

Tim

SkyRise
Posts: 178
Joined: Tue Jan 24, 2012 1:20 pm

Re: ,h264 playback - help !

Wed May 04, 2016 9:00 am

Yes,

Code: Select all

sudo apt-get install omxplayer
will install omxplayer

Also, when installing packages, apt keeps a copy of the file it downloaded for installation. This cache can become quite big over time.
A

Code: Select all

sudo apt-get clean
will prune the download files from the cache.

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: ,h264 playback - help !

Wed May 04, 2016 9:44 am

Many many thanks,

:D :D :D

Tim

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: ,h264 playback - help !

Wed May 04, 2016 4:15 pm

tried that and omxplayer and it installed but ./omxplayer yielded

No such file or directory....

all this was in the home directory...

so I'm still stuck..

Any more tips greatly appreciated ?

Tim

DirkS
Posts: 9876
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: ,h264 playback - help !

Wed May 04, 2016 4:21 pm

timmoore46 wrote:tried that and omxplayer and it installed but ./omxplayer yielded
Use it without the ./

User avatar
RaTTuS
Posts: 10381
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: ,h264 playback - help !

Wed May 04, 2016 4:24 pm

if you want to play it back on other machines then you may want to container the file
as the .h264 is a raw file you need to tell it that it is
25fps
or it may just play back as fast as possible
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: ,h264 playback - help !

Wed May 04, 2016 6:06 pm

Got smplayer downloaded to the Pi and it took 3 minutes to play the 25second video clip

the version of smplayer was.....14.9.0

it took a bit to get smplayer to accept it !

file/multimedia (bottom right on screen), scrolled down its menu and settle on 'All Filesand high lighted video.h264
and it played it very very slowly !

What do I do next ?

Any thoughts anyone ?

:D :D

Tim

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: ,h264 playback - help !

Wed May 04, 2016 7:05 pm

RaTTuS wrote:if you want to play it back on other machines then you may want to container the file
as the .h264 is a raw file you need to tell it that it is
25fps
or it may just play back as fast as possible
How do you tell it that its 25fps ?

Many thanks for responding !

:D :D

Tim

ghans
Posts: 7868
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: ,h264 playback - help !

Thu May 05, 2016 7:34 am

You have to use a muxer like MP4Box after you've finished
recording to create "proper" .mp4 files from raw .h264.

Code: Select all

sudo apt-get install gpac
MP4Box  -fps 30  -add infile.h264 outfile.mp4
omxplayer outfile.mp4
ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: ,h264 playback - help !

Thu May 05, 2016 6:58 pm

Many many thaks for responding. I'll try MP4Box.

:D :D :D

Tim

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: ,h264 playback - help !

Thu May 05, 2016 9:48 pm

I put the video.h264 file on a PC running Ubuntu 14.04 and installed 'gpac' and that automatically woke a variant of VLC which ran the video clip close to real time, but also put it into a continuous loop.

Now that's a huge improvement over being massively too slow or massively too fast.

Technically I don't know what I'm doing, just poking it with a stick until I stumble on a satisfactory solution.

I'm very very grateful for all the tips and suggestions the members of this Forum have offered !

:D :D :D

Tim

ghans
Posts: 7868
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: ,h264 playback - help !

Sat May 07, 2016 6:36 am

Both the "raspivid" command and the "MP4Box" command
have an "fps" option - it obviously needs to be the same
for both commands.


ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

Return to “Raspbian”