Page 1 of 1

Transmission gui don´t work on restart

Posted: Sun May 01, 2016 11:57 pm
by mcatto
Hi.
I have raspberry 3 and transmission in raspbian
The daemon is loadead and the torrents downloaded.
But when restart de raspberry the gui don't work. I need to stop the daemon and start again, and the gui works for my 192.168.1.103:9091 ip.
How i can solve this?
Thanks
Sorry for my english

Re: Transmission gui don´t work on restart

Posted: Tue May 03, 2016 6:43 pm
by Peter Ryan
If systemd is condifured to not start transmission at boot, checking it's status will show something like this:

Code: Select all

[email protected]:~ $ systemctl status transmission-daemon.service
● transmission-daemon.service - Transmission BitTorrent Daemon
   Loaded: loaded (/lib/systemd/system/transmission-daemon.service; disabled)
   Active: inactive (dead)
If that's the case, then setting it to start at boot is easy:

Code: Select all

[email protected]:~ $ systemctl enable transmission-daemon.service
If it's not that though... then I'm a bit short on ideas! You could try "reenable" instead of "enable" which is meant to disable and then enable to ensure the symlinks sytemd uses are correctly set up.

Re: Transmission gui don´t work on restart

Posted: Tue May 03, 2016 7:40 pm
by mcatto
I have this

[email protected]:~ $ [email protected]:~ $ systemctl status transmission-daemon.service
-bash: [email protected]:~: no se encontró la orden
[email protected]:~ $ ● transmission-daemon.service - Transmission BitTorrent Daemon
-bash: ●: no se encontró la orden
[email protected]:~ $ Loaded: loaded (/lib/systemd/system/transmission-daemon.service; enabled)
-bash: error sintáctico cerca del elemento inesperado `('
[email protected]:~ $ Active: active (running) since mar 2016-05-03 22:37:05 GMT-3; 1min 8s ago
-bash: error sintáctico cerca del elemento inesperado `('
[email protected]:~ $ Main PID: 592 (transmission-da)
-bash: error sintáctico cerca del elemento inesperado `('
[email protected]:~ $ Status: "Uploading 0.59 KBps, Downloading 0.53 KBps."
-bash: Status:: no se encontró la orden
[email protected]:~ $ CGroup: /system.slice/transmission-daemon.service
-bash: CGroup:: no se encontró la orden
[email protected]:~ $ └─592 /usr/bin/transmission-daemon -f --log-error
-bash: └─592: no se encontró la orden
[email protected]:~ $ [email protected]:~ $
-bash: [email protected]:~: no se encontró la orden
[email protected]:~ $ clear
[email protected]:~ $ systemctl status transmission-daemon.service
● transmission-daemon.service - Transmission BitTorrent Daemon
Loaded: loaded (/lib/systemd/system/transmission-daemon.service; enabled)
Active: active (running) since mar 2016-05-03 22:37:05 GMT-3; 1min 55s ago
Main PID: 592 (transmission-da)
Status: "Uploading 0.19 KBps, Downloading 0.68 KBps."
CGroup: /system.slice/transmission-daemon.service
└─592 /usr/bin/transmission-daemon -f --log-error
[email protected]:~ $