DoyleChris
Posts: 32
Joined: Wed Nov 20, 2013 10:04 pm

Mount Flash Drive

Sat Mar 26, 2016 3:28 am

I am having problems mounting a flash drive.
If i let raspbian do plug and play it puts it into /media/********.
But i want to make it a permanent mount point /mnt/32.
but when i do i haft to use sudo to run the command, which when its all done it is controlled by root not pi.

In fstab this is the line i have in there.
/dev/sda1 /mnt/32 auto rw,defaults 0 0

I cant figure out how to give pi access to the drive.

JimmyN
Posts: 1109
Joined: Wed Mar 18, 2015 7:05 pm
Location: Virginia, USA

Re: Mount Flash Drive

Sat Mar 26, 2016 9:26 am

Add a user id and group id

"/dev/sda1 /mnt/32 auto rw,defaults,uid=pi,gid=pi 0 0

DoyleChris
Posts: 32
Joined: Wed Nov 20, 2013 10:04 pm

Re: Mount Flash Drive

Sat Mar 26, 2016 4:46 pm

So i have tried everything i can to get this to work all the way to reloading Raspbian.

Last thing i did was removed the Stick, removed the lines from /etc/fstab.

If anybody has a way to do it, none of the things i have found are working.
This is what i have.

Raspberry PI 2
Raspbian Jessie Updated and Upgraded
32GB flash stick formated to NTFS plugged into USB on the PI

I would like the stick mounted in a way that the pi user can install programs onto it.

All methods i have found do not give me access to create folders or install files.

User avatar
DougieLawson
Posts: 35542
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Mount Flash Drive

Sat Mar 26, 2016 9:26 pm

Option 1: reformat the stick as ext4
Option 2: install ntfs-3g
Note: Having anything remotely humorous in your signature is completely banned on this forum. Wear a tinfoil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

dchao99
Posts: 45
Joined: Fri Jan 15, 2016 9:26 pm

Re: Mount Flash Drive

Sun Mar 27, 2016 10:18 pm

DoyleChris wrote: 32GB flash stick formated to NTFS plugged into USB on the PI
Use FAT or exFAT. Much faster.
Just make sure "uid=1000, gid=1000" is in fstab
If you want the stick to be accessible to the PC, don't use EXT-4.

Return to “Raspbian”