Superkikim
Posts: 18
Joined: Tue Mar 15, 2016 9:09 am

brcmfmac brcmf_cfg80211 trouble on RPI3

Fri Mar 18, 2016 11:08 pm

Hi all,
I'm trying to troubleshoot a random wireless issue.

The problem is the onboard wlan does not hook to the accesspoint randomly. And when it does, it is then very unstable and loses a lot of packets.

I've tried on two different RPI3, two different AP and networks. If anyone gets anything on this shit, for now, personnally, I'm giving up raspian on my RPI3.....

Code: Select all

[    6.006328] cfg80211: Calling CRDA to update world regulatory domain
[    6.079828] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24
[    6.081389] usbcore: registered new interface driver brcmfmac
[    6.254535] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Dec 15 2015 18:10:45 version 7.45.41.23 (r606571) FWID 01-cc4eda9c
[    6.276380] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    6.464192] bcm2835-rng 3f104000.rng: hwrng registered
[    6.464794] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[    6.528607] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    6.528638] cfg80211: World regulatory domain updated:
[    6.528648] cfg80211:  DFS Master region: unset
[    6.528719] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[    6.528735] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[    6.528748] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[    6.528760] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[    6.528775] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[    6.528789] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[    6.528802] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[    6.528814] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[    6.528826] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[    6.675167] systemd-journald[105]: Received request to flush runtime journal from PID 1
[    7.035657] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[    7.035671] brcmfmac: brcmf_add_if: ignore IF event
[    7.039849] brcmfmac: power management disabled
[   14.366281] random: nonblocking pool is initialized
[   68.207292] uart-pl011 3f201000.uart: no DMA platform data
[   68.452232] Adding 102396k swap on /var/swap.  Priority:-1 extents:2 across:176124k SSFS
[   68.610017] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   68.610287] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   70.228440] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   70.231922] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   72.662456] Bluetooth: Core ver 2.20
[   72.662512] NET: Registered protocol family 31
[   72.662518] Bluetooth: HCI device and connection manager initialized
[   72.662533] Bluetooth: HCI socket layer initialized
[   72.662543] Bluetooth: L2CAP socket layer initialized
[   72.662566] Bluetooth: SCO socket layer initialized
[   72.670478] Bluetooth: HCI UART driver ver 2.3
[   72.670489] Bluetooth: HCI UART protocol H4 registered
[   72.670494] Bluetooth: HCI UART protocol Three-wire (H5) registered
[   72.670499] Bluetooth: HCI UART protocol BCM registered
[   72.822746] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   72.822763] Bluetooth: BNEP filters: protocol multicast
[   72.822781] Bluetooth: BNEP socket layer initialized
[  487.339932] brcmfmac: power management disabled
[  526.219738] brcmfmac: power management disabled
[  606.928199] brcmfmac: power management disabled
[  693.393546] cfg80211: Calling CRDA to update world regulatory domain
[  693.405034] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[  693.405056] cfg80211: World regulatory domain updated:
[  693.405065] cfg80211:  DFS Master region: unset
[  693.405074] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  693.405082] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  693.405089] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  693.405095] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[  693.405102] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[  693.405110] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[  693.405116] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[  693.405122] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[  693.405128] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[  722.767306] brcmfmac: power management disabled

dchao99
Posts: 45
Joined: Fri Jan 15, 2016 9:26 pm

Re: brcmfmac brcmf_cfg80211 trouble on RPI3

Fri Mar 25, 2016 10:10 pm

What WiFi channel are you using?

Code: Select all

To display the channel number
$ iwlist wlan0 frequency
I've found a problem with RPi3 running on channel 11 when the country code is set to US or you have an American AP.
The work around is to use channel 6 on the AP.

Return to “Raspbian”