Ramphex
Posts: 6
Joined: Wed Jan 20, 2016 1:44 am

Can't update raspberrypi-sys-mods and raspberrypi-ui-mods

Tue Feb 09, 2016 1:48 am

Setting up raspberrypi-sys-mods (20160112) ...
Fixing ping capabilities...
Failed to set capabilities on file `/bin/ping' (Invalid argument)
The value of the capability argument is not permitted for a file. Or the file is not a regular (non-symlink) file
dpkg: error processing package raspberrypi-sys-mods (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of raspberrypi-ui-mods:
raspberrypi-ui-mods depends on raspberrypi-sys-mods; however:
Package raspberrypi-sys-mods is not configured yet.

dpkg: error processing package raspberrypi-ui-mods (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
raspberrypi-sys-mods
raspberrypi-ui-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)
Any ideas?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6228
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Feb 09, 2016 9:32 am

Thanks, will take a look.

Ramphex
Posts: 6
Joined: Wed Jan 20, 2016 1:44 am

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Feb 09, 2016 9:33 am

I'm experiencing this on all 3 of my RPi2 machines. All running the latest version of Raspbian.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6228
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Feb 09, 2016 10:46 am

Did you change the rootfs filesystem?

Ramphex
Posts: 6
Joined: Wed Jan 20, 2016 1:44 am

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Feb 09, 2016 11:29 am

No. Everything was fine until the updates yesterday 02/08/2016. Ran apt update then apt upgrade and that's the result.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6228
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Feb 09, 2016 11:35 am

I am just not sure why running 'setcap cap_net_raw+ep /bin/ping
' would say 'The value of the capability argument is not permitted for a file. Or the file is not a regular (non-symlink) file'

What is the output of 'ls -la /bin/ping' ?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6228
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Feb 09, 2016 12:22 pm

If you run `sudo apt-get update && sudo apt-get dist-upgrade` is the issue resolved?

jaggions
Posts: 2
Joined: Sun Aug 24, 2014 9:04 pm

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Feb 09, 2016 12:50 pm

I was having the same issue.
What is the output of 'ls -la /bin/ping' ?
-rwsr-xr-x 1 root root 38844 feb 12 2014 /bin/ping
If you run `sudo apt-get update && sudo apt-get dist-upgrade` is the issue resolved?
Yes.

Ramphex
Posts: 6
Joined: Wed Jan 20, 2016 1:44 am

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Wed Feb 10, 2016 2:20 am

You guys are the best! Problem is solved with today's update.

Could you guys disclose what the issue was with setting capabilities for ping?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6228
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Wed Feb 10, 2016 6:28 pm

Ramphex wrote: you guys disclose what the issue was with setting capabilities for ping?
Unfortunately, I don't know what the issue is, I only made it continue even when that step fails.


nemo9955
Posts: 1
Joined: Tue Oct 18, 2016 6:14 pm

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Oct 18, 2016 6:22 pm

Fresh RASPBIAN JESSIE LITE 2016-09-23, all commands run so far.

Code: Select all

pi@raspberrypi:~ $ sudo apt-get update && sudo apt-get upgrade -y
Get:1 http://archive.raspberrypi.org jessie InRelease [13.2 kB]
Get:2 http://mirrordirector.raspbian.org jessie InRelease [14.9 kB]
Get:3 http://archive.raspberrypi.org jessie/main armhf Packages [106 kB]
Get:4 http://mirrordirector.raspbian.org jessie/main armhf Packages [8,981 kB]
Get:5 http://archive.raspberrypi.org jessie/ui armhf Packages [52.6 kB]
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Get:6 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [37.5 kB]
Get:7 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [70.3 kB                                               ]
Get:8 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 9,277 kB in 16s (559 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  bind9-host libbind9-90 libdns-export100 libdns100 libirs-export91
  libisc-export95 libisc95 libisccc90 libisccfg-export90 libisccfg90
  liblwres90 libssl1.0.0 openssl raspberrypi-sys-mods raspi-config
15 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,112 kB of archives.
After this operation, 9,216 B of additional disk space will be used.
Get:1 http://archive.raspberrypi.org/debian/ jessie/main raspberrypi-sys-mods al                                               l 20161018+1 [7,022 B]
Get:2 http://archive.raspberrypi.org/debian/ jessie/ui raspi-config all 20161013                                                [16.8 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ jessie/main libssl1.0.0 armhf                                                1.0.1t-1+deb8u5 [853 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ jessie/main libisc-export95 a                                               rmhf 1:9.9.5.dfsg-9+deb8u7 [124 kB]
Get:5 http://mirrordirector.raspbian.org/raspbian/ jessie/main libdns-export100                                                armhf 1:9.9.5.dfsg-9+deb8u7 [397 kB]
Get:6 http://mirrordirector.raspbian.org/raspbian/ jessie/main libisccfg-export9                                               0 armhf 1:9.9.5.dfsg-9+deb8u7 [37.7 kB]
Get:7 http://mirrordirector.raspbian.org/raspbian/ jessie/main libirs-export91 a                                               rmhf 1:9.9.5.dfsg-9+deb8u7 [36.3 kB]
Get:8 http://mirrordirector.raspbian.org/raspbian/ jessie/main bind9-host armhf                                                1:9.9.5.dfsg-9+deb8u7 [65.4 kB]
Get:9 http://mirrordirector.raspbian.org/raspbian/ jessie/main libisc95 armhf 1:                                               9.9.5.dfsg-9+deb8u7 [149 kB]
Get:10 http://mirrordirector.raspbian.org/raspbian/ jessie/main libdns100 armhf                                                1:9.9.5.dfsg-9+deb8u7 [601 kB]
Get:11 http://mirrordirector.raspbian.org/raspbian/ jessie/main libisccc90 armhf                                                1:9.9.5.dfsg-9+deb8u7 [34.1 kB]
Get:12 http://mirrordirector.raspbian.org/raspbian/ jessie/main libisccfg90 armh                                               f 1:9.9.5.dfsg-9+deb8u7 [50.0 kB]
Get:13 http://mirrordirector.raspbian.org/raspbian/ jessie/main libbind9-90 armh                                               f 1:9.9.5.dfsg-9+deb8u7 [41.0 kB]
Get:14 http://mirrordirector.raspbian.org/raspbian/ jessie/main liblwres90 armhf                                                1:9.9.5.dfsg-9+deb8u7 [47.5 kB]
Get:15 http://mirrordirector.raspbian.org/raspbian/ jessie/main openssl armhf 1.                                               0.1t-1+deb8u5 [652 kB]
Fetched 3,112 kB in 4s (676 kB/s)
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 31216 files and directories currently installed.)
Preparing to unpack .../libssl1.0.0_1.0.1t-1+deb8u5_armhf.deb ...
Unpacking libssl1.0.0:armhf (1.0.1t-1+deb8u5) over (1.0.1t-1+deb8u3) ...
Preparing to unpack .../libisc-export95_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libisc-export95 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) .                                               ..
Preparing to unpack .../libdns-export100_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libdns-export100 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6)                                                ...
Preparing to unpack .../libisccfg-export90_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libisccfg-export90 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6                                               ) ...
Preparing to unpack .../libirs-export91_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libirs-export91 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) .                                               ..
Preparing to unpack .../bind9-host_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking bind9-host (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) ...
Preparing to unpack .../libisc95_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libisc95 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) ...
Preparing to unpack .../libdns100_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libdns100 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) ...
Preparing to unpack .../libisccc90_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libisccc90 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) ...
Preparing to unpack .../libisccfg90_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libisccfg90 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) ...
Preparing to unpack .../libbind9-90_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking libbind9-90 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) ...
Preparing to unpack .../liblwres90_1%3a9.9.5.dfsg-9+deb8u7_armhf.deb ...
Unpacking liblwres90 (1:9.9.5.dfsg-9+deb8u7) over (1:9.9.5.dfsg-9+deb8u6) ...
Preparing to unpack .../openssl_1.0.1t-1+deb8u5_armhf.deb ...
Unpacking openssl (1.0.1t-1+deb8u5) over (1.0.1t-1+deb8u3) ...
Preparing to unpack .../raspberrypi-sys-mods_20161018+1_all.deb ...
Unpacking raspberrypi-sys-mods (20161018+1) over (20160916) ...
Preparing to unpack .../raspi-config_20161013_all.deb ...
Unpacking raspi-config (20161013) over (20160810) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for systemd (215-17+deb8u5) ...
Setting up libssl1.0.0:armhf (1.0.1t-1+deb8u5) ...
Setting up libisc-export95 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libdns-export100 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libisccfg-export90 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libirs-export91 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libisc95 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libdns100 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libisccc90 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libisccfg90 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up libbind9-90 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up liblwres90 (1:9.9.5.dfsg-9+deb8u7) ...
Setting up bind9-host (1:9.9.5.dfsg-9+deb8u7) ...
Setting up openssl (1.0.1t-1+deb8u5) ...
Setting up raspberrypi-sys-mods (20161018+1) ...
/var/lib/dpkg/info/raspberrypi-sys-mods.postinst: 49: /var/lib/dpkg/info/raspber                                               rypi-sys-mods.postinst: Syntax error: ";;" unexpected (expecting "fi")
dpkg: error processing package raspberrypi-sys-mods (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up raspi-config (20161013) ...
Processing triggers for libc-bin (2.19-18+deb8u6) ...
Errors were encountered while processing:
 raspberrypi-sys-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up raspberrypi-sys-mods (20161018+1) ...
/var/lib/dpkg/info/raspberrypi-sys-mods.postinst: 49: /var/lib/dpkg/info/raspber                                               rypi-sys-mods.postinst: Syntax error: ";;" unexpected (expecting "fi")
dpkg: error processing package raspberrypi-sys-mods (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 raspberrypi-sys-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up raspberrypi-sys-mods (20161018+1) ...
/var/lib/dpkg/info/raspberrypi-sys-mods.postinst: 49: /var/lib/dpkg/info/raspberrypi-sys-mods.postinst: Syntax error: ";;" unexpected (expecting "fi")
dpkg: error processing package raspberrypi-sys-mods (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 raspberrypi-sys-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $ raspi-config
Script must be run as root. Try 'sudo raspi-config'
pi@raspberrypi:~ $ sudo raspi-config

Welcome to fdisk (util-linux 2.25.2).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.


Command (m for help): Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x7f0f5ed8

Device         Boot  Start      End  Sectors  Size Id Type
/dev/mmcblk0p1        8192   137215   129024   63M  c W95 FAT32 (LBA)
/dev/mmcblk0p2      137216 31116287 30979072 14.8G 83 Linux


Command (m for help): Partition number (1,2, default 2):
Partition 2 has been deleted.

Command (m for help): Partition type
   p   primary (1 primary, 0 extended, 3 free)
   e   extended (container for logical partitions)
Select (default p): Partition number (2-4, default 2): First sector (2048-31116287, default 2048): Last sector, +sectors or +si
Created a new partition 2 of type 'Linux' and of size 14.8 GiB.

Command (m for help): Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x7f0f5ed8

Device         Boot  Start      End  Sectors  Size Id Type
/dev/mmcblk0p1        8192   137215   129024   63M  c W95 FAT32 (LBA)
/dev/mmcblk0p2      137216 31116287 30979072 14.8G 83 Linux


Command (m for help): The partition table has been altered.
Calling ioctl() to re-read partition table.
Re-reading the partition table failed.: Device or resource busy

The kernel still uses the old table. The new table will be used at the next reboot or after you run partprobe(8) or kpartx(8).

Enter new UNIX password:
Retype new UNIX password:
Sorry, passwords do not match
passwd: Authentication token manipulation error
passwd: password unchanged
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
Created symlink from /etc/systemd/system/default.target to /lib/systemd/system/multi-user.target.

Current default time zone: 'Europe/Bucharest'
Local time is now:      Tue Oct 18 20:58:48 EEST 2016.
Universal Time is now:  Tue Oct 18 17:58:48 UTC 2016.

Failed to stop vncserver-x11-serviced.service: Unit vncserver-x11-serviced.service not loaded.
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
raspi-config is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up raspberrypi-sys-mods (20161018+1) ...
/var/lib/dpkg/info/raspberrypi-sys-mods.postinst: 49: /var/lib/dpkg/info/raspberrypi-sys-mods.postinst: Syntax error: ";;" unex
dpkg: error processing package raspberrypi-sys-mods (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 raspberrypi-sys-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $ sudo apt-get update
sudo: unable to resolve host raspberrypi
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Reading package lists... Done
pi@raspberrypi:~ $ sudo apt-get upgrade
sudo: unable to resolve host raspberrypi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up raspberrypi-sys-mods (20161018+1) ...
/var/lib/dpkg/info/raspberrypi-sys-mods.postinst: 49: /var/lib/dpkg/info/raspberrypi-sys-mods.postinst: Syntax error: ";;" unex
dpkg: error processing package raspberrypi-sys-mods (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 raspberrypi-sys-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $ ^C
pi@raspberrypi:~ $ sudo apt-get update && sudo apt-get dist-upgrade
sudo: unable to resolve host raspberrypi
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Reading package lists... Done
sudo: unable to resolve host raspberrypi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up raspberrypi-sys-mods (20161018+1) ...
/var/lib/dpkg/info/raspberrypi-sys-mods.postinst: 49: /var/lib/dpkg/info/raspberrypi-sys-mods.postinst: Syntax error: ";;" unexpected (expecting "fi")
dpkg: error processing package raspberrypi-sys-mods (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 raspberrypi-sys-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)

User avatar
ukscone
Forum Moderator
Forum Moderator
Posts: 4214
Joined: Fri Jul 29, 2011 2:51 pm
Contact: Website

Re: Can't update raspberrypi-sys-mods and raspberrypi-ui-mod

Tue Oct 18, 2016 9:12 pm

i had that earlier today but it seems to be fixed now

Return to “Raspberry Pi OS”