Posts: 12
Joined: Mon Aug 13, 2012 8:13 pm

openarena + jessie + Raspberry Pi 2

Wed Nov 04, 2015 4:48 pm

Has anyone managed to get OpenArena to work on a Raspberry Pi 2 with jessie (debian 8)?

This is what I've tried so far:

* Setting the resolution in the config file to the same as the actual screen resolution
* Trying a custom resolution
* Forcing window mode.

An excerpt of the crash log from openarena: (full log at )
SDL using driver "x11"
Initializing OpenGL display
Estimated display aspect: 1.333
...setting mode 6: 1024 768
Available modes: '1024x768'
Couldn't get a visual
...WARNING: could not set the given mode (6)

One thing that DID work was to install the OpenGL software renderer (libgl1-mesa-swx11) but this is of course glacially slow - so slow I couldn't even use the basic UI to exit and had to Ctrl-Chift-F1 and kill openarena from the command line. This leads me to suspect that there is some missing hardware OpenGL library, but searching using aptitude doesn't bring up anything useful.

OpenArena was installed using apt-get install openarena so I presume it pulled all the dependencies it needed, though (and presumably was properly built for the Pi and works on *someone's* machine otherwise it wouldn't be in the repository)

Any further ideas?

Posts: 12
Joined: Mon Aug 13, 2012 8:13 pm

Re: openarena + jessie + Raspberry Pi 2

Thu Nov 05, 2015 10:45 am

Answering my own question, in case it helps someone in the future searching for this.

The openarena package in Raspbian doesn't actually work on Raspbian. It's simply the version in Debian recompiled, and as such it needs desktop OpenGL rather than OpenGL ES, which is what's available on the Raspberry Pi.

Fortunately someone's done much of the hard work of porting a version of the game to the Pi for the now defunct Pi store (unfortunately, packages aren't available), and I was able to build it from source. You can get working source code doing this:

git clone

Make sure you have the SDL development packages installed. You can then build by running the (and waiting many hours, best done overnight). The resulting executables will be in build/release-linux-arm.

I don't have anything with sound at the moment so I don't know if the sound works, and I've only got it working with the Q3 Demo Paks available by running:


(unzip this file in the directory where the executables are)

and then running ioquake3.arm.

I've only run this so far on Debian 7, not tried Debian 8 but I expect it'll work. I may make debian packages of this later if all goes well.

User avatar
Posts: 95
Joined: Tue Jan 10, 2012 10:37 pm
Location: West Yorkshire

Re: openarena + jessie + Raspberry Pi 2

Thu Nov 05, 2015 6:15 pm

Could this be a similar reason why the Stella emulator has stopped working in Jessie?

Return to “Raspberry Pi OS”