Michael_O
Posts: 23
Joined: Sat Oct 20, 2012 12:28 pm

mencoder not in jessie?

Fri Oct 16, 2015 2:04 pm

I tried to install mencoder to make a timelapse video from a set of images but I get a strange error:

Code: Select all

[email protected] ~ $ sudo apt-get install mencoder
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mencoder is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'mencoder' has no installation candidate
Mencoder is used in the RPF timelapse learning resource so this should concern them.
ffmpeg and avconv both have the same problem. I have confirmed that I have full access to the repository by installing other packages such as iceweasel.
Can anybody tell me what is going on?

fruitoftheloom
Posts: 20685
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: mencoder not in jessie?

Fri Oct 16, 2015 2:13 pm

Michael_O wrote:I tried to install mencoder to make a timelapse video from a set of images but I get a strange error:

Code: Select all

[email protected] ~ $ sudo apt-get install mencoder
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mencoder is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'mencoder' has no installation candidate
Mencoder is used in the RPF timelapse learning resource so this should concern them.
ffmpeg and avconv both have the same problem. I have confirmed that I have full access to the repository by installing other packages such as iceweasel.
Can anybody tell me what is going on?
ffmpeg / avconv / mencoder all replaced.

libav-tools and mpv are the updated packages in Jessie:

https://packages.debian.org/jessie/libav-tools

https://packages.debian.org/jessie/mpv

http://mpv.io

https://libav.org
Retired disgracefully.....

Cloud-Hopper
Posts: 1
Joined: Mon Mar 28, 2016 5:44 pm

Re: mencoder not in jessie?

Mon Mar 28, 2016 6:00 pm

All,

Good news for mencoder users. I have just installed mencoder under jessie yesterday (2016-03-28) on a RPI v3.

You will have to compile from the source, having also installed ffmeg.

It took about 25 minutes to build on the Pi v3 and there were a few compile warnings, but no errors.

To do this, follow the build instructions as normal .. ./configure, make, make install ... and you should get a working binary.

As noted, this will not be a permanent solution so look to move away from mencoder in the longer term under debian.

Good luck!

Cloud-Hopper

-----------
Build commands from history ...

Code: Select all

wget http://www.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
bunzip2 *
tar xvf *
cd mplayer-export-2016-03-26/
sudo apt-get install ffmpeg
./configure
make
< ... wait a long time here ...>
./mencoder
sudo make install

User avatar
DougieLawson
Posts: 36098
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: mencoder not in jessie?

Tue Mar 29, 2016 6:50 am

Try using tar xavf rather than bunzip2 followed by tar xvf. I think you'll be amazed at what happens.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

gomako
Posts: 5
Joined: Sun Jul 01, 2012 8:49 pm

Re: mencoder not in jessie?

Fri Mar 24, 2017 8:47 pm

I used the new packages on my Pi Zero W.

Install the tools:

Code: Select all

sudo apt-get install libav-tools
Then you can combine stills using a command from the link https://wiki.libav.org/Snippets/avconv# ... e_sequence
I used:

Code: Select all

avconv -framerate 25 -f image2 -i image-%04d.jpg -b 65536k out.mov

Return to “Raspbian”