Page 2 of 2

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 7:21 pm
by n67
PianoPCJ/A.F wrote:
Sat Feb 17, 2018 6:42 pm
ShiftPlusOne wrote:
Fri Feb 16, 2018 5:14 pm
Use raspi-config to disable serial shell instead of the way they say in the tutorial. You want to keep the hardware enabled, but disable the shell (it should ask you two questions).

what do you mean with raspi-config? is this a comand or a file?
It's both!

It's also a desert topping and a floor wax.

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 7:31 pm
by PianoPCJ/A.F
Ok thanks! But how can I follow no my tutorial? Again: In the tutorial they used a Raspi 2 and I have a Raspi3B

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 7:34 pm
by n67
PianoPCJ/A.F wrote:
Sat Feb 17, 2018 7:31 pm
Ok thanks! But how can I follow no my tutorial? Again: In the tutorial they used a Raspi 2 and I have a Raspi3B
The fundamental problem is that they keep changing things, rendering existing tutorials inaccurate.

If your tutorials reference a Raspi 1 or 2, then they probably were written with Wheezy in mind, which, as the fruity one will tell you any second now, is not only EOL, but dead and buried.

The only way to follow the tutorials and not go mad, is to install and use Wheezy. It is possible to download and use old versions of Raspbian; I am told that all old versions are kept available.

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 7:43 pm
by PianoPCJ/A.F
n67 wrote:
Sat Feb 17, 2018 7:34 pm
PianoPCJ/A.F wrote:
Sat Feb 17, 2018 7:31 pm
Ok thanks! But how can I follow no my tutorial? Again: In the tutorial they used a Raspi 2 and I have a Raspi3B
The fundamental problem is that they keep changing things, rendering existing tutorials inaccurate.

If your tutorials reference a Raspi 1 or 2, then they probably were written with Wheezy in mind, which, as the fruity one will tell you any second now, is not only EOL, but dead and buried.

The only way to follow the tutorials and not go mad, is to install and use Wheezy. It is possible to download and use old versions of Raspbian; I am told that all old versions are kept available.
OK, but right now I'm using raspian stretch light(without a GUI) and as far as I know, wheezy is a GUI for Debian 8, isn't it? Right now I control the Raspi over SSH

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 8:19 pm
by n67
No, Wheezy is not the GUI, per se.

Like Jessie and later versions, it has a GUI as part of it, but it is the OS, just like Jessie and later versions.

And, just as in those other versions, it comes in both a full and a lite version. You can download either one.

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 8:23 pm
by bensimmo
Wheezy is two Debian versions before Stretch. (Jessie being the one in the middle we have just moved from).
If you come from a Windows background. It's like running Windows 7 instead of windows 10 (with Windows 8 in between).


You'll need to work around and figure out the new methods unfortunately, or fine an up to date tutorial.


The Pi model you have changes nothing with respect to the method you use on serial devices.

Type
sudo rapsi-config

Start a new Topic and ask for help with your project, give a link to the one you are trying to follow.


As for wheezy, unfortunately it doesn't work on the Pi3 from the image. You'll need a mid 2016 image for a nicely working Pi3 image.
But that Jessie and also will not have the init part.
(Iirc)
http://downloads.raspberrypi.org/raspbian/images/

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 8:47 pm
by bensimmo
These may or may not be of use as I've not used MIDI over UART.
It is on Jessie, so one Raspbian version older :-( but they tend to be the same/similar.

Fluisynth
https://lucidbeaming.com/blog/running-f ... pi-zero-w/

MIDI talk.
viewtopic.php?t=183724

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 10:04 pm
by PianoPCJ/A.F
bensimmo wrote:
Sat Feb 17, 2018 8:23 pm
Wheezy is two Debian versions before Stretch. (Jessie being the one in the middle we have just moved from).
If you come from a Windows background. It's like running Windows 7 instead of windows 10 (with Windows 8 in between).


You'll need to work around and figure out the new methods unfortunately, or fine an up to date tutorial.


The Pi model you have changes nothing with respect to the method you use on serial devices.

Type
sudo rapsi-config

Start a new Topic and ask for help with your project, give a link to the one you are trying to follow.


As for wheezy, unfortunately it doesn't work on the Pi3 from the image. You'll need a mid 2016 image for a nicely working Pi3 image.
But that Jessie and also will not have the init part.
(Iirc)
http://downloads.raspberrypi.org/raspbian/images/
and how can I start a new Topic?

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Feb 17, 2018 11:53 pm
by DougieLawson
sudo raspi-config in an LXTerminal window runs a configuration program.

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sun Feb 18, 2018 10:08 am
by bensimmo
Hit the New Topic button in a forum section.

Here's the Sound & Multimedia section
viewforum.php?f=38

/etc/inittab not present in Raspbian

Posted: Sat Dec 29, 2018 2:00 am
by phill38
:( hello every body
new here and new on raspberry pi
i try since some days to make configuration for a GPS on the raspberry
nothing run
i just receive my RPI GPS Add-on V2.0 and follow many links
like this one : https://github.com/mcauser/Raspberry-Pi ... GPS-NEO-6M

when i edit by
sudo nano /boot/cmdline.txt
and change the line by
dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait

after reboot
My PI MEGA BUGG, do not start, if need a pict of this bug
i have to replace the line by
dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait

after if i follow the next step
sudo nano /etc/inittab
My PI said " inittab " no exist

i have not enought knowleges

i need you to RUN a GPS on my PI
please your help will be greate

best regards philippe

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Dec 29, 2018 11:41 am
by bensimmo
Start again, you don't need to edit anything with USB. (You are following Serial UART setup)
Oh and we are on Raspbian Stretch OS now .
Just plug in, wait a bit.
Then check if
lsusb
Show the usb as a Ublox or an serial adaptor (either way it should work)

use
cat /dev/ttyUSB0
or
cat /dev/ttyACM0

You should see NMEA streams.

If it sees it as UBlox then there is a good chance gpsd is now also setup and running.
You should be good to go.

Re: /etc/inittab no longer present in Raspbian Jessie?

Posted: Sat Dec 29, 2018 11:43 am
by bensimmo
Do you have a link to the product you bought.
Also I would start a new topic as this is a thread using an old OS version with a problem from an even older OS than that.

The one you mention isn't USB, not sure where I got that from

Anyway, always start a new topic as the post above your say to do.

Use Raspi-config to enable the serial port, but disable the console.
Reboot.
That's it.

Use /dev/serial0 as the "port"
That is assuming there is no other things on that HAT, if so then send ITEAD an email for help.