jbernardo
Posts: 6
Joined: Sat Apr 04, 2015 6:16 am

Removing systemd on Jessie

Tue Sep 29, 2015 3:57 pm

Hi,
We've been told several times that systemd isn't mandatory in Jessie, however I am finding it very difficult to remove while keeping the functionality of wheezy.
I've followed the "generic Debian" guide on how to remove systemd from jesse, but I get hit by two issues:
1 - boot pauses several seconds with "waiting for /dev to be fully populated". This doesn't happen when I have systemd installed.
2 - I am unable to install polkit-1 and upower, the first one "has no installation candidate", the second "is not available, but is referred by another package".
I've tried using both "http://ftp.debian.org/debian/" (installing debian-archive-keyring) and "http://mirrordirector.raspbian.org" in /etc/apt/sources.list.d/wheezy.list, but always had the second issue. And of course, the first issue happens 100% of the time.

Any idea on how to fix these two issues, or should I assume that systemd is unfortunately unavoidable in raspbian/jesse?

PS: I don't want to start a flame war and don't need or want the claims that systemd is perfect and I should just use it. I've tried for nearly three years, and ended up by removing arch linux from all my machines this summer to get rid of systemd, for several reasons. I asking because we were told, in these forums, that systemd isn't mandatory in Jesse, so I assume that there should be a way to remove it without breaking the whole system.
Mit der Dummheit kämpfen Götter selbst vergebens.

diederik
Posts: 391
Joined: Wed Mar 26, 2014 11:17 pm

Re: Removing systemd on Jessie

Thu Oct 01, 2015 12:30 am

jbernardo wrote:I've followed the "generic Debian" guide on how to remove systemd from jesse, but I get hit by two issues:
1 - boot pauses several seconds with "waiting for /dev to be fully populated". This doesn't happen when I have systemd installed.
2 - I am unable to install polkit-1 and upower, the first one "has no installation candidate", the second "is not available, but is referred by another package".
You won't be able to fix the first issue, because systemd starts things in parallel and is thus faster.
Regarding the second issue, I would remove the section with "Package: *systemd*" from your /etc/apt/preferences.d/systemd file.
AFAIK there are various programs which depend on a library with "systemd" in its name (like libsystemd0) but have no dependency on systemd itself. That setting seems overly jealous.

jbernardo
Posts: 6
Joined: Sat Apr 04, 2015 6:16 am

Re: Removing systemd on Jessie

Thu Oct 01, 2015 5:24 pm

You won't be able to fix the first issue, because systemd starts things in parallel and is thus faster.
Regarding the second issue, I would remove the section with "Package: *systemd*" from your /etc/apt/preferences.d/systemd file.
AFAIK there are various programs which depend on a library with "systemd" in its name (like libsystemd0) but have no dependency on systemd itself. That setting seems overly jealous.
The first issue is not directly related to systemd starting things in non-deterministic parallel fashion, even if it probably is hidden by it. The "waiting for /dev" does not happen in wheezy, and does not happen in debian/x86 without systemd. It only happens in raspbian when you remove systemd. There is a possibility it is a bug introduced with the move to systemd and that it is not visible, because, as you said, systemd launches think in parallel and you don't see the wait.

As for your suggestion, it is known that too many packages are linked to libsystemd0. I have 'package "systemd*"' without a starting '*' , as it is also suggested on the wiki I linked.
Mit der Dummheit kämpfen Götter selbst vergebens.

jbernardo
Posts: 6
Joined: Sat Apr 04, 2015 6:16 am

Re: Removing systemd on Jessie

Sat Oct 10, 2015 6:25 pm

Ok, this has now been fixed for my setup, thanks to this reply at raspberrystackexchange.com:

Edit /etc/udev/udev.conf and change from:

Code: Select all

#udev_log="info"
to

Code: Select all

udev_log="err"
I've now upgraded my openvpn box to Jessie and it is working without any issues and without systemd.
Mit der Dummheit kämpfen Götter selbst vergebens.

User avatar
psergiu
Posts: 223
Joined: Mon Nov 07, 2011 8:36 am
Location: TX, U.S.A. (was: RO, E.U.)
Contact: Website

Re: Removing systemd on Jessie

Fri Aug 10, 2018 12:24 am

Almost 3 years later and the same trick also works on Raspbian/Debian 9 stretch with systemd removed.
Add a line with:

Code: Select all

udev_log="err"
in /etc/udev/udev.conf
and the annoying ~2 min boot delay is gone (and the Pi boots faster with sysvinit than with systemd).

n67
Posts: 938
Joined: Mon Oct 30, 2017 4:55 pm

Re: Removing systemd on Jessie

Fri Aug 10, 2018 12:53 am

(and the Pi boots faster with sysvinit than with systemd).
I thought the whole point (and the main selling point) of systemd was that it booted faster than sysvinit. At least that's what everybody claims...

Without that, what have you got?
"L'enfer, c'est les autres"

G fytc hsqr rum umpbq rm qyw rm rfc kmbq md rfgq dmpsk:

Epmu Sn!

J lnacjrw njbruh-carppnanm vxm rb mnuncrwp vh yxbcb!

Return to “Raspbian”