Page 1 of 1

Update function

Posted: Sat Jul 21, 2012 7:35 pm
by sheriff076
Hello,

I was using Arch until the launch of Raspian and have a couple of questions to ask the forum.

Does either apt-get update or apt-get upgrade upgrade the firmware for the Pi. Like pacman command does under Arch? If not what should I be doing to ensure I keep my Rasbian firmware up to date?
On another note Ive got a wifi dongle from the supported hardware list but I don't clearly understand what I need to do next on Raspian to get the dongle working. There countless forum entries and sites offering help but to be honest I could do with good pointer that covers a novice using Rasbian.

Thanks in advance.

Re: Update function

Posted: Sat Jul 21, 2012 8:02 pm
by gidoca
No, if you want to update the firmware and kernel, you have to use the following command:

Code: Select all

rpi-update

Re: Update function

Posted: Sat Jul 21, 2012 8:22 pm
by plugwash
The answer is it depends on what image you are using.

The foundation's image has packages installed and a repository configured for the Pi firmware/kernel. So on these apt-get update followed by apt-get upgrade will update the firmware/kernel just like it updates other stuff.

Most other images however are not using packaged versions of the firmware/kernel so you will need to use rpi-update on those.

Re: Update function

Posted: Sat Jul 21, 2012 8:47 pm
by sheriff076
Hello and thanks,

I'm using the Wheezy Raspian image available from the download page so i can rely on update and upgrade commands to keep me updated. If i follow your post correctly.

Re: Update function

Posted: Sat Jul 21, 2012 8:49 pm
by plugwash
Yes,

Remember update downloads updated package lists while upgrade actually upgrades stuff. You need both.

Re: Update function

Posted: Sun Jul 22, 2012 7:40 am
by thurgold
In an effort to get video4linux working, used apt-get to download version 3.2 of the kernel.
apt-get seems to have place all the version 3.2 files, but the system still boots into 3.1.9+.

I have seen posts indicating that raspberry pi is incompatible with boot loaders, so what do I need to do to actually upgrade the kernel being used? All the debian help files I can find just say to use apt-get, but since that does not work, I could use some suggestions on what the process is for raspberian.

Re: Update function

Posted: Sun Jul 22, 2012 9:57 am
by jui-feng
If you installed the package linux-image-3.2.0-3-rpi, that is currently alpha and not considered to be stable enough for daily use (and I think it's not quite up-to-date with foundation kernel patches).

See this thread for details. The third post says how to boot the kernel. (You could also rename the kernel image, but I think that the third post has a better method.) http://www.raspberrypi.org/phpBB3/viewt ... =66&t=9486