hleung168
Posts: 1
Joined: Thu Jul 19, 2012 5:55 am

USB flash drive Error

Thu Jul 19, 2012 5:57 am

After I booted up, I insert a USB drive and open file manager
I can see my drive, but if I try to access it, it would say "Error not authorized"
Any suggestion?

User avatar
mpthompson
Posts: 620
Joined: Fri Feb 03, 2012 7:18 pm
Location: San Carlos, CA
Contact: Website

Re: USB flash drive Error

Fri Jul 20, 2012 6:07 am

I've seen this issue myself when using 'startx' at the command line to start up X windows. However, if I enable the Pi to start an X display manager so I can log in through a graphical interface the "not authorized" issue goes away. Presumably the display manager configures some things that aren't done when using 'startx'. Unfortunately, I'm not familiar enough with X desktops to suggest a fix beyond perhaps enabling a graphical login via X.

Theremin
Posts: 1
Joined: Wed Aug 01, 2012 10:21 pm

Re: USB flash drive Error

Wed Aug 01, 2012 10:41 pm

I know I'm late, but I just encountered the same error and found this thread while searching for a solution.
This blog suggests a workaround which worked for me.

I just ran

Code: Select all

usermod -a -G plugdev 'username'
and after that all my flash drives and external HDDs has been recognized and auto-mounted by my file manager.

Disclaimer: I know very little about linux in general and I have no idea how good this is as a workaround, all I know is that it worked for me.

Return to “Raspbian”